13.2 Installation Failure

I’ve just downloaded 13.2 64bit and written it to a USB stick in order to overwrite 12.2 (ie. installation and not upgrade). All seemed to install OK but when the system rebooted the KDE desktop looked OK until I noticed there was nothing on the toolbar tray at the bottom. Actually if I placed the cursor in the bottom left I could bring up the panels only partially. When I opened other panels the fonts were huge and/or small and unreadable and basically it was all screwed up and un-useable. I need to take a step back and verify the download. I didn’t so this originally I was slightly confused by the instructions.

I first downloaded the .iso file using direct link and then downloaded the .iso.meta4 file using metalink to the same location using Firefox with the DownThemAll add-in. I didn’t get any confirmation that I’d downloaded the iso correctly. Should I have done the .iso.meta4 download first and then the .iso to the same location. What should I expect in terms of verification. The iso image was just over 4.4Gb in size so I’d assumed it was probably OK. I suspect I’ve still got the problem above but I need to rule out a duff .iso first.

Any help much appreciated.

Ian

Boot up with DVD disk / stick and look at the options in front of you and pick Check Installation Media.

I normally pick the Direct Link option and use Firefox’ own download manager.

Is there any chance that you have Nvidia graphics?

My “Nvidia” box behaved about how you describe, when using the “nouveau” driver (default open source driver for Nvidia cards).

I don’t think that works with a USB stick. As far as I know, it reports bad, even when it is good.

My normal practice is to find the meta4 link, and copy that to the clipboard in firefox.

I then open a terminal window, and run


aria2c -V "the copied link goes here"

However, you first have to install “aria2c” to use that method. This way, I can continue to use the browser for other activity while the download proceeds, and I don’t have to worry about accidentally closing a browser tab and breaking the download halfway through.

It is my understanding that, with “DownThemAll” and firefox, using just the metalink should download the full iso and verify the download as it proceeds. However, I have not tried that.

I do have Nvidia graphics (Nvidia geforce 6600gt video card). It worked OK with 12.2 but I seem to remember I had to do something to it as I was getting a cheqerboard pattern on the screen intially. How do I go about loaded an appropriate driver?

Ok I’ll try that.

That was my understanding but it just downloaded the meta4 file and that was it.

Login to “Icewm”. You can choose that on the login screen. It will probably work out okay.

Choice 1: Edit the file “$HOME/.kde4/share/config/kwinrc”. Look for the “[Compositing]” section header. If there is a line “Enabled=true” then change that to “Enabled=false”. If there isn’t a line, then add it to that section (as “Enabled=false” without the quotes). That disables Desktop Effects. KDE will probably work that way.

Choice 2: Add the Nvidia driver.
Yast –> Software Repositories.
Click Add.
Select “Community Repositories”
Select the Nvidia repository.

Then Yast –> Software Management
Search for Nvidia
I think you need the G02 driver for that card, but I could be mistaken. You will need to decide which driver you need. You will want the “kmp” driver that matches your kernel. I’m using the “desktop” kernel. The command “uname -a” will tell you which kernel you are running. You probably also want other G02 packages that do not contain “kmp” as part of the name (or G03 package if those are correct for you).
Once the Nvidia drivers are installed, reboot to start using them. Thereafter, all should work including desktop effects.

Not sure what you mean by login to ICEwm. Remember I can’t use the desktop. I can’t even bring up a konsole. How do I login to a linux prompt so I can have a go at loading the driver as you suggest above.

I’m assuming that you at least get a KDM login screen.

On that screen, there’s a tool (wrench, spanner). It’s at the bottom left. Click on that and select “Icewm”. Then login. You will probably get a usable session, since Icewm put low demands on graphics.

If you cannot do that, then the other alternative is to boot with “nomodeset”.

On the grub2 boot screen, hit the “e” key. That should show the boot command. Scroll down until you find the line that begins “linux” (it might be “linuxefi”). Hit the END key to get to the end of the line. Add " nomodeset" to the end. Then hit the key to continue booting (it will tell you on the screen).

That should boot you into a usable session, where you can add the Nvidia drivers.

Logged in normally and managed to load in the nvidia repository through a partial window using
**zypper ar -f ftp://download.nvidia.com/opensuse/13.2/ nvidia **

logged in as root using Icewm and opened an Xterm
**lspci | grep VGA ** returned ----> compatible controller : NVIDIA Corporation NV43 [GeForece 6600 DT] (rev a2)

zypper install x11-video-nvidiaG02 returned ----> Timeout exceeded when accessing 'ftp://download.nvidia.com/opensuse/13.2/repodata/repomd.xml

and it fails time and again. Probably haven’t got an internet connection through Icewm.

I’m struggling now.

Ignore my last post. I’ve now got it sorted. Thank god for that I was seriously considering giving it a swerve and loading ubuntu >:(

Okay. You are probably setup to use NetworkManager.

Then try with “nomodeset”. You should then be able to login to KDE with low quality graphics. But that will enable you to setup a WiFi connection and then install the Nvidia driver.

Well I thought I had it sorted out but not really. Logging in as root seems to work OK and all seems to be working through wired internet but I noticed Network Manager isn’t running so I haven’t got wireless working yet but I’ll try and sort that out later. Logging into my account the KDE fires up but with the previous session and bits of window all over the place (ie. unuseable still). Why does it seem to work OK as root and not as my non-admin account. Obviously I need to log in as root to load the repository and install the video driver so why doesn’t my non-admin account pick the driver up?

Off to work now so I’ll check back in when the boss isn’t around.

You should never log into a GUI as root. You can inadvertent break stuff. It is safe to log in as a user and become root but never log in as root!!! I suspect that your confusion come from using auto-login. You don’t see a login screen then

DO you know how to boot to a terminal???

No, I didn’t know you shouldn’t log in as root. If I log in as root through the su command, surely I can break stuff just as well as logging in as root from the start??

I’m running 13.2 alongside windows and I get the option of booting to windows or linux(default) when I switch the PC on. I’m not sure how to boot to terminal as I just have the normal login screen with the various login options selected from the bottom left hand corner. If I select Icewm then I do get a linux prompt but the keyboard isn’t mapped properly. eg the ~ is the | and the @ is " etc. so it tends to make stuff difficult.

Not the same thing. You are temp root with su command and your GUI is not running under the full root permissions If you log to a GUI as root just looking around the machine can cause a change in ownership of certain files and that will make it impossible to log a user on with out fixing the ownership. Best practice is do not log in to a GUI as root. There is nothing you need to do in a root GUI all can be done with su as a regular user.

Ok so if you get to a GUI log in you can move to a terminal by pressing CTRL-ALT-F1 (or F2 F3 etc. Note that F7 is the terminal reserved for GUI)

Now log in as root ( it is fine to log in as root in a terminal it is GUIs that cause the problems)

You can then run yast in terminal mode and install the drivers or use zypper. You need to uninstall the GO2 drivers

You will probably need the GO3 drivers ( note that consists of 5 packages all with GO3 in the name and 2 of them will have the kernel name which if you did not change anything is desktop. DO NOT INSTALL ANY OTHER NVIDIA package. Mixing packages is bad (like crossing the streams)

I have found that the NVIDIA web site is not always correct on which card works with which driver. particularly when it says 2 different versions.

Ah. Thanks for that. Useful stuff. My video card is a nvidia geforce 6600 gt which looked like it needed the G02 driver but I’ll defer to your suggestion. OK. So how do I remove the G02 driver that I already installed using zypper? How do I find out what the name of the 5 packages are and is it just one that I need or do I need them all? I don’t know if I’ve screwed anything up by logging into root and as I’ve only just installed it then it’s no big deal to start again.

Well, IMHO it is nonsense that you should never login as root to a GUI.
Yes, you can break your system, but you can do that while running programs as root in a user’s session as well.
Yes, there are security issues, yes there are good reasons not to do it, but at least to test things I see no problem with that.

And no, just logging in as root, will NOT break your system.
In fact it’s more dangerous to run applications as root in your user session, as exactly then they could change the owner of your files in your home directory to root if the environment is not set up correctly.

Root is a user like any other with its own home directory (/root), why should logging in as root break different user’s files?
Linux is a multi-user OS after all. Logging in as root does not touch your user’s files at all, just like logging in as any other user will not touch/change your user’s files.

My video card is a nvidia geforce 6600 gt which looked like it needed the G02 driver but I’ll defer to your suggestion.

No!
The GeForce 6600 is indeed only supported by the G02 driver. Installing the G03 driver WILL NOT WORK!

Have you ever tried to boot to “recovery mode” (“Advanced Options” in the boot menu)?
If that works, please post the file /var/log/Xorg.0.log.old while in recovery mode.

That it works as root may indicate it’s some permission problem though.
Try to add your user to the group “video”. This should not be necessary, but will workaround the issue if for some reason your user will not get direct access to the graphics card.

And please post what exact nvidia and kernel packages you have installed now:

rpm -qa | egrep "nvidia|kernel"

kernel-desktop-3.16.6-2.1.x86_64

and I can’t print the contents of the /var/log/Xorg.0.log.old file. The icon is a recycle symbol with a + in the corner and requires additional software to open it. When I select the option to go and look for additional software it doesn’t move off 0% on the progress bar. I can print the Xorg.0.log file though but guess you don’t want that.