13.2 doens't remember wireless password

I installed 13.2 on my laptop, worked well from the start except for wireless - network manager doesn’t remember the password for the access point, so I have to re-enter it every time I resume from suspend. Anyone know how to fix this?

Tell us which desktop environment you’re using.

Using KDE. I kept my home directory from 13.1 installation, just installed 13.2 to a separate / partition.

I did check the wicked.service mentioned in the release notes, but that’s unknown and
systemctl is-active network.serviceshows as ‘active’.

Are you using kwallet? (ie is it enabled/running?)

No, I’ve never used kwallet. Is that now a requirement?

No.

Are these system connections? (ie is ‘All users may connect to this network’ set?)

Ah, I see now - I was confused because the network manager doesn’t show up on 13.2 when you right-click the network icon, but left-clicking the icon brings up a panel with a tool icon in the upper right that brings up “Connection editor”. Editing the connection and setting the password there saves it for reuse.

The connection was already set to “Automatically connect…”

So… all good now? :slight_smile:

The wireless management seems quirky to me. The approach that seems to work for me when accessing a new connection I want to have remembered is:

  1. Click on wifi icon in taskbar to bring up list, click on the connection I want, enter password and connect (if I stop here I have to reenter the password every time I connect)
  2. Click on wifi icon in taskbar to bring up list, click on wrench icon at upper right to open Connection editor, select connection and Edit
  3. Enter password again in Wireless Security tab and click OK

After going through this process wifi will automatically connect whenever it’s in range.

It’s been a while but I recall this quirky behaviour when using the KDE NM front-end (KDE 4.14.x) too. :slight_smile:

While that person managed to figured a workaround, the underlying issue remains. Under normal use condition, without kwallet, passwords are not saved for wifi by default. nor is there a convenient checkbox for saving them.
I came across the same problem, and then this thread while searching for a solution. this could definitely be improved

Done all that (and several times previously), but I still have to enter the wifi password and KWallet password every time I log in. The connection manager has the correct password in the wifi security section, but it just doesn’t seem to want to use it - and why is it asking KWallet to store the password?. I’ve tries deleting the wifi entry from connection manager and the associated entry from KWallet, but it just resets from scratch again and back to square one with having to enter two passwords on login. :\ Never had any trouble with Network Manager on 13.1 & before . (Running KDE with all current updates applied)

Didn’t it always do so? At least by default?
It’s much safer to save it in KWallet than as plaintext in a config file…

Configure the connection as “system connection” (“Allow other users to connect” or similar) and KWallet will not be used. This will also connect during boot already, making it possible to use the connection even in text mode…

If you’re annoyed by having to enter KWallet’s password on login, just give it an empty one… :wink:

Thx - having ‘all users’ checked (needing root access to save) seems to have worked and has now auto-connected without having to enter any password for wifi or KWallet - before I was having to give both. We’ll see if this sticks…

Previously, KWallet wasn’t used, though I’ve no idea where the password was stored - it always ‘just connected’.
Having to enter the KWallet password every login would be tiresome but do-able; what was really annoying was having to enter* both* on every login :. Having an empty KWallet password wouldn’t have been wise for other uses.

Previously there was an option to not use KWallet, but store the password in plaintext in the config file, yes (the default was to use KWallet though).
But this option has been removed (or rather not reimplemented on purpose, as the new applet is basically a complete rewrite).

Having to enter the KWallet password every login would be tiresome but do-able; what was really annoying was having to enter* both* on every login :. Having an empty KWallet password wouldn’t have been wise for other uses.

Well, either you use no password for KWallet, or you have to enter its password to open it. That’s the purpose of the password, no?
Of course you shouldn’t have to enter the wireless password as well if it is stored in KWallet. Maybe there’s a timeout because you had to enter the KWallet password?
There is a bug report about this:
https://bugzilla.opensuse.org/show_bug.cgi?id=909683
And apparently this should be fixed in the latest plasma-nm version.