[13.2] Can't play AAC music. What do I need to install?

I am unable to play my music right now (AAC - purchased from the iTunes music store).

I did a search and found what I thought would be the answer, which was adding the “Packman” repo, and I clicked the “switch system packages to the version in this repository” button under software management in YaST.

I also installed faad2 (no idea if that was necessary or not)

Anyway, I still can’t get Amarok or VLC to play my music. Any thoughts on what else I need to do?

sounds like a drm issue to me, I don’t think apple supports Linux if it does it’s the place to ask
you need the drm-ed files corresponding keys, try this FAQ
http://all-streaming-media.com/streaming-media-faq/faq-playing-DRM-protected-m4p-AAC-Apple-iTunes-files.htm

what happens when you try to open them with vlc?
you can try running vlc in a console and see it’s output.

As far as I know, Apple no longer has any DRM on the music from the iTunes store, and the music I have was purchased after they made this change so it shouldn’t have any DRM.

I have a couple of albums I ripped myself into AAC, I didn’t think to try them yet. The link looks interesting and I’m going to look into it a little more.

You need to install the package vlc-codecs. That’s not installed automatically if you do a full switch to Packman.

AACs should play fine in VLC and most other players, at least if they are not DRM protected.

Thank you for your help.

I think I managed to get a bunch of the packages from different repos mixed up. I ended up reinstalling my system and followed the directions in the “Multimedia in One Click” thread, and now my music is playing just fine (first link on the forum and I didn’t actually see it before posting).

You really did not have to reinstall. You just switch vendors to packman. Yes you can mix things but a vendor switch will normally bring everything into line.

I know you’re right, but after switching everything back to the default repos, the software management tool said it had to download over 700 packages and given that this was a brand new clean install anyway (first attempt at running Linux on my laptop), I figured it was easy enough to just start over.

700 packages?
What repo did you add, Factory/Tumbleweed?

In that case you would have had to switch back to the standard 13.2 repos too.

I play AACs with dragonplayer (KDE) without adding additional codecs.

I do not have VLC installed.

You definitely need to install additional codecs to play AACs.

But dragonplayer uses Phonon (KDE’s multimedia framework), which in turn uses either gstreamer or VLC.
If you have the codecs installed for those, you don’t need to install anything additional for dragonplayer any more of course.

From packman, is ffmpeg and gstreamer’s ffmpeg plugin installed? If not, try that.

ffmpeg is not needed (only the libav* libraries).
And “gstreamer’s ffmpeg plugin” has absolutely no influence whatsoever on VLC, and on Amarok only with the phonon-backend-gstreamer…

Btw, the ffmpeg plugin is only available for gstreamer-0.10.
For 1.0 there’s only gstreamer-plugins-libav, which contains its own static copy of libav, a fork of ffmpeg.

I never said it did, and I use the gstreamer backend. My AAC works fine on various players, and I know I had to add an ffmpeg related package originally before playback worked, but not sure which one. Did you mention beforehand what codecs were required and what source, maybe I missed it?

But the question was about VLC, and that doesn’t have a gstreamer backend… :wink:

Did you mention beforehand what codecs were required and what source, maybe I missed it?

Well, yes, vlc-codecs from Packman.
And if you use phonon-backend-vlc, that applies to Amarok too.

For gstreamer, gstreamer-plugins-libav should work (there is no ffmpeg plugin for gstreamer 1.0 as mentioned).
There’s a specific AAC plugin too in gstreamer-plugins-bad-orig-addon.

But the problem seems to be solved anyway already.

The OP also mentioned Amarok (BTW both work here)

SMPlayer is telling me the audio codec used is “ffaac-FFmpegAAC (MPEG-2/MPEG-4 Audio) [aac]”.

The repos I added to the stock 13.2 were:

  • X11:bumblebee (I’ve got Intel/nVidia hybrid graphics)
  • packman-essentials and packman-multimedia (from this page: Additional package repositories - openSUSE Wiki)
  • home:derselbsts (to install faad2 - didn’t know if I needed it but it says it’s an AAC decoder which on the surface sounded like something useful)

I vendor switched and updated my packages. When I still couldn’t get it working, I posted here. I finally noticed the “One Click Multimedia” thread which added another “Packman” repo. This new Packman repo didn’t work either, and I figured that if something like this was pinned as the first thread on these forums, it was going to be my system that was at fault.

I vendor switched everything back to the stock 13.2 repos and carefully went through the conflict warnings… when everything started going I had 717 packages to update.

“Packman” sounds like the all-of-packman repo which includes the other two you mentioned. I really only want Packman for multimedia, so I stick with your previous two. You don’t now have three packman repos, i.e. duplication, right?

Correct. Right now all I have is what was added when I followed the directions in the “One Click Multimedia” thread and everything is working.

SMPlayer is a completely different beast again, and uses neither vlc-codecs nor gstreamer.
It’s just a frontend to either mpv or MPlayer, which come with all codecs included because they are not included in the distribution anyway…

faad2 is available from Packman too. You should rather use that versions… (and remove this repo if that was the only reason to add it)