13.2 Beta (KDE) - Touchpad not working

Hi Everyone,

I tried installing the Beta release (KDE) earlier in my Lenovo G50 laptop.
All of my hardware (I think) worked fine after the initial installation, which is great.
I updated the OS via YaST, installing all suggested packages then restarted my system.
And then the issue started… My Touchpad stopped working.
I tried installing synaptiks, but it didn’t resolve the issue.
The touchpad is actually working in the Login/Switch user screen, but once KDE is loaded, the touchpad would stop working.
Any help is much appreciated

You can disable the touchpad daemon and see if it helps.


Hey jetchisel! Just tried it and it worked! :smiley:
Great!! Thanks very much, man!

Glad you have it working now.
Now the question remains, how did you broke it? lol!

lol that, I am not sure of. Like I said, it was working fine after the fresh install but stopped working after I updated using YaST. I don’t remember doing anything else to break it :stuck_out_tongue:

But yeah, thanks again :slight_smile: