13.1 triple boot (GRUB2) no longer boots to GRUB: Linux inaccessible

I have 2 HDDs on AMD desktop: sda has Win 7 (64bit), sdb has a small MSDOS partition, the remainder being OpenSUSE 13.1. Booting is via GRUB2.
Win 7 threw a wobbly and demanded repair before booting. Thereafter, both HDDs boot directly to Win7. I can see the Linux partition(s) using KDE 4 Live DVD, but cannot boot it. I suspect Win7 has messed up something (MBR?) of sdb, but have no idea how to repair it.
My Win7 HDD now seems to have a new partition "System reserved (E:) " which I assume has resulted from the “repair” process.

I am reluctant to reinstall 13.1 from DVD, as updates are unavailable (unless you know better), as are some files needed for video editing that I managed to find.

How can I restore my system? It has worked perfectly for a couple of years until yesterday.


Would try this:


Thanks. Just one problem: the Rescue Mode of the DVD asks for a login & password. Unsurprisingly, my login for the HDD installation does not work. It may seem very stupid, but I have not needed to use Rescue previously, so am completely flummoxed how to proceed.

Try “root” as the login name. And there should not be a password in that case.

There is also a “supergrub” CD that can supposedly boot many linux systems.

Many thanks!
That has worked. My system appears to be as before (save for the superflous “System reserved” drectory in Win7 - I shall refrain from tinkering with that).

Panic averted, thanks to your expertise. Unfortunately, there are still a few things that I have to do with Windoze, else I should dump it.