13.1 rc1, wrong grub2 installation when booting from raid volume

I have Installed opensuse 13.1 rc1 on a raid 1 volume and i’ve experienced a problem with grub2 which has not been correctly installed on both the disks MBR. I know very well this problem which is present since opensuse 12.2.
I have opened a bug on it (https://bugzilla.novell.com/show_bug.cgi?id=811830) and discussed about it on the forum (https://forums.opensuse.org/english/get-technical-help-here/pre-release-beta/483476-failed-installation-md-raid-opensuse-12-3-rc1.html).

I’m very surprised that the bug is still present in 13.1! (it is classified as “Major”)

Yes, installer defaults to installation on the MBR of the first disk. I’m not convinced it is a bug - as with any default you will always find someone who thinks default has to be different. The real problem in bug you quoted was that installer did not even detect that RAID1 was present and that is fixed in 13.1.

When you install on RAID1, you need to go into bootloader settings, verify that “Enable redundancy” (not exact name) is checked and confirm with OK - not Cancel! Here is the second bug - this field is checked even though it is internally disabled until you press OK. So it is misleading. See https://bugzilla.novell.com/show_bug.cgi?id=842919.

Probably installer should expose redundancy setting on summary page to avoid confusion.

thank you for signaling this bug which is for sure strictly connected to the one I quoted! I’ll have a look to the bootloader settings interface hoping to find this “Enable redundancy” and see the effect it has if checked. Honestly during the first test installation i didn’t notice it.
I’ll let you know the result of course

I tried to install 13.1 rc1 again using an md raid 1 volume for boot and root partition, but i didn’t see any “enable redundancy” option coming up during the whole installation process. I opened every possible windows of the yast installer…

you need to do this after install.
during the initial install it does not work.
after you boot the system for the first time (after all auto configuration is done and all)
you go to Yast /bootloader remove the boot loader first
and than go back and add the boot loader , this will give you the options to enable redundancy and should install it on both disks of the Raid.
in my experience(Os 12.3) it did not always worked. maybe it was fixed in 13.x

It works during install. You need to go into Bootloader from summary page and simply confirm with OK.

I did a further test, going into bootloader settings from the summary page as you suggest, but i can’t see any “enable redundacy” (or similar) option in the menu. I hit ok and the installation process ended regularly. Grub2 was installed only on the mbr of the first disk. No way to change this. No option to install on both mbr are present even in the yast configuration center after the installation.

The problem is still present in 13.1 final release.
The yast installer does not install grub on the second raid device leaving the system not bootable if the first disk has failed. No “Enable redundancy” options are available during installation or in yast after the installation.
Furthermore 13.1 introduces a new bug which further complicates the management of a failure situation: when the system boots with only one of the two disks composing the raid systemd cannot complete the boot sequence and no emergency shell comes out!!!

I think this is a different bug and i’ll further investigate prior to open a new bug. Have you ever had any similar experience ?