13.1 on a new HP Pavilion 15: No KDE

OK, this is an HP Pavilion 15 with AMD Radeon HD 8330 video. I installed 13.1 from the full DVD download, not a Live install, resized the Windows 8.1 partition to make it fit.

First time we tried to install, it hung during the installation, no error messages, couldn’t abort. Had to hard reset the laptop with the power button.

Second time, it installed. No glaring UEFI issues (which had worried me), but we do have to use “nomodeset” in the GRUB args to make it boot.

When it boots, we get into a very plain jane desktop, a single little text window. Looks like twm or one of the other minimal window managers. If I mouse into that little terminal box and enter “startkde,” KDE will start and seems to be OK. I’ve checked:

  • an “lsmod | grep -i radeon” shows nothing. I’m obviously not using that driver.
  • the YAST->System->/etc/sysconfig->Display settings (I think that’s right) show that KDE and KDM are selected. Everything there looks fine, so far as I can tell.

I suspect that something got wonked during the install. The DVD checks good when I run the media test. Wonder if I should try installing one more time? Any ideas?

When you get to your login screen,
Click on the icon (IIRC it’s the gear icon?) to display the various desktop options.
Note that when you select any one, it becomes your default until you select another.

Try each and see if that resolves your problem.


That’s expected. Specifying “nomodeset” prevents the radeon driver from being used.

I would suggest to try removing “nomodeset” again and see if it works. Press ‘e’ at the boot menu, search for the line starting with “linux” and remove it there. Then press ‘F10’ to boot.
Note that this doesn’t save anything, so if there are problems just reboot.

Or install the proprietary fglrx driver (would be the better choice I guess).
See here f.e.:
openSUSE Lizards

But your KDE problem doesn’t seem to be graphics driver related. More likely the default desktop is set wrong.
Are you using Auto-Login? Then log out to get to the Login Screen
On the Login Screen, click on the wrench symbol and choose “KDE Plasma Desktop”

Or edit the file /etc/sysconfig/windowmanager and set DEFAULT_WM=“kde-plasma”.

And make sure that you have the package “kdebase4-session” installed.

The unit is configured to autologin, so I never get to that screen. Let me try disabling the autologin and I’ll see if I get that choice. I didn’t even think of that. :slight_smile:


– Stephen

Ctrl>Alt>Backspace gets you out of desktop and back to log in window.

But you have to press it twice

And every Windowmanager should offer a possibility to logout/exit as well.
Try clicking on the desktop with the left and the right mousebutton.

OK, folks, thanks for the help. I’ve got it working for now, but I do need “nomodeset” in the boot args, or I get a very ugly-looking kernel panic as soon as it tries to load the video subsystem. Apparently the FOSS radeon driver doesn’t agree with my hardware.

What was throwing me was the little terminal window. I should have realized it was a tiny window manager. So, I said, “duh” and just entered “logoff.” That took me to the login screen where I did indeed select KDE, then rebooted. It came up as expected.

For our next adventure, this weekend I’ll try installing the proprietary radeon driver(s). I remember I had to do that with my HP laptop at work. (The one I’m discussing here is my wife’s laptop.)

But I think we’re on a roll now. At least she can browse the Web and check email, so she’s happy. Once I get the graphics straightened out we can really go crazy. :slight_smile:

So, to summarize, if anyone should hit this thread in the future:

  1. I had to use “nomodeset” in the boot options.
  2. For some reason, the installer selected the twm, even though I had told it to use KDE. Whatever, who knows? :slight_smile:

I’m happy. Thanks again for the help.