13.1/KDE: window focus repeatedly "stolen"

it drives me crazy: repeatedly the focus is shifted a away from the currently active window every few seconds
irrespective of what I am doing. e.g. while I am typing a text.

changing in KDE settings the window behaviour (preventing unwanted activation) to none didn’t have any effect.

does anyone have an idea how I can achieve that an activated window stays active.

I tried that
but it’s nor working for me or I’m not able to do it properly.

the strange thing is that the problem appeared “suddenly”.
the system worked well for a while

Okay, I’ll guess.

This is a laptop with a touchpad. And while typing, your fingers lightly brush the touchpad which has tapping enabled.

My solution: Use a separate mouse, and disable the touchpad.

I have set “synaptiks” to start on login to KDE. And I configure “synaptiks” to disable the touchpad if there is another mouse. I’m currently using a Logitech M325 wireless mouse, which is small enough that it is usable on a laptop sitting on my lap.

I thought of that, but it also happens when I just watch the screen without doing anything, definitely not touching the touchpad

is there documentation somewhere for synaptiks?

Perhaps the touchpad is hyper-sensitive, responding to small air currents.

is there documentation somewhere for synaptiks?

If you run the program (it should already be installed), there is internal documentation.

As I recall, the way that I ran it the first time was enter it in the search line on the kickoff menu. Thereafter, it is remembered as part of my session and automatically starts. When running, there’s an icon in the tray (hidden) that you can use to get to its settings, or to tell it to quit. It’s harmless enough to try, and it should already be installed on your system.

switching of the touchpad via snaptiks didn’t have any effect

after another reboot the problem seems to have disappeared for the moment

a few reboots later the problem is back again!

does anyone have an idea in the meantime what could steal the focus?

another logoff/logon and it seems to work properly.

sounds to me like something in KDE/plasma is crashing (or not) during startup.

It’s uncommon enough to be a hardware problem, perhaps in the touchpad or keyboard controller circuit.

I’d try some extended testing with a liveCD, both KDE and GNOME or other DE. If the problem still happens, it’s probably hardware.