13.1 - 'Hanging at Search For Linux Partitions'

Just downloaded SUSE, seems to be hanging on the ‘search for LINUX Partitions’ option in System Analysis. The system is currently using WIN7, but I carved out a free partition on my HD (using WIN7 Volume Manager, about 300Gigs) that I intended to use for my SUSE Install. Can anyone tell me what to do? I found something online about setting the ‘no-apci’ option, but the install setup program that spawned couldn’t find the iso image on the CD-ROM.

Any help would be appreciated. Thanks!

This is often caused by a non-existing floppy drive. The BIOS tells the kernel that one exists though there is none, and the kernel then hangs when trying to access it.

Try to disable the floppy drive in the BIOS settings.

Or type “brokenmodules=floppy” at the boot options line at the installation DVD’s boot menu.
If there is no such line (i.e. typing characters doesn’t make them appear on the screen), press ‘e’, search for a line starting with “linux” and append “brokenmodules=floppy” at the end. Then press F10 to boot and start the installation.

On 2014-02-01 21:16, rally point wrote:

> I found something online about setting the
> ‘no-apci’ option, but the install setup program that spawned couldn’t
> find the iso image on the CD-ROM.

What do you mean? Are you perhaps trying to install from inside Windows,
clicking on something to install Linux? No, you have to boot the
openSUSE CD/DVD. at the very first window is where you type those options.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

And there is some more confusing wording here.

  1. You constantly talk about SUSE. But these forums are about openSUSE, not SUSE Linux Exterprise. So please check what you have. And please, when it is openSUSE tell us which version.
  2. You are talking about a CD-ROM, but current openSUSE versions are not installed from a CD, but from a DVD. The ISO is to large to fit on a CD.

The title of the thread says 13.1.

You are talking about a CD-ROM, but current openSUSE versions are not installed from a CD, but from a DVD. The ISO is to large to fit on a CD.

There is also the NET-install CD.
So you actually can install current openSUSE versions from a CD (although the packages are downloaded from the online repos then).

Well, apparently I just needed to be more patient! :slight_smile: It took awhile, but eventually it passed the ‘Search for Linux Partitions’ phase and EVENTUALLY the installation completed. I’d say it took about two and a half hours to finish the install. Not sure why it took so long, it was at the ‘saving bootloader configuration’ phase (93% complete) for about 45 minutes.

Ok, now I get to try and install Apache. Let’s see how that goes. Thanks for the help, sorry for sounding the false alarm.rotfl!

Well, that’s typical for that “non-existing floppy drive, but BIOS says it is there” issue.

See also here: https://bugzilla.novell.com/show_bug.cgi?id=773058

Yes, but the whole impression was (and still is) so confusing that I hesitated to draw any conclusion at all.

Thank YOU!!
I have an old Dell latitude C640, 1GB memory, 2.0GHz CPU, BIOS says something like none or not present for the floppy drive.

Wanting to experiment with openSUSE 13.1 GNOME to see if it would be quicker than KDE on an older box. The install program at “SYSTEM PROBING” would take a long time especially probing hard drive and the search for linux partition took a couple hours. the install would then come to a halt at about 75% and not go any further. I am basically on my 2nd day working on this install.

Thanks to your reply I typed in brokenmodules=floppy at the boot option line and the “SYSTEM PROBING” screen took about 30 seconds.

Install just rebooted and completed the automatic configuration.
Thank You

There is a bug in the kernel on 13.1 install BIOS must have no floppy checked. Even if the BIOS does not SEE the floppy there is a box saying that floppy is there If the box indicates a floppy and no floppy is present the kernel will take next to forever to look for that missing floppy. Alternatively you can use the **brokenmodules=floppy perameter **in the kernel line

Well, that doesn’t apply to every BIOS out there, just some.

I haven’t seen this on any of my machines, but I can reproduce it in VMware (not in VirtualBox though).