13.1 goes blank after reboot

I successfully burned a dvd iso (had previous issues) and successfully installed 13.1.

However there is a problem. I had it autologin so when it starts loading those icons which start by a hard drive icon until KDE icon. Well at that point the screen went blank.

I have seen another post where they were saying that it could be the autologin.

Once I logged out I could see again, however every time I login whether it is autlogin or not, at the point where the resolution is been fixed to fit my screen it goes blank.

I can run the recovery mode.

If I run the normal way, it will go blank however it is still factional, I just do not see ****.

Any ideas of what to do ?

I am not an expert but I have some idea.

Maybe you set an invalid resolution in KDE’s “Configure Desktop”? Try to remove the directory ~/.kde4/share/apps/kscreen/ to get the default.

If that doesn’t help, try to disable the KScreen2 service in “Configure Desktop”->“Startup and Shutdown”->“Service Manager”

Did you try booting from Advanced options - Failsafe?

Edit: please post some info on the system you’re running openSUSE on, specially videocard

It is an MSI laptop. A bit old.

I dont know exactly but I can check and tell you.

Now it works fine. But it sometimes doesnt.

I can tell you right now it is the MSI board. Their boards are complete ****. Take it from a former MSI owner get something different and the headache goes away. If you want to satisfy your curiosity run the Linux Firmware tests and watch what happens with MSI BIOS. I paid $35 for a brand new board from MSI and well you know the saying - you gets what you pay for. Had I spent just $30 more it would have saved me a pile of headache. From what I can see they have hacked a BIOS and it doesnt work.