13.1 gnome volume slider not working, pulseaudio permissions

Installed opensuse 13.1 64-bit on desktop (zypper dup)
With MY user, I don’t get a volume icon in the top right corner. The volume slider doesn’t have an icon next to it either.
The volume control makes the same loudness of a pop whether I slide it all the way to the left or right.
I don’t believe pulseaudio is starting.
If I try to start pulseaudio


$ pulseaudio
E: [pulseaudio] core-util.c: Failed to create secure directory (/run/user/1000/pulse): Permission denied

if I look at permissions


$ ls -l /run/user/1000/
total 0
drwx------ 2 craig users  60 Nov 21 22:18 dconf
drwx------ 3 craig users  60 Nov 19 18:06 gnome-shell
dr-x------ 2 craig users   0 Nov 21 22:13 gvfs
drwx------ 2 craig users  40 Nov 19 18:06 gvfs-burn
drwx------ 2 craig users 120 Nov 21 22:13 keyring-KezADb
drwx------ 2 craig users  60 Nov 19 18:06 krb5cc
drwx------ 2 root  root   80 Nov 19 18:39 pulse
drwxr-xr-x 2 craig users  60 Nov 19 18:06 systemd
lrwxrwxrwx 1 root  root   17 Nov 19 18:06 X11-display -> /tmp/.X11-unix/X0

if I change ownership


$ chown craig:users pulse

then run pulseaudio


$ pulseaudio
W: [pulseaudio] pid.c: Stale PID file, overwriting.
W: [pulseaudio] source.c: Default and alternate sample rates are the same.


If I then type Alt-F2 and then “r” to reset gnome-shell, I then get the volume icon in the top right
and I also get an icon next to the slider. Unfortunately this results in no audio.

My sound worked fine in opensuse 12.3. It works fine as another user and works fine on my 32 bit installation of 13.1 on my laptop.
any hints would be appreciated.

Nevermind I fixed it.

I added myself to group audio


su -
usermod -a -G audio <user name>

Then went to gnome settings, chose sound, and selected Analog Output
Now it seems to be working fine