13.1 - Fresh installed, and now i can't boot.

I am currently trying to add a Dual Boot through Grub using my everyday 1tb drive(which is my current windows 7 home premium)
and a 250g Toshiba drive.

I added the 250g drive earlier today, downloaded 13.1, burnt the iso, boot from the disk, did the partitions…
Boot 128m
Swap 2gb
/ (root) 20gb
Srv 2gb
Var 6gb
Home Remainder
(I’m not sure how valid this partitioning is. It is just what i was tought during class, and I am still using the notes i took.)

… After i did the Partitions, I started the installation and went to a relatives house for dinner.
By the time i returned home, the installation was complete, and it was on the green splash screen.

I thought to myself that it might still be doing something, so i went to the living room, and watched a movie (1hr 20min)
Came back and it was still there on that slpash screen.

I hit Del
and the following came up
“resume device /dev/sda1 not found (ignoring)”
then some random numbers and letters
and this “waiting for device /dev/root to appear … could not find /dev/root”

I rebooted several times praying that it would work and i wouldn’t have to find a workaround…
It did not, so i decided to do a re-install.

now when i go to installation from my disk, and get the partitions, there is no longer a SDA.
Only my SDB which is my windows drive is visible, so i cannot perform another fresh install on the SDA.

On top of that, Grub IS working. If i boot from hard disk, it takes me to the selection screen.
OpenSuse adv options
Windows 7

Windows 7 still works properly as far as i can tell.
But both Open Suse selections end up frozen on the splash screen, and when i hit Del, i get the same thing that i previously mentioned.

I went into the BIOS settings, and the 250gb drive is being detected, and the PC knows that it is a toshiba, But it does not list the data size.

I am trying to get this dual boot, for web development.
During the class i mentioned previously, we learned a wide variety of things.
From A++, html, and Programming, to Graphics, animation, and game design.

This is all irrelevant to the post though.

Please somebody help me get 13.1 working, or at least help me return my 250gb hardrive to a “Partition-able” state once again.

I am willing to help find more info if you need it!
But i will warn you that i am terrible with command lines, so I’ll need baby steps, to understand what you’re asking for.

Thanks for any Feedback!!

What video? Sounds like the video is freezing things. Try booting to safe mode

Pics of DxDiag
For specs


In the grub menu
Use the Advanced Options to use failsafe or add nomodeset

I do not see a failsafe option.
What is nomodeset?

I tried to unhook my windows drive, so that the linux drive was the only option.
Grub was still there, but linux would not boot, and it still told me what i said previously.

I ran the install, but SDA was still missing.

I went into the cmos settings, and navigated to the toshiba drive.

It says that the capacity for the drive is 0 bytes.
this has me completely dumbfounded, because i have no idea how that happened.

It turns off selection of higher level graphic drivers

I forget that that mode is called but if you go advanced it is obvious (have not booted for a while LOL) safe or recovery or something like that

to set nomodeset press e at boot find line starting linux press end key to go to end of line enter space and nomodeset then F10 to continue

This should allow boot but with a lesser graphics driver

I forget if you said what graphics chip you have but we need to get the boot to work before we address that directly.

Select advanced options for openSUSE, it’s usually the second item down

At the next screen select the first or only option but don’t press enter, press the letter e on the keyboard

The screen will now change and you can edit it, find the point listed here:

I made it that far.
I found the line you mentioned in the example. Added nomodeset to the end, and then hit F10 before booting into the Advanced Options.
I still get the same reply, and i took a picture of it. Mind that the picture is missing some things from the right.

imgur: the simple image sharer <— Edit: Not sure why the image links did that.

On top of that, while adding nomodeset, I noticed that the beginning of that line, did NOT include anything about /boot

Its in the section to the right of “by-id/ata”
imgur: the simple image sharer <— Edit: Not sure why the image links did that.

Also sorry for the delayed reply. Was out of town for New Years. =)

( Happy New Year, Fellas! )

I’m wondering if you could follow this:

If you didn’t use a DVD
Then this
Once you reach the end

  • Now you can start Yast, zypper, or whatever is needed to repair your system.

Just follow on with the instructions in the DVD guide to repair grub

Did that, but i Only made it to the second step.
The Toshiba Drive that i had installed linux on is apperently not being detected now.
I’ve opened up my PC and checked to see if it is hooked up properly and it is… So i’m not sure what is going on. =S

imgur: the simple image sharer

You need to remake the connections to be sure.

Now, just for checking. Boot with only this problem HD connected and see if it shows in fdisk

Report back

Ok. I disconnected my windows drive, and disconnected/reconnected the troublesome linux drive.

I went into the rescue mode, and tried all 3 fdisk commands, but none of them gave any response that included anything about sda. ( or any clues that there is even a drive hooked up.)

Speaking from another family members computer atm so i don’t have to keep rebooting the other machine.

Is it a new drive? Sounds like it died. Do you see or hear any activity?

The drive came out of a 2 year old laptop that had been dropped on the floor.
The screen was essentially ripped away from the keyboard.

As for activity, i don’t know how to see if there is activity, other than it being slightly warm to the touch after it has been on.

But for it’s age, it should have been fine.

The drive ran perfectly clear through the linux installation, and grub is being found on the drive, somehow.

That should mean that the drive is fine, right?


A drive can fail anytime for a bunch of reasons.

Ordering a new Drive wouldn’t be a problem, for times sake, but i thought it might be better to try and troubleshoot this drive.

Any good suggestions for a drive? I’m needing this linux drive very soon for a project i have coming up.

I’ve heard that HDDs require more power, due to there motors, and that SSDs are much faster, but can cost more.

Not sure what i should go with.
The windows drive is a 1tb hdd, should i try to get a twin drive? or would that matter?

I’m not big on the whole “Building” part of PCs, but i did manage to build the one that i’m using. =)

There is no harm using just your 1 HDD
Assuming the partition table will permit!?

If it’s a MBR table it can only have 4 Primary partitions

Perhaps you can show us?

Yep, this drive is setup to MBR.

The reason i was wanting a separate drive was for web testing on a temp server.
Which is why i had my partitions set the way they were. (see op)

imgur: the simple image sharer

Check the brand of HD, then go to the drive manufacturer’s website. They should have a free downloadable tool to fully test & setup the drive. They will also have jumper configuration information, and your problem might be as simple as the drive jumper settings. Also, if you are using a drive cable with two drive connectors, try the Drive on one connector, and then on the other if it doesn’t work on the first on. I have seen both these situations cause a drive not to work many times in the past.

Or, if you have Hiren’s Boot CD or the Ultimate Boot CD (both free, available online), they have HD testing tools.

If it passes the tests, then we should be able to get it set up & running.