13.1 freezes after 15-20 minutes of idle time - no Ctrl-Alt-F1 etc helps

Hi all !

This is a fresh install of openSUSE 13.1 64bit, with KDE,
on Fujitsu-Siemens Esprimo (Pentium Dual-Core E5200,
intel onboard graphics).

It worked perfect.
And I’m using this PC to write this.

Up to this point:
I left the PC alone for 15-20 minutes.

Afterwards I wasn’t even able to shutdown anymore.

Not even Ctrl-Alt-F1 and saying ‘shutdown -h now’ did work.

>:(

The disk light flashed every few seconds - so something still was going on.

Rebooting, after cutting power, gave a pretty long list of fixes for the file system at boot -
yes I removed the options splash=silent (or the like) from my /boot/grub/menu.lst
(I’m still using legacy GRUB).

To me it seems that power saving functions didn’t work correctly.

Thanks in advance
Mike

In KDE power settings, uncheck the box “Dim Screen”.

You can leave the “Screen Energy Savings” box checked. And keep the screen brightness at the max (should be the default).

At least, that is my experience with Intel graphics. My laptop has perhaps a 50% chance of freezing when the brightness changes. By making sure that brighness never changes, I rarely have freezes. Maybe, about 1 time in 100, it freezes during KDE startup - just after showing the first icon in the startup screen.

In the KDE settings I found ‘Hardware/Power Management’ and there ‘Screen Energy Saving’.

But I didn’t find the other ones.

Best wishes
Mike

Am I looking in the wrong place?

It is
(1) SUSE Menu (lower left corner of the screen)
(2) Favorites
(3) Configure Desktop
(4) Hardware

SUSE Menu –> Configure Desktop –> Power Management

or

Favorites –> Configure Desktop –> Power Management

Yes, it’s the hardware section of “Configure Desktop”

http://paste.opensuse.org/images/52197997.png

Maybe there are different options for your system. I think the options offered might depend on the hardware. I’m seeing this on both laptop and desktop with Intel graphics. But your Intel graphics is a bit different from either of mine.

Perhaps I should add that I’m usually not logged in as root.
Would that change anything?

Thank you very much!

Yes, on my system it looks different.

I e.g. miss the entry for ‘Dim Screen’.

Otherwise the window looks quite the same !

Thanks again for taking your time !
Mike

I’m not logged in as root, either. So, no, that should not be relevant.

Maybe your screen does not have the dim possibility.

A possible alternative: Look in $HOME/.kde4/share/config/powermanagementprofilesrc

with a text editor.

I do not have a section


[AC][DimDisplay]

and I think that’s because I have disable display dimming. If you have that section, try removing it. Similarly for Battery, if you are using on Battery.

If you edit that file, it’s a good idea to save a copy of the original, but keep it somewhere else. That way you can restore it if you don’t like the change, and you will have a memory of what was originally there.

Hi again!

OK (I have a Fujitsu-Siemens P19-2 with 1280x1024).

Here comes the good stuff … :wink:

Found that!

I do have that section.

In my file it is

[AC][DimDisplay]
idleTime=300000

I’m running a desktop PC.

OK, yes, I made a backup copy, good practice.

Otherwise I completely deleted the contents of this file, because my desktop PC doesn’t have a battery.

Let’s see what that does.

Rebooting now.

Thanks again !
Mike

Are you running the desktop kernel? You should be.

I’m running what the DVD openSUSE 13.1 64bit installer selected for that PC,
:wink:
except for a few amendments made with respect to software installed,
leaving out libreoffice, Apper, flash, Java, but including thunderbird, kfind,
and kdebase3-session (from repository
download.opensuse.org/repositories/KDE:/KDE3/openSUSE_13.1/
activated during the installation by means of selecting to include
external sources).

Hi again!

Great!
That solved it!

I meanwhile left that PC alone several times,
one time for several hours.

Result: No more freezing!

I think I know what you mean:
On my other PC, a core i5, running openSUSE 12.3,
I sometimes saw a bar appearing in the lower part of the screen,
telling sth. about 75%, 50%, 25%, before the screen finally went dark.

Just the brightness of the screen (I have two P19-2) never changed.

One more difference between the two systems:
at the Esprimo, the screen is connected by VGA interface,
the core i5 PC, on the other hand, has a DVI interface,
used to connect the same screen digitally.

Thank you very much again
Mike

That’s good to hear.