[12.3][xfce] Sound works only in Skype

Using XFCE as MATE is not yet a stable DE in openSUSE.

Firstly I don’t have any speakers connected to the PC motherboard, or nVidia Graphics card, I am using a Microsoft LifeChat LX-3000 headset.

I having a strange situation, with default XFCE installation. Installed Skype, and in the Skype options when I was not getting any sound, I went to the options and selected the LX-3000 device for all 3 settings, and all is working fine. Can have Skype voice chats.

I went to Yast Sound and also selected the LX-3000 as primary sound device, shifting to 0 position. I also checked the XFCE Mixer in the XFCE Settings that LX-3000 (Alsa mixer) is selected, yet get no test sounds, nor any sounds in any application or game. The XFCE Mixer affects the volume in Skype.

I saw pulseaudio was not installed, and so installed that too. Still no sound. I tried to use pavucontrol, yet only gives error “Fatal Error: Unable to connect to PulseAudio: OK”. Same result even after reboot.

In Yast System Services I see only alsasound (Yes*), see nothing for pulseaudio.

Any ideas to what the problem can be?

PulseAudio doesn’t seem to be running.
And it is no system service that starts on boot, that’s why it’s not listed in YaST->System Services. It is started on demand for the current user.
You have to activate it in YaST->Hardware->Sound. Click on “Other…” in the bottom-right and choose “PulseAudio Configuration”.

Thanx, working.

Is there a setting that allows for various sources to be heard at the same time?

Sorry I can’t answer that as I never used PulseAudio.

But what sources do you mean exactly?
I think it is a hardware limitation of most sound cards (at least cheap and onboard ones) to only be able to record/play-through one (hardware) input source at a time.

This is what I want to do. Play a game, have the normal action sounds, yet play other background music at the same time. Even able to use Skype at the same time, just lowering the game and music volume levels while having a conversation. Without a single application grabbing sole use of the audio device.

Thanx for you help so far.

Ok. That’s one of the main functions of PulseAudio. And alsa supports it as well for years.
But the problem is that PulseAudio takes complete control over alsa and blocks other alsa apps AFAIK.
You could try to install the package “alsa-plugins-pulse”, then those applications using alsa should be redirected to PulseAudio instead.

For apps that have pulse plugins themselves, you should install those as well of course, so they can use PulseAudio directly.
E.g. VLC has “vlc-aout-pulse” and xine has “libxine2-pulse”

I would suggest to just search for “pulse” in YaST->Software Management and install all those *-pulse packages applicable to you…