12.3 on Toshiba P855 - and can not change brightness ... :(

Hey, there,

I tried many distros on my new laptop - Toshiba Satellite P855-108, and on none of them I’m able to change the screen brightness.

Decided to try openSUSE 12.3 KDE - cause it’s pretty new, uses very latest kernel, so I assumed many things - that don’t work on other distros - would work here. Unfortunately - I’m unable to change the brightness screen, neither from the function keys, nor from the slider in the power settings. (From the slider I see the indicator changes, but no real change of the screen brightness.)

Can you help me? … It’s working on the pre-installed Windows 7, so I think it’s not a hardware problem.

Thanks in advance :slight_smile:

Welcome to the forums.

You should take a look at this thread, also in the laptop subforum: https://forums.opensuse.org/english/get-technical-help-here/laptop/482935-brightness-keys-toshiba-satellite-a660-2.html#post2524780

You may find threads related to your problem(s) by using the forum search facility.

Normally speaking, you should have posted this in the Pre-release/Beta forum since any RC1 is pre-release. :\


thanks for the other thread, I’m gonna check it :slight_smile:

And also - I posted already in the Toshiba forums, and also - I tried with 12.2 first, but had no success with it.

That’s why I started this thread :slight_smile:

Hi, welcome.

Did some searching, and it seems that these machines have a BIOS setting related to the Fn-Fx keys. Did you already find this?

Plus, what’s the desktop environment you’re using?

I see you have now posted in that other thread this : “I’m on Toshiba Satellite P855-108 with i7 processor and NVidia GT 640M video card.”
More importantly it needed to be in this thread, and now it is. :slight_smile:

Cheers, consused :).

I chose KDE variant (Kubuntu at the moment installed) - because I read that it’s the richest of tools, functionalities and widgets.
But among the other ones I’ve tried - Ubuntu with Unity, CrunchBang with Openbox, Kubuntu (KDE) and the openSUSE: 12.2 with Gnome3 and 12.3 with KDE.

And about the function keys mode - I have such setting in the BIOS:

Function Keys mode (without pressing FN first)

with the options:

[Standard F1-F12 mode]
[Special function mode]

But it’s affecting the function keys, as I see … it’s not working at all, including the brightness slider - and the slider is independent from the BIOS setting.

Please post output of

su -c lspci

Am I correct in assuming this one has dual graphics, i.e. an integrated Intel + the NVIDIA ? An Optimus?
IMHO we should try to get dimming working first, then check / redefine the keyboard settings.