12.3 nvidia with nouveau stuck at Reached Target Graphical Interface


This types of “I did not do anything, but suddenly I cannot login” type regression is the one thing I hate about GNU/Linux.
Anyway, this time it happened again, where my system is stuck at Reached Target Graphical Interface.

I searched for it and found another thread(https://forums.opensuse.org/english/get-technical-help-here/install-boot-login/485694-black-screen-ok-reached-target-graphical-interface-after-update.html), but it seems the OP was using proprietary driver.

I am using nouveau with KDE. I’m using encrypted LVM, and I can login in Failsafe mode. Tried to reinstall plymouth/kernel/nouveau but did not work.

This is another issue, but I took the SSD and attached it to a laptop with Intel graphics. It seems the screen loads up, but it did not show the passphrase input. So I pressed ESC, and I found that the screen was going crazy with repeated messages about searching for partition (I could not figure out the exact messages because they were scrolling too fast) as if I am keep pressing enter without correct passphrase. How can I fix this?


So, you might need to use the nomodeset kernel command perhaps? Have a look at this blog if you use Grub2: How to Start openSUSE 12.2 with Grub 2 into Run Level 3 - Blogs - openSUSE Forums

You can use this to make easy edits to your grub2 files if you wish and see what different between normal and recover modes: GNU Grub2 Command Listing Helper with --help & Input - Blogs - openSUSE Forums

If you decided to stick with Grub Legacy somehow because of using encrypted LVM partition setup, its hard for me to know for sure just what might be wrong now.

Thank You,

Thanks for your always helpful comment, jdmcdaniel3. I will try nomodeset and let you know. I am using Grub2.

Oh by the way, do you live in Austin? I go to UT! :slight_smile:

Yes I do and my son graduated from UT. You have selected the right school!

Thank You,

But if you add “nomodeset” you won’t be using the nouveau driver anymore, but “fbdev” or “vesa” (I’m not sure right now).

Do you have a file /etc/X11/xorg.conf? Try to rename it, so X’s autoconfiguration is used.
And the /var/log/Xorg.0.log from a failed boot would be helpful to find out what goes wrong…:wink:

Maybe you should just try to install the proprietary nvidia driver.

It would be useful to know what nvidia hardware is being referred to .

It’s Quadro NVS 295.

What wolfi said :wink:

(you can do this (from a failed attempt) by pressing Alt-F1 (or failing that, Alt-Ctl-F1) to get to the first VT (TTY1), and log in and then copy it any number of ways (e.g. “more /var/log/Xorg.0.log > myfile.txt”) and then post the contents of the log file to SUSE Paste and provide us a link to that )

I have installed nvidia proprietary driver. Now my machine boots and I can login, but it just recognizes 640x480 resolution.
Here is the contents of Xorg.0.log (with nvidia blob): SUSE Paste

Thank you for your help,

Okay. After blacklisting nouveau, I finally got native resolution screen with nvidia proprietary driver.

echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf

It seems for some reason the installer did not blacklist it … I remember I did not have to do this in 12.2.
I just logged in, so I will let you know how it goes.


So far so good. So I guess this happened because nouveau was broken with an update?


So how did you load the proprietary nVIDIA video driver? The nouveau driver is built into the kernel and does not ever blacklist it self. To install the proprietary nVIDIA driver manually I would do this:

  1. Using my Grub2cmd bash script, add nomodeset as a default kernel load option and run the update to place it in all installed kernel loads. The script is here: GNU Grub2 Command Listing Helper with --help & Input - Blogs - openSUSE Forums

  2. Load YaST / System / Sysconfig Editor and set Kernel option No_KMS_IN_INITRD=Yes (Default is NO). KMS=Kernel Mode Switching

  3. Download Latest nVIDIA driver you can find here: Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

  4. Download My Bash script LNVHW used to install the nVIDIA driver: LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.46 - Blogs - openSUSE Forums

  5. Edit LNVHW bash file as root to point to your /home/username/Downloads folder using this: SYSEdit - System File Editor - Version 1.50 - Blogs - openSUSE Forums

  6. Reboot PC and switch to Run Level 3 : How to Start openSUSE 12.3 with Grub 2 into Run Level 3 - Blogs - openSUSE Forums

  7. Run LNVHW to install the nVIDIA driver the hard way. Bash Script will blacklist the nouveau driver for you.

  8. Be aware on each update of the kernel, you need to go to run level 3 and reload the nVIDIA driver.

  9. If you compile your own kernel, you can use dkms to auto install the nVIDIA driver. For kernel info, look here: openSUSE and Installing New Linux Kernel Versions - Blogs - openSUSE Forums

  10. Use this bash script to install the nVIDIA driver and load it into dkms: S.A.N.D.I. - SuSE Automated NVIDIA Driver Installer - Version 1.00 - Blogs - openSUSE ForumsThank You,

Thanks for the detailed instructions. Anyway, I just used 1-click installer found https://en.opensuse.org/SDB:NVIDIA_drivers. I thought the installer would automatically blacklist nouveau.


The rpms do blacklist nouveau.
And your Xorg.0.log shows that the nvidia kernel module and driver was correctly loaded.
Your problem was a different one:

    39.110] (WW) NVIDIA(GPU-0): Unable to read EDID for display device DFP-2

So the driver could not determine the monitor’s resolution and used 640x480 instead.
Could be caused by a broken cable, a monitor switch or maybe your monitor just doesn’t support EDID or is broken.
Btw, I experienced a similar thing once with my monitor (bad EDID checksum). It worked fine again after unplugging and replugging the power cord. :sarcastic:

But you can use “nvidia-settings” to change the resolution…

That makes sense. I have had problems with my monitor and it got fixed with unplugging as well. But could you please explain why did it start working after I blacklisted nouveau? Thanks!!


Don’t know, maybe coincidence? :wink:

But you must have had nouveau blacklisted before, otherwise the nvidia driver would have failed to load.
The driver rpms do create a file /etc/modprobe.d/nvidia-desktop.conf (or /etc/modprobe.d/nvidia-default.conf) for that.

You are right. There is /etc/modprobe.d/nvidia-desktop.conf with the blacklist. So next time my computer does not boot, I will try unplugging my monitor. :slight_smile: