12.3 Nvidia driver freeze - reinstall/rollback to working Nouveau

Finally I had got 12.3/Gnome 3.8.3 and Nvidia driver working for dual monitor setup (2560x1600) on my hp8710 w/Quadro FX 3600M and via dual-link DVI on the docking station. So after some weeks use and distro upgrades it stopped working, and I had to reinstall 12.3 from scratch. The default Nouveau installation works fine for single monitor use, but as soon as I now add the Nvidia community repo and ‘zypper dup’ to Nvidia packages, the system freeze shortly after login to Gnome.

Now I have reinstalled 12.3 with Nouveau and upgraded to Gnome 3.8.3 again.

# zypper se -i nouveau
Loading repository data...
Reading installed packages...

S | Name                          | Summary                                                      | Type   
--+-------------------------------+--------------------------------------------------------------+--------
i | libdrm_nouveau2               | Userspace interface for Kernel DRM services for NVIDIA chips | package
i | xorg-x11-driver-video-nouveau | Accelerated Open Source driver for nVidia cards              | package

My related system specification is

~> inxi -Fz
System:    Host: linux-gi83.site Kernel: 3.7.10-1.16-desktop x86_64 (64 bit) 
           Desktop Gnome Distro: openSUSE 12.3 (x86_64) VERSION = 12.3 CODENAME = Dartmouth
Machine:   System: Hewlett-Packard (portable) product: HP Compaq 8710w version: F.0F
           Mobo: Hewlett-Packard model: 30C3 version: KBC Version 73.31
           Bios: Hewlett-Packard version: 68MAD Ver. F.0F date: 11/25/2008
CPU:       Dual core Intel Core2 Duo CPU T9500 (-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) 
           Clock Speeds: 1: 2601.00 MHz 2: 800.00 MHz
Graphics:  Card: NVIDIA G92M [Quadro FX 3600M] 
           X.Org: 1.13.2 drivers: nouveau (unloaded: fbdev,nv,vesa) Resolution: 1920x1200@60.0hz 
           GLX Renderer: Gallium 0.4 on NV92 GLX Version: 3.0 Mesa 9.0.2

After adding the Nvidia community repo, ‘zypper dup’ will install

# zypper dup
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

The following NEW packages are going to be installed:
  binutils gcc gcc47 glibc-devel kde-gtk-config-lang kernel-desktop-devel kernel-devel libXext6-32bit 
  libdvdcss2 linux-glibc-devel make nvidia-computeG03 nvidia-gfxG03-kmp-desktop site-config 
  x11-video-nvidiaG03 

The following packages are going to be upgraded:
  transmission-common transmission-gtk 

My first question is if this causes system freeze again, I wonder how to easier roll back to the default nouveau setting again, without reinstalling everything from scratch?

All available Nvidia packages for installation are:

# zypper se nvidia
Retrieving repository 'nVidia Graphics Drivers' metadata ............................................[done]
Loading repository data...
Reading installed packages...

S | Name                      | Summary                                                        | Type      
--+---------------------------+----------------------------------------------------------------+-----------
  | nvidia-computeG02         | NVIDIA driver for computing with GPGPU                         | package   
  | nvidia-computeG03         | NVIDIA driver for computing with GPGPU                         | package   
  | nvidia-gfx-kmp-default    | NVIDIA graphics driver kernel module for GeForce4 GPUs         | package   
  | nvidia-gfx-kmp-desktop    | NVIDIA graphics driver kernel module for GeForce4 GPUs         | package   
  | nvidia-gfx-kmp-pae        | NVIDIA graphics driver kernel module for GeForce4 GPUs         | package   
  | nvidia-gfxG01-kmp-default | NVIDIA graphics driver kernel module for GeForceFX GPUs        | package   
  | nvidia-gfxG01-kmp-desktop | NVIDIA graphics driver kernel module for GeForceFX GPUs        | package   
  | nvidia-gfxG01-kmp-pae     | NVIDIA graphics driver kernel module for GeForceFX GPUs        | package   
  | nvidia-gfxG02-kmp-default | NVIDIA graphics driver kernel module for GeForce 6xxx and ne-> | package   
  | nvidia-gfxG02-kmp-desktop | NVIDIA graphics driver kernel module for GeForce 6xxx and ne-> | package   
  | nvidia-gfxG02-kmp-pae     | NVIDIA graphics driver kernel module for GeForce 6xxx and ne-> | package   
  | nvidia-gfxG03-kmp-default | NVIDIA graphics driver kernel module for GeForce 8xxx and ne-> | package   
  | nvidia-gfxG03-kmp-desktop | NVIDIA graphics driver kernel module for GeForce 8xxx and ne-> | package   
  | nvidia-gfxG03-kmp-pae     | NVIDIA graphics driver kernel module for GeForce 8xxx and ne-> | package   
  | nvidia-settings           | Configuration Tool for nVidia GPUs                             | package   
  | nvidia-settings           | Configuration Tool for nVidia GPUs                             | srcpackage
  | nvidia-texture-tools      | NVIDIA Texture Tools                                           | package   
  | oyranos-monitor-nvidia    | Nvidia card support                                            | package   
  | x11-video-nvidia          | NVIDIA graphics driver for GeForce4 GPUs                       | package   
  | x11-video-nvidiaG01       | NVIDIA graphics driver for GeForceFX GPUs                      | package   
  | x11-video-nvidiaG02       | NVIDIA graphics driver for GeForce 6xxx and newer GPUs         | package   
  | x11-video-nvidiaG03       | NVIDIA graphics driver for GeForce 8xxx and newer GPUs         | package 

If the above cause freeze or other problems again, I’m not really sure what to try as the right options?
But the following link say that NVIDIA Quadro FX 3600M is based upon the 8800M GTX consumer card (G92 architecture). Possibly this is equivalent to category

openSUSE is that stable, that “doing it all over again” will result in the same issues.
Rather than using “zypper dup”. add the NVIDIA repo through Yast, start the softwareinstaller and let it decide which NVIDIA driver to install.

I don’t know what nVIDIA driver version you are trying to load, but it looks as if you need 319.17 when looked up online: http://us.download.nvidia.com/XFree86/Linux-x86_64/319.17/NVIDIA-Linux-x86_64-319.17.run

I have a blog on installing the nVIDIA driver the hard way: Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

Make sure to remove ALL nVIDIA repositories beofre you proceed. If you are a big Zypper fan, have a look at my bash script Zypper Command while you are at it:

Zypper Command - Zypper Package Management Menu System - Version 2.00 - Blogs - openSUSE Forums

Thank You,

There is am issue with the NVIDIA driver on a fresh 12.3 installation: https://www.suse.com/releasenotes/i386/openSUSE/12.3/RELEASE-NOTES.en.html#idm1265054156
So add your user to the “video” group before rebooting when you install the driver.

This shouldn’t be needed if you already installed all available updates, but anyway, just do it, it can’t hurt.

And yes, the G03 driver supports your card.

If it doesn’t work, just boot into recovery mode (select “Advanced Options” at the boot menu) and remove the 3 nvidia packages again with YaST or zypper.

# zypper se -s -u kernel-desktop-devel kernel-devel nvidia-computeG03 nvidia-gfxG03-kmp-desktop
Loading repository data...
Reading installed packages...

S | Name                      | Type    | Version                 | Arch   | Repository             
--+---------------------------+---------+-------------------------+--------+------------------------
  | kernel-desktop-devel      | package | 3.7.10-1.16.1           | x86_64 | openSUSE-12.3-Update   
  | kernel-desktop-devel      | package | 3.7.10-1.11.1           | x86_64 | openSUSE-12.3-Update   
  | kernel-desktop-devel      | package | 3.7.10-1.4.1            | x86_64 | openSUSE-12.3-Update   
  | kernel-desktop-devel      | package | 3.7.10-1.1.1            | x86_64 | openSUSE-12.3-Oss      
  | kernel-desktop-devel      | package | 3.7.10-1.16.1           | i686   | openSUSE-12.3-Update   
  | kernel-desktop-devel      | package | 3.7.10-1.11.1           | i686   | openSUSE-12.3-Update   
  | kernel-desktop-devel      | package | 3.7.10-1.4.1            | i686   | openSUSE-12.3-Update   
  | kernel-desktop-devel      | package | 3.7.10-1.1.1            | i686   | openSUSE-12.3-Oss      
  | kernel-devel              | package | 3.7.10-1.16.1           | noarch | openSUSE-12.3-Update   
  | kernel-devel              | package | 3.7.10-1.11.1           | noarch | openSUSE-12.3-Update   
  | kernel-devel              | package | 3.7.10-1.4.1            | noarch | openSUSE-12.3-Update   
  | kernel-devel              | package | 3.7.10-1.1.1            | noarch | openSUSE-12.3-Oss      
  | nvidia-computeG03         | package | 319.17-12.1             | x86_64 | nVidia Graphics Drivers
  | nvidia-computeG03         | package | 319.17-12.1             | i586   | nVidia Graphics Drivers
  | nvidia-gfxG03-kmp-desktop | package | 319.17_k3.7.10_1.1-12.1 | x86_64 | nVidia Graphics Drivers
  | nvidia-gfxG03-kmp-desktop | package | 319.17_k3.7.10_1.1-12.1 | i586   | nVidia Graphics Drivers

And according to YaST it’s the latest x86_64 version that will be installed.

Now I’ve added ‘video’ as secondary group to my user, and try now to install the drivers with YaST this time.
Thank you all so far :wink:

Sorry, the Nvidia upgrade still causes the same system freeze.

> groups
users video
# zypper se -is nvidia

Loading repository data...
Reading installed packages...

S | Name                      | Type    | Version                 | Arch   | Repository             
--+---------------------------+---------+-------------------------+--------+------------------------
i | nvidia-computeG03         | package | 319.17-12.1             | x86_64 | nVidia Graphics Drivers
i | nvidia-gfxG03-kmp-desktop | package | 319.17_k3.7.10_1.1-12.1 | x86_64 | nVidia Graphics Drivers
i | nvidia-settings           | package | 290.10-1.6              | x86_64 | Packman Repository     
i | x11-video-nvidiaG03       | package | 319.17-12.1             | x86_64 | nVidia Graphics Drivers

I actually had better luck with a newer kernel and I see you tried 3.8 at first. Why not go all the way to 3.10, just released final yesterday or 3.9.8 just see if they help?

openSUSE and Installing New Linux Kernel Versions - Blogs - openSUSE Forums

Thank You,

First: don’t install that nvidia-settings package! It doesn’t work with the current driver (its version is 290.10, the driver’s version is 319.17).
nvidia-settings is included in the driver packages anyway.

I don’t think this causes your freeze though.

Second: Could you please boot to recovery mode and post the file /var/log/Xorg.0.log.old?
Maybe that provides a clue.

You could also try the G02 driver. Maybe that one would work better for you?
Remove the G03 nvidia driver:

sudo zypper rm nvidia-computeG03 nvidia-gfxG03-kmp-desktop x11-video-nvidiaG03

Install the G02 driver:

sudo zypper in nvidia-computeG02 nvidia-gfxG02-kmp-desktop x11-video-nvidiaG02

I don’t know where you read that he tried kernel 3.8… He only talked about GNOME 3.8 AFAICS.
But if he did, that would explain why he has problems.
The driver packages from the repo ONLY work with the standard kernel included in openSUSE!

So terjejh, could you please clear that up and post the output of:

uname -a

Also I doubt that the kernel version makes much difference when using the nvidia driver (nouveau is a different story of course).
Except that it can happen that the nvidia driver kernel module doesn’t compile yet with the latest kernel… (was the case with kernel 3.10rc4 IIANM, is this fixed already? I don’t know)

Oh, I wasn’t aware of that. I couldn’t see the ‘nvidia-settings’ package listed after the Nvidia installation and therefore searched and added it with YaST myself afterwards.

Second: Could you please boot to recovery mode and post the file /var/log/Xorg.0.log.old?
Maybe that provides a clue.

Sorry, this isn’t available now. Due to system freeze before I reached to replace the removed Nvidia drivers and kernel packages, I had to boot from the original 12.3 DVD. The first try with an update installation didn’t fix it and I had to make a new reinstallation from scratch to 12.3, Gnome 3.6 and Nouveau again. Just now the installation is upgraded to the same level with Gnome 3.8.3, where I started this thread.

You could also try the G02 driver. Maybe that one would work better for you?
Remove the G03 nvidia driver:

sudo zypper rm nvidia-computeG03 nvidia-gfxG03-kmp-desktop x11-video-nvidiaG03

Install the G02 driver:

sudo zypper in nvidia-computeG02 nvidia-gfxG02-kmp-desktop x11-video-nvidiaG02

Yes, I can give G02 a try from the current Nouveau installation level. Can you confirm if I should remove all of following packages first, or if they will be replaced automatically during the zypper installation of the G02 packages:

# zypper se -is kernel nouveau
Loading repository data...
Reading installed packages...

S | Name                          | Type    | Version           | Arch   | Repository          
--+-------------------------------+---------+-------------------+--------+---------------------
i | kernel-desktop                | package | 3.7.10-1.16.1     | x86_64 | openSUSE-12.3-Update
i | kernel-desktop                | package | 3.7.10-1.1.1      | x86_64 | openSUSE-12.3-Oss   
i | kernel-firmware               | package | 20130114git-1.2.1 | noarch | openSUSE-12.3-Oss   
i | libdrm_nouveau2               | package | 2.4.42-1.1.1      | x86_64 | openSUSE-12.3-Oss   
i | xorg-x11-driver-video-nouveau | package | 1.0.6-2.1.1       | x86_64 | openSUSE-12.3-Oss

Hopefully not to cause confusion, I can also mentione here that on another Xeon based, stationary workstation with Quadro FX 550, Nvidia G02 was installed automatically and has worked without freeze so far.

~> rpm -qa | grep nvidia 
nvidia-settings-290.10-1.3.x86_64 
nvidia-gfxG02-kmp-desktop-304.88_k3.7.10_1.1-24.1.x86_64 
nvidia-computeG02-304.88-25.1.x86_64 
x11-video-nvidiaG02-304.88-25.1.x86_64 
~> inxi -Fz 
System:    Host: linux-q390.site Kernel: 3.7.10-1.11-desktop x86_64 (64 bit) 
           Desktop Gnome Distro: openSUSE 12.3 (x86_64) VERSION = 12.3  CODENAME = Dartmouth 
Machine:   System: Dell product: Precision WorkStation 490 
           Mobo: Dell model: 0F9382 version: A00 Bios: Dell version:  A08 date: 04/25/2008 
CPU:       Dual core Intel Xeon CPU 5160 (-MCP-) cache: 4096 KB flags:  (lm nx sse sse2 sse3 ssse3 vmx) 
           Clock Speeds: 1: 2992.317 MHz 2: 2992.317 MHz 
Graphics:  Card: NVIDIA NV43GL [Quadro FX 550] 
           X.Org: 1.13.2 drivers: nvidia (unloaded:  fbdev,nv,vesa,nouveau) Resolution: [EMAIL="1920x1200@60.0hz"]1920x1200@60.0hz[/EMAIL] 
           GLX Renderer: Quadro FX 550/PCIe/SSE2 GLX Version: 2.1.2  NVIDIA 304.88 

I don’t know where you read that he tried kernel 3.8… He only talked about GNOME 3.8 AFAICS.
But if he did, that would explain why he has problems.
The driver packages from the repo ONLY work with the standard kernel included in openSUSE!

So terjejh, could you please clear that up and post the output of:

uname -a

That’s correct, I had upgraded to Gnome 3.8.3. The kernel-desktop version was and is the standard 3.7.10 included in openSUSE, as shown above in this post and as previous shown in #5 above.

No, don’t remove them!
Not even nouveau!

Hopefully not to cause confusion, I can also mentione here that on another Xeon based, stationary workstation with Quadro FX 550, Nvidia G02 was installed automatically and has worked without freeze so far.

~> rpm -qa | grep nvidia 
nvidia-settings-290.10-1.3.x86_64 
nvidia-gfxG02-kmp-desktop-304.88_k3.7.10_1.1-24.1.x86_64 
nvidia-computeG02-304.88-25.1.x86_64 
x11-video-nvidiaG02-304.88-25.1.x86_64 

Well, you should remove nvidia-settings there as well.

Oh, and if the G02 driver also doesn’t work, you don’t have to completely reinstall from scratch.
Just remove the driver and you should have your working nouveau system back:

sudo zypper rm nvidia-computeG02 nvidia-gfxG02-kmp-desktop x11-video-nvidiaG02

To be able to do that, boot to text or recovery mode, or login to a different session than GNOME from the login screen. (at least twm and IceWM should be available by default)

So if G02 fails as well you shouldn’t immediately remove it, but reboot, login to IceWM f.e. and post XOrg.0.log.old.
And check if the driver is correctly installed and running:

glxinfo | grep render

(you may have to install the package “Mesa-demo-x” first)

I noticed several ‘sign warnings’ during the G02 installation.
And sorry, also every 12.3 Nvidia G02 login mode freeze within a minute or so. I’ve tried Gnome, KDE and console login.
I just reached to run and save glxinfo before freeze. To be able to post also Xorg.0-log.old here, Iv’e utilized the parallell ‘dual-boot-installed’ 13.1 M2 KDE to mount and reach 12.3/var/log from there. Iv’e had to cut down the long output to be able to post it here

cat glxinfo
direct rendering: Yes
OpenGL renderer string: Quadro FX 3600M/PCIe/SSE2
    GL_NV_conditional_render, GL_NV_copy_depth_to_color, GL_NV_copy_image, 
    GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
    GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
    GL_OES_depth_texture, GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,
cat /suse123/var/log/Xorg.0.log.old
    11.706] 
X.Org X Server 1.13.2
Release Date: 2013-01-24
    11.706] X Protocol Version 11, Revision 0
    11.706] Build Operating System: openSUSE SUSE LINUX
    11.706] Current Operating System: Linux linux-bvd2.site 3.7.10-1.16-desktop #1 SMP PREEMPT Fri May 31 20:21:23 UTC 2013 (97c14ba) x86_64                                                                                                                           
    11.706] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.7.10-1.16-desktop root=UUID=d1b91cd5-4eef-4f9a-9132-830436f40f7b resume=/dev/disk/by-id/ata-INTEL_SSDSA2CW160G3_CVPR13530944160DGN-part1 splash=silent quiet showopts                                      
    11.706] Build Date: 30 April 2013  08:24:17AM                                                                                  
    11.706]                                                                                                                        
    11.706] Current version of pixman: 0.28.2                                                                                      
    11.706]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
    11.706] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    11.706] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jul  3 01:05:30 2013
    11.707] (==) Using config directory: "/etc/X11/xorg.conf.d"
    11.707] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    11.707] (==) No Layout section.  Using the first Screen section.
    11.707] (==) No screen section available. Using defaults.
    11.707] (**) |-->Screen "Default Screen Section" (0)
    11.707] (**) |   |-->Monitor "<default monitor>"
    11.707] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
    11.707] (==) Automatically adding devices
    11.707] (==) Automatically enabling devices
    11.707] (==) Automatically adding GPU devices
    11.707] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    11.707]    Entry deleted from font path.
    11.707] (==) FontPath set to:
        /usr/share/fonts/misc:unscaled,
        /usr/share/fonts/Type1/,
        /usr/share/fonts/100dpi:unscaled,
        /usr/share/fonts/75dpi:unscaled,
        /usr/share/fonts/ghostscript/,
        /usr/share/fonts/cyrillic:unscaled,
        /usr/share/fonts/truetype/,
        built-ins
    11.707] (==) ModulePath set to "/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules"
    11.707] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
    11.707] (II) Loader magic: 0x801c20
    11.707] (II) Module ABI versions:
    11.707]    X.Org ANSI C Emulation: 0.4
    11.707]    X.Org Video Driver: 13.1
    11.707]    X.Org XInput driver : 18.0
    11.707]    X.Org Server Extension : 7.0
    11.710] (--) PCI:*(0:1:0:0) 10de:061c:10de:0518 rev 162, Mem @ 0xe5000000/16777216, 0xd0000000/268435456, 0xe6000000/33554432, I/O @ 0x00004000/128
    11.710] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    11.710] Initializing built-in extension Generic Event Extension
    11.710] Initializing built-in extension SHAPE
    11.710] Initializing built-in extension MIT-SHM
    11.710] Initializing built-in extension XInputExtension
    11.710] Initializing built-in extension XTEST
    11.710] Initializing built-in extension BIG-REQUESTS
    11.710] Initializing built-in extension SYNC
    11.710] Initializing built-in extension XKEYBOARD
    11.710] Initializing built-in extension XC-MISC
    11.710] Initializing built-in extension SECURITY
    11.710] Initializing built-in extension XINERAMA
    11.710] Initializing built-in extension XFIXES
    11.710] Initializing built-in extension RENDER
  
    14.031] (--) Depth 24 pixmap format is 32 bpp
    14.031] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
    14.041] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
    14.041] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
   eyboard catchall"
    14.461] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
    14.461] (**) Video Bus: Applying InputClass "LocalKeyboard"
    14.461] (II) Using input driver 'evdev' for 'Video Bus'
    14.461] (**) Video Bus: always reports core events
    14.461] (**) evdev: Video Bus: Device: "/dev/input/event8"
    14.462] (--) evdev: Video Bus: Vendor 0 Product 0x6
    14.462] (--) evdev: Video Bus: Found keys
    14.462] (II) evdev: Video Bus: Configuring as keyboard
    14.462] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:00/LNXVIDEO:00/input/input8/event8"
    14.462] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
    14.462] (**) Option "xkb_rules" "evdev"
    14.462] (**) Option "xkb_model" "evdev"
    14.462] (**) Option "xkb_layout" "no"
    14.462] (II) config/udev: Adding input device Lid Switch (/dev/input/event6)

    14.462] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input5/event5"
    14.462] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 8)
    14.462] (**) Option "xkb_rules" "evdev"
    14.462] (**) Option "xkb_model" "evdev"
    14.462] (**) Option "xkb_layout" "no"
    14.463] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event12)
    14.463] (II) No input driver specified, ignoring this device.
    14.463] (II) This device may have been added with another device file.
    14.463] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event2)
    14.463] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall"
    14.463] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall"
    14.463] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
    14.463] (**) Logitech USB Receiver: always reports core events
    14.463] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event2"
    14.463] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52f
    14.463] (--) evdev: Logitech USB Receiver: Found 20 mouse buttons
    14.463] (--) evdev: Logitech USB Receiver: Found scroll wheel(s)
    14.463] (--) evdev: Logitech USB Receiver: Found relative axes
    14.463] (--) evdev: Logitech USB Receiver: Found x and y relative axes
    14.463] (II) evdev: Logitech USB Receiver: Configuring as mouse
    14.463] (II) evdev: Logitech USB Receiver: Adding scrollwheel support
    14.463] (**) evdev: Logitech USB Receiver: YAxisMapping: buttons 4 and 5
    14.463] (**) evdev: Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    14.463] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.1/usb6/6-1/6-1:1.0/input/input2/event2"
    14.463] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: MOUSE, id 9)
    14.463] (II) evdev: Logitech USB Receiver: initialized for relative axes.
    14.464] (**) Logitech USB Receiver: (accel) keeping acceleration scheme 1

    14.470] (**) Option "YAxisMapping" "4 5"
    14.470] (**) evdev: PS/2 Generic Mouse: YAxisMapping: buttons 4 and 5
    14.470] (**) Option "XAxisMapping" "6 7"
    14.470] (**) evdev: PS/2 Generic Mouse: XAxisMapping: buttons 6 and 7
    14.470] (**) evdev: PS/2 Generic Mouse: EmulateWheelButton: 2, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    14.470] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/serio5/input/input4/event4"
    14.470] (II) XINPUT: Adding extended input device "PS/2 Generic Mouse" (type: MOUSE, id 13)
    14.470] (II) evdev: PS/2 Generic Mouse: initialized for relative axes.
    14.470] (**) PS/2 Generic Mouse: (accel) keeping acceleration scheme 1
    14.470] (**) PS/2 Generic Mouse: (accel) acceleration profile 0
    14.470] (**) PS/2 Generic Mouse: (accel) acceleration factor: 2.000
    14.470] (**) PS/2 Generic Mouse: (accel) acceleration threshold: 4
    14.470] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/mouse2)
    14.470] (**) PS/2 Generic Mouse: Applying InputClass "PS/2 Generic Mouse"
    14.470] (II) Using input driver 'evdev' for 'PS/2 Generic Mouse'
    14.470] (**) PS/2 Generic Mouse: always reports core events
    14.470] (**) evdev: PS/2 Generic Mouse: Device: "/dev/input/mouse2"
    14.471] (EE) PS/2 Generic Mouse: Couldn't open mtdev device
    14.471] (EE) evdev: PS/2 Generic Mouse: ioctl EVIOCGID failed: Bad file descriptor
    14.471] (EE) PreInit returned 8 for "PS/2 Generic Mouse"
    14.471] (II) UnloadModule: "evdev"
    14.471] (II) config/udev: Adding input device ST LIS3LV02DL Accelerometer (/dev/input/event10)
    14.471] (II) No input driver specified, ignoring this device.
    14.471] (II) This device may have been added with another device file.
    14.471] (II) config/udev: Adding input device ST LIS3LV02DL Accelerometer (/dev/input/js0)
    14.471] (II) No input driver specified, ignoring this device.
    14.471] (II) This device may have been added with another device file.
    14.471] (II) config/udev: Adding input device PC Speaker (/dev/input/event9)
    14.471] (II) No input driver specified, ignoring this device.
    14.471] (II) This device may have been added with another device file.
    14.473] (II) config/udev: Adding input device HP WMI hotkeys (/dev/input/event11)
    14.473] (**) HP WMI hotkeys: Applying InputClass "evdev keyboard catchall"
    14.473] (**) HP WMI hotkeys: Applying InputClass "evdev keyboard catchall"
    14.473] (**) HP WMI hotkeys: Applying InputClass "LocalKeyboard"
    14.473] (II) Using input driver 'evdev' for 'HP WMI hotkeys'
    14.473] (**) HP WMI hotkeys: always reports core events
    14.473] (**) evdev: HP WMI hotkeys: Device: "/dev/input/event11"
    14.473] (--) evdev: HP WMI hotkeys: Vendor 0 Product 0
    14.473] (--) evdev: HP WMI hotkeys: Found keys
    14.473] (II) evdev: HP WMI hotkeys: Configuring as keyboard
    14.473] (**) Option "config_info" "udev:/sys/devices/virtual/input/input11/event11"
    14.473] (II) XINPUT: Adding extended input device "HP WMI hotkeys" (type: KEYBOARD, id 14)
    14.473] (**) Option "xkb_rules" "evdev"
    14.473] (**) Option "xkb_model" "evdev"
    14.473] (**) Option "xkb_layout" "no"
    14.850] (II) NVIDIA(GPU-0): Display (AU Optronics Corporation (DFP-0)) does not support
    14.850] (II) NVIDIA(GPU-0):     NVIDIA 3D Vision stereo.
    14.850] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
    14.850] (**) NVIDIA(0):     device AU Optronics Corporation (DFP-0) (Using EDID
    14.850] (**) NVIDIA(0):     frequencies has been enabled on all display devices.)
    15.255] (II) NVIDIA(GPU-0): Display (AU Optronics Corporation (DFP-0)) does not support
    15.255] (II) NVIDIA(GPU-0):     NVIDIA 3D Vision stereo.
    15.255] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
    15.255] (**) NVIDIA(0):     device AU Optronics Corporation (DFP-0) (Using EDID
    15.255] (**) NVIDIA(0):     frequencies has been enabled on all display devices.)
    15.569] (II) NVIDIA(GPU-0): Display (AU Optronics Corporation (DFP-0)) does not support
    15.569] (II) NVIDIA(GPU-0):     NVIDIA 3D Vision stereo.
    15.569] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
    15.569] (**) NVIDIA(0):     device AU Optronics Corporation (DFP-0) (Using EDID
    15.569] (**) NVIDIA(0):     frequencies has been enabled on all display devices.)
    36.740] (II) NVIDIA(GPU-0): Display (AU Optronics Corporation (DFP-0)) does not support
    36.740] (II) NVIDIA(GPU-0):     NVIDIA 3D Vision stereo.
    36.740] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
    36.740] (**) NVIDIA(0):     device AU Optronics Corporation (DFP-0) (Using EDID
    36.740] (**) NVIDIA(0):     frequencies has been enabled on all display devices.)
    46.656] (II) NVIDIA(GPU-0): Display (AU Optronics Corporation (DFP-0)) does not support
    46.656] (II) NVIDIA(GPU-0):     NVIDIA 3D Vision stereo.
    46.656] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
    46.656] (**) NVIDIA(0):     device AU Optronics Corporation (DFP-0) (Using EDID
    46.656] (**) NVIDIA(0):     frequencies has been enabled on all display devices.)
   144.049] (WW) NVIDIA(0): WAIT (2, 6, 0x8000, 0x0000d360, 0x0000d370)
   151.049] (WW) NVIDIA(0): WAIT (1, 6, 0x8000, 0x0000d360, 0x0000d370)

That looks ok.

cat /suse123/var/log/Xorg.0.log.old
    11.706] 
X.Org X Server 1.13.2
Release Date: 2013-01-24
    11.706] X Protocol Version 11, Revision 0
    11.706] Build Operating System: openSUSE SUSE LINUX
    11.706] Current Operating System: Linux linux-bvd2.site 3.7.10-1.16-desktop #1 SMP PREEMPT Fri May 31 20:21:23 UTC 2013 (97c14ba) x86_64                                                                                                                           
...
   144.049] (WW) NVIDIA(0): WAIT (2, 6, 0x8000, 0x0000d360, 0x0000d370)
   151.049] (WW) NVIDIA(0): WAIT (1, 6, 0x8000, 0x0000d360, 0x0000d370)

I guess those lines indicate your problem.
Googling for that i found:
https://bbs.archlinux.org/viewtopic.php?id=117102

So try this:
Create a file /etc/X11/xorg.conf.d/45-use-events.conf with the following content:

Section "Device"
    Identifier  "Default Device"
    Option  "UseEvents"  "false"
EndSection

If iit helps then both the G02 and the G03 driver work WITHOUT freezes… :wink:

I did that and got got a new freeze shortly after a new reboot and login with 12.3 Nvidia G02.
Also I noticed that that archlinux thread titled it ‘sporadic freezing in X’. In my case I will denote it a permanent, hard freeze shortly after login *). As this also looks to happends on console login, I wonder if it is ‘more kernel than graphical’ related(?). I also have the expression that the machine fan run harder until freeze with this Nvidia driver than with the working Nouveau.

*) On the other hand I have an AMD based machine where I would say there has been temporary, short desktop freezes with the latest openSUSE versions

(It looks like newer Gnome will be difficult to apply as my dual boot with openSUSE 13.1 M2/Gnome 3.9.1 won’t login at all but report just the wisely ‘Oh no, something has gone wrong’, as previously posted in another forum:
https://forums.opensuse.org/english/get-technical-help-here/pre-release-beta/487889-broken-gnome-3-8-login-13-1-milestone-1-2-a.html#post2564959
The latter issue is with Gnome only, and I write this reply using working KDE4 on 13.1 M2).

Wait a moment.
You (at least I think that is you ;)) mention a hybrid Intel/Nvidia system in Access Denied, is that this one?
Then the proprietary nvidia driver cannot work AFAIK!

You’d have to use Bumblebee then I think:
Smithfarm - the Brain: openSUSE 12.3: How to install ‘bumblebee’ for NVIDIA Optimus VGA

Sorry if I’m wrong, but I heard that a few times. And SDB:NVIDIA drivers - openSUSE Wiki also says:

For all NVIDIA current cards (Geforce 8 and later, but excluding all cards with Optimus technology, for this technology see bumblebee project, in particular its version 3)
(and similar for the other driver versions)
I have absolutely no experience with hybrid systems myself.

That’s me, yes. But maybe my title ‘HP - Intel/Nvidia’ has been confusing as I didn’t mention ‘hybrid’ graphics, but a HP 8710 machine with Intel Core2 Duo CPU T9500 and NVIDIA G92M [Quadro FX 3600M] graphical card. See the inxi output #1 above in this thread.

And to add; I have had Nvidia drivers working on this machine previously. Do I misunderstand something here?

Ok, it’s no hybrid system then, but I don’t know what inxi would show in that case. Sorry.
But I wanted to clear that up, since we could try things on and on and wouldn’t succeed if it had been one.

Well, if the freezes also happen in text mode, it can’t really be related to the X driver.
But you don’t have the freezes with nouveau, right?

Some more ideas:

  • Try to disable plymouth (the boot splash). May sound silly, but that has caused some strange problems for other users.
    Add “plymouth.enable=0” to your boot options.

  • Maybe you should try to upgrade your kernel. This repo has 3.10.0: Index of /repositories/Kernel:/stable/standard
    You would have to install the nvidia driver “the hard way” then (which isn’t really that hard ;)).
    But maybe that would cure it? (there’s also already a newer version of the G03 driver out by now, which isn’t yet part of the repo)
    And be sure to remove the nvidia packages first.
    SDB:NVIDIA the hard way - openSUSE Wiki

If Optimus means to utilize hybrid integrated (embedded) and external graphichs, I haven’t read that hp8710w has that. The Nvidia Quadro FX 3600M was the high-end option graphical card for this mobile workstation in 2008 as described here

Quadro FX 3600M

Well, if the freezes also happen in text mode, it can’t really be related to the X driver.
But you don’t have the freezes with nouveau, right?

I have no freezes with Nouveau, that’ right.
With Nvidia I thought I had got freeze also using text in console mode using Ctrl+Alt+F1 from the GDM login menu, but I did not happend to reconstruct this again now.

To sum up what I experience now, when booting the desktop kernel and Nvidia driver loaded are:

  • the machine freeze after short time also with only the GDM menu on the screen, without login to Gnome or KDE login sessions first
  • when I entered Ctrl+Alt+F1 to console mode first before graphical login, I didn’t get freeze in text mode. But as soon as I then entered Ctrl+Alt+F7 to come back to the GDM login menu, the machine freeze occured immediately in text mode without displaying the gui login menu

If I boot recovery mode with the fbdev driver loaded, the following happends:

  • The “Oh, no something is wrong” message is displayed without the GDM login menu first
  • Ctrl+Alt+F1 here has not caused freeze in text mode

Some more ideas:

  • Try to disable plymouth (the boot splash). May sound silly, but that has caused some strange problems for other users.
    Add “plymouth.enable=0” to your boot options.

I’m not sure where and how to add this boot option using Grub2 ?

AFAIK GNOME3 absolutely needs OpenGL/direct rendering to work, which isn’t the case with fbdev.

I’m not sure where and how to add this boot option using Grub2 ?

For one boot, press ‘e’ at the boot menu, search for the line starting with “linux” and append it there.

Or to add a boot option permanently, open YaST->System->Boot Loader, choose “Boot Loader Option” and edit the “Optional Kernel Command Line Parameter”.

Sorry, I have to correct myself there.
On 12.3 Mesa actually DOES support direct rendering with the fbdev driver (through the llvm software pipe), so GNOME should work. (this hasn’t been the case in earlier openSUSE versions, that’s why there was GNOME fallback mode)
I just tested in on my (radeon) system.

But maybe the non-working GNOME in recovery mode is caused by the nvidia driver? This overrides some parts of Mesa with its own, so maybe that causes problems with the fbdev driver then?

A hybrid system is a system with 2 integrated graphics, e.g. Intel and NVIDIA.
For low power use you can switch to the Intel chip, and if you need higher graphics performance you can switch to the NVIDIA chip (which uses more power and produces more heat).
NVidia’s technology for switching between the two chipsets is called “Optimus”, see here:
Nvidia Optimus - Wikipedia, the free encyclopedia

Your laptop apparently has an Intel PM965 chipset, which according to List of Intel chipsets - Wikipedia, the free encyclopedia doesn’t have integrated graphics.
So it can’t be a hybrid system, you only have the NVIDIA graphics.