12.3 new install, more radeon graphics problems

I realize that there is quite an extensive set of recent posts on radeon modeset graphics problems. However, it appears to me that many are after an upgrade, so perhaps my problem is different. I had a working 11.4 desktop with both 6670 and 6800 Series cards installed, using the fglrx driver(x86_64, AMD 8120). I did an new 12.3 install from a DVD burned from the iso image. At the point that the machine reboots after the software installation and goes to hardware configuration, the screen display goes black, except for a rapidly pulsing dash, or underscore, in the upper right quadrant of the screen. It starts white, and ultimately becomes a green color. I am conjecturing that I am seeing the whole screen compressed to nothing as the hardware configuration occurs, and then the green occurs when the kdm login screen appears. In any event, if I hit the hardware restart, I do get a useful GRUB2 screen, and if I choose OpenSUSE 12.3 I end up with a green dash again. Editing the kernel command line in GRUB2 to add nomodeset does not change this. If I instead choose Advanced Options and boot to 12.3 Failsafe, I get the usual scrolling text that ends with Reached Target Graphical Interface. I can then use Cntl-Alt-F1 to get a login screen in text mode and login as root. If I do a lsmod I see that the radeon module is loaded. Each of the files 50-device.conf, 50-monitor.conf, 50-screen.conf are all comments. The tail of the Xorg.0.log file ( I am hand copying here) shows:

[9.864] (II) FBDEV: driver for framebuffer: fbdev
[9.864] (II) VESA: driver VESA chipsets: vesa
[9.864] (**) using VT number 7
[9.919] (II) modesetting(0): using drv /dev/dri/card1
[9.919] (II) modesetting(G0): using drv /dev/dri/card0
[9.919] (WW) Falling back to old prove method fbdev
[9.919] (II) Loading submodule “fbdevhw”
[9.919] (II) LoadModule: “fbdevhw”
[9.920] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[9.920] (II) Module fbdevhw: vendor=“X.Org Foundation”
[9.920] compiled for 1.13.2, module version=0.0.2
[9.920] ABI class: X.Org Video Driver, version 13.1
[9.920] (WW) Falling back to old probe method for vesa
[9.948] (EE) modesetting(0): Specified fbbpp(728721696) is not a permitted value
[9.948] (II) UnloadModule: “modesetting”
[9.948] (EE) modesetting(G0): Specified fbbpp(728721696) is not a permitted value
[9.948] (II) UnloadModule: “modesetting”
[9.948] (EE) Screen(s) found, but none have a usable configuration

Fatal Server Error

[9.952] Server terminated with error(1)


modprobe -r radeon
modprobe -r drm
modprobel radeon modeset=1

causes my text screen go away (with a flash) to be replaced by another black screen.

If it seems I am shooting in the dark here, trying anything I have read in other posts, without really knowing what I am doing, or what to expect, you would be correct.

Some connected questions:

  1. Should I remove one of the graphics cards to make this easier(?)
  2. If nothing works, since there seem to be many problems associated with the 3.7 kernel series in this regard, where can I find, download, and burn the iso image for a 12.2 install, which I believe uses kernels from the 3.4 series?

Thanks for any advice.

I answered one of my final questions by removing one of the graphics cards, the 6800 series. After doing so I begin to track the symptoms/results of several posts in
12.3 radeon modeset boot problem in this forum. If I add nomodeset to the kernel line in GRUB2 I get the gecko-on-the-vine screen briefly, then it blacks out, and the next display is a few lines leading up to Reached target Graphical Interface. Then Cntrl-Alt-F1 gets me to the login, and as root I look at the Xorg.0.log. Now I get a very long list of the hardware that the radeon driver supports, but at the tail of the file I first get several instances of

(II) [KMS] drm report modesetting isn’t supported

then messages as before about falling back to old probe method in fbdev and vesa, and then 4 instances of

(EE) Screen 0 deleted because no matching config section
(II) UnloadModule: “radeon”

and then

(II) modesetting(0): Create default Display subsection in Screen section

which is almost immediately followed by

(EE) modesetting(0): KMS doesn’t support dumb interface

and finally the Screen(s) not found error message.

If I go into /etc/X11/xorg.conf.d and edit 50-device.conf to uncomment the section commands and the Driver line, reboot, then I get the gecko-on-the-vine screen and nothing else, it just stalls.

Since this install seems headed for the trash, I thought what do I have to lose, and downloaded kernel 3.8.5 from Kernel:/stable/standard/. Booting with this kernel had no effect on these problems or the results I have just described. Can I revert to a 3.4 kernel just as I advanced to a 3.8 kernel?

I recommend you search to see if a bug has been raised on this yet (guidance here : https://en.opensuse.org/openSUSE:Submitting_bug_reports#Searching_for_bugs ) and if not , raise a bug report. You can use your openSUSE forum username and password when logging on to openSUSE bugzilla.

You could also consider raising a bug report on this upstream, as this is likely an upstream problem. https://bugs.freedesktop.org/ By doing such you increase your chances (IMHO) of getting a fix. You will need to setup a new account with the freedesktop bugzilla.

try the following, (assuming NO_KMS_IN_INITRD is set to yes)

from the black screen press Alt-F2 to reach a terminal

if successful,
(if it exists go to /usr/share/ati/ and run the fglrx un-installer and then reboot),

from the black screen press Alt-F2 to reach a terminal,
start yast and enable network in ‘Traditional Method with ifup’,
again in yast add repo Index of /mirror/amd-fglrx/openSUSE_12.3,
in yast program manager, search for fglrx, and select appropriate driver, and then update

if all has gone ok a reboot into the gui should be possible


Thank you Keellambert. Your procedure worked. I guess I am little surprised, though. I am sure I have seen several posts within the last 2 weeks that the existing fglrx driver would not work with XOrg 1.13, which is what comes with 12.3. But I also saw a post from you that using a development driver from AMD with the 3.8 kernel series also worked fine. So, has the new fglrx driver that works with 1.13 very recently been added to the ATI repository? I am not complaining if it has, just wondering at my good luck if so!

On Wed 03 Apr 2013 10:56:04 PM CDT, lrkeefe wrote:

Thank you Keellambert. Your procedure worked. I guess I am little
surprised, though. I am sure I have seen several posts within the last
2 weeks that the existing fglrx driver would not work with XOrg 1.13,
which is what comes with 12.3.

The legacy version of the ATI driver won’t work for the older cards…
Your card is still supported.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.1-desktop
up 2 days 7:04, 4 users, load average: 0.06, 0.06, 0.05
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile


You’re welcome, glad it helped


for HD 6XXX Series cards

the beta driver is available,
see ‘http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product=

if an attempt to install this driver is made, suggest
– first delete the installed one via yast
– then install the run file via the init 3 method


if it was necessary to use the line,

start yast and enable network in 'Traditional Method with ifup'

its recommended to re-set it back to the original setting

it was there only to get the network available for downloading while in init 3

have fun