12.3 boot hang on UEFI-GPT system w/ GRUB2-EFI

I am trying to boot OpenSUSE 12.3 on a GPT-partitioned UEFI system, specifically a Dell 5523 with the latest firmware installed. I have a vfat /boot/efi partition as /dev/sda1, ext4 /boot as /dev/sda2 and a BtrFS / partition on a second SSD drive, /dev/sdb1. I have manually added /boot/efi/EFI/opensuse/grubx64.efi to my firmware’s boot order and can successfully get to the brub boot menu screen. When I try to boot in UEFI mode it hangs after echoing “Loading initial ramdisk…” When I added “set page=1” and “set debug=all” options at the boot menu I got the following output pasted here.

Any help would be appreciated.

please post whatever you have to post to SUSE Paste. I get access denied trying your link.

This is CLOSED at the moment. Will be moved to Pre-Release/Beta.

Moved from Install/Boot/Login and open again.

apologies for the bad link, try this one instead.

I also tried booting into UEFI mode from the 12.3 build 370 install DVD and received what looks like a similar debug output. Screenshot here.

Bug reports about trying to boot openSUSE 12.3 RC1 in EFI have already been made.



Thank You,

The build-370 DVD I mentioned in #6 was actually from the 802363 bug thread. I don’t know if it’s just quirk of my particular hardware setup or if the bug needs to be re-opened. Sorry I forgot to include that in my original comment.

You have completely different problem. Which is actually smells more like upstream. Please open bug report (post number here), attach two screenshots you did and as detailed information about your hardware as possible (model, vendor, firmware version, etc). Of course, the first thing to check would be firmware update for your system.

Are you able to boot using 12.2 DVD? Are you able to boot using legacy BIOS and not UEFI? If yes, it could offer possibility to install openSUSE and do testing for grub2. You can convert to UEFI boot later.

Apologies for taking a while to write back. I seem to get the same error when booting from the 12.2 DVD in EFI mode but can boot fine from either DVD or HDD in legacy mode using GRUB2-EFI. I have checked that I am using the latest BIOS release. Where would i report this upstream?

Never mind, I found the grub bug forum. bug has been posted at #38403](https://savannah.gnu.org/bugs/index.php?38403)