12.3 and Nvidia FX5200, Segfault

After being unable to keep my old 12.2 system stable with the nvidia drivers I took the plunge to do a new install of 12.3. I followed the advice to patch the drivers and compile the kernel modules. All went as expected and the drivers were installed. First boot following I got this:


    33.426] 
X.Org X Server 1.13.2
Release Date: 2013-01-24
    33.426] X Protocol Version 11, Revision 0
    33.426] Build Operating System: openSUSE SUSE LINUX
    33.426] Current Operating System: Linux linux-vutm.site 3.7.10-1.4-default #1 SMP Fri Apr 19 12:06:34 UTC 2013 (8ef74f8) i686
    33.427] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.7.10-1.4-default root=UUID=7a61ede6-668a-451a-9722-853c8f2e49c5 resume=/dev/disk/by-id/scsi-SIBM-ESXSST336753LC_FN3HX1HSPS00007337Z3ZK-part5 splash=silent quiet nomodeset showopts
    33.427] Build Date: 30 April 2013  08:23:18AM
    33.427]  
    33.427] Current version of pixman: 0.28.2
    33.427]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    33.427] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    33.427] (==) Log file: "/var/log/Xorg.0.log", Time: Fri May 17 16:57:31 2013
    33.428] (==) Using config directory: "/etc/X11/xorg.conf.d"
    33.428] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    33.430] (==) No Layout section.  Using the first Screen section.
    33.430] (==) No screen section available. Using defaults.
    33.430] (**) |-->Screen "Default Screen Section" (0)
    33.430] (**) |   |-->Monitor "<default monitor>"
    33.430] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
    33.430] (==) Automatically adding devices
    33.430] (==) Automatically enabling devices
    33.430] (==) Automatically adding GPU devices
    33.445] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    33.445]     Entry deleted from font path.
    33.445] (==) FontPath set to:
    /usr/share/fonts/misc:unscaled,
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/ghostscript/,
    /usr/share/fonts/cyrillic:unscaled,
    /usr/share/fonts/truetype/,
    built-ins
    33.445] (==) ModulePath set to "/usr/lib/xorg/modules/updates,/usr/lib/xorg/modules"
    33.445] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
    33.445] (II) Loader magic: 0x8261620
    33.445] (II) Module ABI versions:
    33.445]     X.Org ANSI C Emulation: 0.4
    33.445]     X.Org Video Driver: 13.1
    33.446]     X.Org XInput driver : 18.0
    33.446]     X.Org Server Extension : 7.0
    33.446] (II) config/udev: Adding drm device (/dev/dri/card0)
    33.451] (--) PCI: (0:4:2:0) 1002:5159:1014:02c8 rev 0, Mem @ 0xe0000000/268435456, 0xd0300000/65536, I/O @ 0x00004400/256, BIOS @ 0x????????/131072
    33.451] (--) PCI:*(0:4:7:0) 10de:0322:1682:203e rev 161, Mem @ 0xd1000000/16777216, 0xd8000000/134217728, BIOS @ 0x????????/131072
    33.451] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    33.451] Initializing built-in extension Generic Event Extension
    33.451] Initializing built-in extension SHAPE
    33.451] Initializing built-in extension MIT-SHM
    33.451] Initializing built-in extension XInputExtension
    33.451] Initializing built-in extension XTEST
    33.451] Initializing built-in extension BIG-REQUESTS
    33.451] Initializing built-in extension SYNC
    33.451] Initializing built-in extension XKEYBOARD
    33.452] Initializing built-in extension XC-MISC
    33.452] Initializing built-in extension SECURITY
    33.452] Initializing built-in extension XINERAMA
    33.452] Initializing built-in extension XFIXES
    33.452] Initializing built-in extension RENDER
    33.452] Initializing built-in extension RANDR
    33.452] Initializing built-in extension COMPOSITE
    33.452] Initializing built-in extension DAMAGE
    33.453] Initializing built-in extension MIT-SCREEN-SAVER
    33.453] Initializing built-in extension DOUBLE-BUFFER
    33.453] Initializing built-in extension RECORD
    33.453] Initializing built-in extension DPMS
    33.453] Initializing built-in extension X-Resource
    33.453] Initializing built-in extension XVideo
    33.453] Initializing built-in extension XVideo-MotionCompensation
    33.453] Initializing built-in extension XFree86-VidModeExtension
    33.453] Initializing built-in extension XFree86-DGA
    33.453] Initializing built-in extension XFree86-DRI
    33.453] Initializing built-in extension DRI2
    33.453] (II) "glx" will be loaded by default.
    33.453] (II) LoadModule: "dri2"
    33.454] (II) Module "dri2" already built-in
    33.454] (II) LoadModule: "glamoregl"
    33.548] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
    33.981] (EE) Failed to load /usr/lib/xorg/modules/libglamoregl.so: /usr/lib/xorg/modules/libglamoregl.so: undefined symbol: _glapi_tls_Context
    33.982] (II) UnloadModule: "glamoregl"
    33.982] (II) Unloading glamoregl
    33.982] (EE) Failed to load module "glamoregl" (loader failed, 7)
    33.982] (II) LoadModule: "glx"
    33.984] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    34.078] (II) Module glx: vendor="NVIDIA Corporation"
    34.078]     compiled for 4.0.2, module version = 1.0.0
    34.078]     Module class: X.Org Server Extension
    34.078] (II) NVIDIA GLX Module  173.14.36  Tue Sep 11 12:33:25 PDT 2012
    34.078] Loading extension GLX
    34.078] (==) Matched fglrx as autoconfigured driver 0
    34.078] (==) Matched ati as autoconfigured driver 1
    34.078] (==) Matched nvidia as autoconfigured driver 2
    34.078] (==) Matched nouveau as autoconfigured driver 3
    34.078] (==) Matched nv as autoconfigured driver 4
    34.078] (==) Matched modesetting as autoconfigured driver 5
    34.078] (==) Matched fbdev as autoconfigured driver 6
    34.078] (==) Matched vesa as autoconfigured driver 7
    34.078] (==) Assigned the driver to the xf86ConfigLayout
    34.078] (II) LoadModule: "fglrx"
    34.087] (WW) Warning, couldn't open module fglrx
    34.088] (II) UnloadModule: "fglrx"
    34.088] (II) Unloading fglrx
    34.088] (EE) Failed to load module "fglrx" (module does not exist, 0)
    34.088] (II) LoadModule: "ati"
    34.091] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
    34.091] (II) Module ati: vendor="X.Org Foundation"
    34.091]     compiled for 1.13.1, module version = 7.0.0
    34.091]     Module class: X.Org Video Driver
    34.091]     ABI class: X.Org Video Driver, version 13.1
    34.091] (II) LoadModule: "radeon"
    34.093] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
    34.099] (EE) 
    34.099] (EE) Backtrace:
    34.099] (EE) 0: /usr/bin/Xorg (xorg_backtrace+0x49) [0x81eb2c9]
    34.099] (EE) 1: /usr/bin/Xorg (0x8048000+0x1a71d6) [0x81ef1d6]
    34.099] (EE) 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xb76f6410]
    34.099] (EE) 
    34.099] (EE) Segmentation fault at address 0x0
    34.099] 
Fatal server error:
    34.099] Caught signal 11 (Segmentation fault). Server aborting
    34.099] 
    34.099] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
    34.099] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    34.100] (EE) 




Your Xserver tries to load the ati drivers… Are you sure you only have an NVIDIA card?
Please post the output of:

hwinfo --gfxcard

You could try to explicitely set the nvidia driver in /etc/X11/xorg.conf.d/50-device.conf or /etc/X11/xorg.conf

Onboard video seems to be conflicting with the Nvidia. HW manager indicates both are on the same IRQ! Thats weird and no wonder its failing.

 hwinfo --gfxcard 25: PCI 402.0: 0300 VGA compatible controller (VGA)                [Created at pci.319]   Unique ID: i_aO.90L+kFsCcY5   Parent ID: 6NW+.k8q0T1+16w3   SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:04:02.0   SysFS BusID: 0000:04:02.0   Hardware Class: graphics card   Model: "ATI Radeon VE"   Vendor: pci 0x1002 "ATI Technologies Inc"   Device: pci 0x5159 "Radeon VE"   SubVendor: pci 0x1014 "IBM"   SubDevice: pci 0x02c8 "eServer xSeries server mainboard"   Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)   I/O Ports: 0x4400-0x44ff (rw)   Memory Range: 0xd0300000-0xd030ffff (rw,non-prefetchable)   Memory Range: 0xd0320000-0xd033ffff (ro,non-prefetchable,disabled)   IRQ: 11 (85403 events)   Module Alias: "pci:v00001002d00005159sv00001014sd000002C8bc03sc00i00"   Driver Info #0:     XFree86 v4 Server Module: radeon   Driver Info #1:     XFree86 v4 Server Module: radeon     3D Support: yes     Color Depths: 16     Extensions: dri     Options:    Config Status: cfg=no, avail=yes, need=no, active=unknown   Attached to: #19 (PCI bridge)  26: PCI 407.0: 0300 VGA compatible controller (VGA)   [Created at pci.319]   Unique ID: 4Yqk.vqh67poEKW4   Parent ID: 6NW+.k8q0T1+16w3   SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:04:07.0   SysFS BusID: 0000:04:07.0   Hardware Class: graphics card   Model: "nVidia GeForce FX 5200"   Vendor: pci 0x10de "nVidia Corporation"   Device: pci 0x0322 "GeForce FX 5200"   SubVendor: pci 0x1682 "XFX Pine Group Inc."   SubDevice: pci 0x203e    Revision: 0xa1   Driver: "nvidia"   Driver Modules: "nvidia"   Memory Range: 0xd1000000-0xd1ffffff (rw,non-prefetchable)   Memory Range: 0xd8000000-0xdfffffff (ro,non-prefetchable)   Memory Range: 0xd0340000-0xd035ffff (ro,non-prefetchable,disabled)   IRQ: 11 (85403 events)   Module Alias: "pci:v000010DEd00000322sv00001682sd0000203Ebc03sc00i00"   Driver Info #0:     XFree86 v4 Server Module: nvidia   Driver Info #1:     XFree86 v4 Server Module: nvidia     3D Support: yes   Config Status: cfg=no, avail=yes, need=no, active=unknown   Attached to: #19 (PCI bridge)  Primary display adapter: #25 

I’ll see if I can disable the onboard but IIRC correctly there is nothing in the bios to do it and the OS is tasked with managing it.

OK I’ve upgraded the bios on the machine as there was an update available. Tried setting Device “nvidia” in 50-device.conf. Failed, so am looking at what I got wrong…

openSUSE-12.3 with a 3.7.x kernel and the nvidia driver built manually for the FX5200 do work (with a patch). I blogged about how to do this here: https://forums.opensuse.org/blogs/oldcpu/nvidia-173-14-36-graphic-driver-nvidia-nv34-fx5200-graphics-device-3-7-x-newer-kernels-125/

Note you need to do 3 things:

  • create the sim link
  • patch the driver
  • add your regular user to group Video

Note that patch does not work with a kernel > 3.7.x. A different patch for kernel > 3.7.x is needed (where there is such a patch referenced in other distribution’s threads, but I have not been able to extract the > 3.7.x kernel nvidia driver patch from the rpm/deb files from whence it is distributed) and hence for now I recommend you remain on a 3.7.x kernel if you wish the nvidia driver to work.

Thanks for the response. I actually tried your method first and got the initial SegFault. As explained above it appears to be a problem of two drivers trying to claim a common resource. I thought putting the entry in 50-device.conf would force the nvidia driver to load but it appears to not recognise “nvidia” as a driver name. Have I got that wrong?? “nv” is nouveau isn’t it?? What does blacklisting do, should I blacklist the ati drivers so they don’t load? If I didn’t need acceleration I wouldn’t bother but my CAD program requires it so I persist!!!

‘nvidia’ is the proprietary driver name, but if the driver is not functioning or not installed then that won’t work

‘nv’ is not ‘nouveau’. ‘nv’ is an older graphic driver that works with the FX5200 graphics (and other nvidia graphics). In the case of the FX5200 and the ‘nv’ driver, I believe there was a bug on the ‘nv’ driver for FX5200 graphics where 1024x768 is the maximum resolution. I recall reading it was decided not to fix that bug in the ‘nv’ but rather effort assigned to improve the ‘nouveau’ driver. The ‘nouveau’ driver is syntactically called the ‘nouveau’ driver.

blacklisting stops a kernel module from loading (I believe) - where drivers will be kernel modules. Do you have ATI hardware ? If no ATI hardware then you should not need to blacklist ATI graphic drivers.

I note in your first post:

I can not figure out what you are doing with that kernel load line and ‘nomodeset’ given you wish to use the proprietary ‘nvidia’ driver.

Note if you wish the proprietary nvidia driver to load, you should not IMHO boot with the ‘nomodeset’ boot code. My recommendation is to remove the ‘nomodeset’ from BEFORE ‘showopts’.

Out of curiousity, which boot manager are you using ? Legacy grub or grub2 ?

Thanks again, clarified the nv nouveau thing nicely.
I do have on board ATI that I never had issues with in the past but this time I did it seems!
So I have blacklisted the radeon driver and believe it or not I HAVE A WORKING DISPLAY!! Sorry to shout, been ,messing with this thing for days!!

I have nomodeset in there because of the “reached graphical target” stoppage we ran into. I’ll attempt to get rid of it but the funny thing is that 12.3 seems to have changed things and the machine booted up with the correct resolution. That never happened before so I’m a bit miffed. I checked that nvidia settings worked and the OpenGL was all there and its all sweet.
On your questioning I’ll attempt to remove the nomodeset and report back.

This is running Grub2.

Cheers

Glad to read progress was made. Note there are a number of other users on our Forum who pitch in to help with graphics, who are much more knowledgeable than I on this subject, so next time possibly consider posting earlier for help, as it may help speed up things. I mainly dove into this thread as I also have an FX5200 nvidia card.

It puzzles me that this booted to the nvidia driver with ‘nomodeset’. My understanding is that by setting ‘nomodeset’ as a boot code, one disables the ‘kernel mode settings’ (KMS) where KMS helps automatically identify and configure one’s graphics. Now likely KMS was confused with your having radeon and nvidia graphics, and it had to choose one of the two. Blacklisting the radeon hardware would help. But that still does not explain why the ‘nvidia’ driver was chosen (with 'nomodeset boot code) over the VESA or FBDEV graphic driver. Could it be that you have an /etc/X11/xorg.conf.d/50-device.conf file in place where ‘nvidia’ is specified ?

Note on my PC with the FX5200 graphics, I boot without ‘nomodeset’, with no /etc/X11/xorg.conf and will all content inside the /etc/X11/xorg.conf.d/50-device.conf file commented out, and the proprietary ‘nvidia’ driver works (after having built it per my blog entry). Hence I’m thinking you have entries in 50-device.conf specifying ‘nvidia’ ?

Ok, thanks. I find Grub2 a bit trickier to custom configure than ‘grub’ and when it came to removing the ‘nomodeset’ entry you may need some help ? … I avoid grub2 myself, although I believe the days of legacy grub are numbered and eventually I will need to use grub2 on all my openSUSE PCs.

So nice to have this running correctly. I understand your motivations also. Your assistance has been valuable!

Read through this, it might confuse you more :slight_smile:
Still not got SusePaste working, I am a spammer according to it!!


    69.198] 
X.Org X Server 1.13.2
Release Date: 2013-01-24
    69.198] X Protocol Version 11, Revision 0
    69.198] Build Operating System: openSUSE SUSE LINUX
    69.198] Current Operating System: Linux linux-vutm.site 3.7.10-1.4-default #1 SMP Fri Apr 19 12:06:34 UTC 2013 (8ef74f8) i686
    69.198] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.7.10-1.4-default root=UUID=7a61ede6-668a-451a-9722-853c8f2e49c5 resume=/dev/disk/by-id/scsi-SIBM-ESXSST336753LC_FN3HX1HSPS00007337Z3ZK-part5 splash=silent quiet nomodeset showopts
    69.198] Build Date: 30 April 2013  08:23:18AM
    69.198]  
    69.198] Current version of pixman: 0.28.2
    69.198]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    69.198] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    69.199] (==) Log file: "/var/log/Xorg.0.log", Time: Sat May 18 20:03:43 2013
    69.199] (==) Using config directory: "/etc/X11/xorg.conf.d"
    69.199] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    69.201] (==) No Layout section.  Using the first Screen section.
    69.201] (==) No screen section available. Using defaults.
    69.201] (**) |-->Screen "Default Screen Section" (0)
    69.201] (**) |   |-->Monitor "<default monitor>"
    69.202] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
    69.202] (==) Automatically adding devices
    69.202] (==) Automatically enabling devices
    69.202] (==) Automatically adding GPU devices
    69.203] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    69.203]     Entry deleted from font path.
    69.203] (==) FontPath set to:
    /usr/share/fonts/misc:unscaled,
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/ghostscript/,
    /usr/share/fonts/cyrillic:unscaled,
    /usr/share/fonts/truetype/,
    built-ins
    69.203] (==) ModulePath set to "/usr/lib/xorg/modules/updates,/usr/lib/xorg/modules"
    69.203] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
    69.204] (II) Loader magic: 0x8261620
    69.204] (II) Module ABI versions:
    69.204]     X.Org ANSI C Emulation: 0.4
    69.204]     X.Org Video Driver: 13.1
    69.204]     X.Org XInput driver : 18.0
    69.204]     X.Org Server Extension : 7.0
    69.207] (--) PCI: (0:4:2:0) 1002:5159:1014:02c8 rev 0, Mem @ 0xe0000000/268435456, 0xd0300000/65536, I/O @ 0x00004400/256, BIOS @ 0x????????/131072
    69.208] (--) PCI:*(0:4:7:0) 10de:0322:1682:203e rev 161, Mem @ 0xd1000000/16777216, 0xd8000000/134217728, BIOS @ 0x????????/131072
    69.208] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    69.208] Initializing built-in extension Generic Event Extension
    69.208] Initializing built-in extension SHAPE
    69.208] Initializing built-in extension MIT-SHM
    69.208] Initializing built-in extension XInputExtension
    69.208] Initializing built-in extension XTEST
    69.208] Initializing built-in extension BIG-REQUESTS
    69.208] Initializing built-in extension SYNC
    69.208] Initializing built-in extension XKEYBOARD
    69.208] Initializing built-in extension XC-MISC
    69.208] Initializing built-in extension SECURITY
    69.208] Initializing built-in extension XINERAMA
    69.208] Initializing built-in extension XFIXES
    69.208] Initializing built-in extension RENDER
    69.208] Initializing built-in extension RANDR
    69.208] Initializing built-in extension COMPOSITE
    69.208] Initializing built-in extension DAMAGE
    69.209] Initializing built-in extension MIT-SCREEN-SAVER
    69.209] Initializing built-in extension DOUBLE-BUFFER
    69.209] Initializing built-in extension RECORD
    69.209] Initializing built-in extension DPMS
    69.209] Initializing built-in extension X-Resource
    69.209] Initializing built-in extension XVideo
    69.209] Initializing built-in extension XVideo-MotionCompensation
    69.209] Initializing built-in extension XFree86-VidModeExtension
    69.209] Initializing built-in extension XFree86-DGA
    69.209] Initializing built-in extension XFree86-DRI
    69.209] Initializing built-in extension DRI2
    69.209] (II) "glx" will be loaded by default.
    69.209] (II) LoadModule: "dri2"
    69.209] (II) Module "dri2" already built-in
    69.209] (II) LoadModule: "glamoregl"
    69.237] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
    69.586] (EE) Failed to load /usr/lib/xorg/modules/libglamoregl.so: /usr/lib/xorg/modules/libglamoregl.so: undefined symbol: _glapi_tls_Context
    69.587] (II) UnloadModule: "glamoregl"
    69.587] (II) Unloading glamoregl
    69.587] (EE) Failed to load module "glamoregl" (loader failed, 7)
    69.587] (II) LoadModule: "glx"
    69.587] (II) Loading /usr/lib/xorg/modules/updates/extensions/libglx.so
    69.621] (II) Module glx: vendor="NVIDIA Corporation"
    69.621]     compiled for 4.0.2, module version = 1.0.0
    69.622]     Module class: X.Org Server Extension
    69.622] (II) NVIDIA GLX Module  173.14.37  Wed Mar  6 17:14:50 PST 2013
    69.622] Loading extension GLX
    69.622] (==) Matched nvidia as autoconfigured driver 0
    69.622] (==) Matched nouveau as autoconfigured driver 1
    69.622] (==) Matched nv as autoconfigured driver 2
    69.622] (==) Matched modesetting as autoconfigured driver 3
    69.622] (==) Matched fbdev as autoconfigured driver 4
    69.622] (==) Matched vesa as autoconfigured driver 5
    69.622] (==) Assigned the driver to the xf86ConfigLayout
    69.622] (II) LoadModule: "nvidia"
    69.622] (II) Loading /usr/lib/xorg/modules/updates/drivers/nvidia_drv.so
    69.713] (II) Module nvidia: vendor="NVIDIA Corporation"
    69.713]     compiled for 4.0.2, module version = 1.0.0
    69.713]     Module class: X.Org Video Driver
    69.739] (II) LoadModule: "nouveau"
    69.758] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
    69.788] (II) Module nouveau: vendor="X.Org Foundation"
    69.788]     compiled for 1.13.1, module version = 1.0.6
    69.788]     Module class: X.Org Video Driver
    69.788]     ABI class: X.Org Video Driver, version 13.1
    69.788] (II) LoadModule: "nv"
    69.790] (II) Loading /usr/lib/xorg/modules/drivers/nv_drv.so
    69.799] (II) Module nv: vendor="X.Org Foundation"
    69.799]     compiled for 1.13.1, module version = 2.1.20
    69.799]     Module class: X.Org Video Driver
    69.799]     ABI class: X.Org Video Driver, version 13.1
    69.799] (II) LoadModule: "modesetting"
    69.801] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
    69.801] (II) Module modesetting: vendor="X.Org Foundation"
    69.801]     compiled for 1.13.1, module version = 0.6.0
    69.801]     Module class: X.Org Video Driver
    69.801]     ABI class: X.Org Video Driver, version 13.1
    69.801] (II) LoadModule: "fbdev"
    69.803] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
    69.803] (II) Module fbdev: vendor="X.Org Foundation"
    69.803]     compiled for 1.13.1, module version = 0.4.3
    69.803]     Module class: X.Org Video Driver
    69.803]     ABI class: X.Org Video Driver, version 13.1
    69.803] (II) LoadModule: "vesa"
    69.804] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
    69.805] (II) Module vesa: vendor="X.Org Foundation"
    69.805]     compiled for 1.13.1, module version = 2.3.2
    69.805]     Module class: X.Org Video Driver
    69.805]     ABI class: X.Org Video Driver, version 13.1
    69.805] (II) NVIDIA dlloader X Driver  173.14.37  Wed Mar  6 17:02:37 PST 2013
    69.805] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
    69.805] (II) NOUVEAU driver 
    69.805] (II) NOUVEAU driver for NVIDIA chipset families :
    69.805]     RIVA TNT        (NV04)
    69.805]     RIVA TNT2       (NV05)
    69.805]     GeForce 256     (NV10)
    69.805]     GeForce 2       (NV11, NV15)
    69.805]     GeForce 4MX     (NV17, NV18)
    69.805]     GeForce 3       (NV20)
    69.805]     GeForce 4Ti     (NV25, NV28)
    69.805]     GeForce FX      (NV3x)
    69.805]     GeForce 6       (NV4x)
    69.806]     GeForce 7       (G7x)
    69.806]     GeForce 8       (G8x)
    69.806]     GeForce GTX 200 (NVA0)
    69.806]     GeForce GTX 400 (NVC0)
    69.806] (II) NOUVEAU driver 
    69.806] (II) NOUVEAU driver for NVIDIA chipset families :
    69.806]     RIVA TNT        (NV04)
    69.806]     RIVA TNT2       (NV05)
    69.806]     GeForce 256     (NV10)
    69.806]     GeForce 2       (NV11, NV15)
    69.806]     GeForce 4MX     (NV17, NV18)
    69.806]     GeForce 3       (NV20)
    69.806]     GeForce 4Ti     (NV25, NV28)
    69.806]     GeForce FX      (NV3x)
    69.807]     GeForce 6       (NV4x)
    69.807]     GeForce 7       (G7x)
    69.807]     GeForce 8       (G8x)
    69.807]     GeForce GTX 200 (NVA0)
    69.807]     GeForce GTX 400 (NVC0)
    69.807] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    69.807] (II) FBDEV: driver for framebuffer: fbdev
    69.807] (II) VESA: driver for VESA chipsets: vesa
    69.807] (++) using VT number 7
SNIP Rest Following

No nothing there and no xorg.conf file

Change is inevitable, you’ll be fine :slight_smile:


    69.807] (II) Loading sub module "fb"
    69.807] (II) LoadModule: "fb"
    69.808] (II) Loading /usr/lib/xorg/modules/libfb.so
    69.809] (II) Module fb: vendor="X.Org Foundation"
    69.809]     compiled for 1.13.2, module version = 1.0.0
    69.809]     ABI class: X.Org ANSI C Emulation, version 0.4
    69.809] (II) Loading sub module "wfb"
    69.809] (II) LoadModule: "wfb"
    69.810] (II) Loading /usr/lib/xorg/modules/libwfb.so
    69.823] (II) Module wfb: vendor="X.Org Foundation"
    69.823]     compiled for 1.13.2, module version = 1.0.0
    69.823]     ABI class: X.Org ANSI C Emulation, version 0.4
    69.823] (II) Loading sub module "ramdac"
    69.823] (II) LoadModule: "ramdac"
    69.823] (II) Module "ramdac" already built-in
    69.845] (WW) Falling back to old probe method for modesetting
    69.845] (EE) open /dev/dri/card0: No such file or directory
    69.845] (WW) Falling back to old probe method for fbdev
    69.845] (II) Loading sub module "fbdevhw"
    69.845] (II) LoadModule: "fbdevhw"
    69.846] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
    69.846] (II) Module fbdevhw: vendor="X.Org Foundation"
    69.846]     compiled for 1.13.2, module version = 0.0.2
    69.846]     ABI class: X.Org Video Driver, version 13.1
    69.847] (WW) Falling back to old probe method for vesa
    69.847] (II) NVIDIA(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
    69.847] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
    69.847] (==) NVIDIA(0): RGB weight 888
    69.847] (==) NVIDIA(0): Default visual is TrueColor
    69.847] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
    69.847] (**) NVIDIA(0): Enabling RENDER acceleration
    69.847] (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
    69.847] (II) NVIDIA(0):     enabled.
    70.557] (II) NVIDIA(0): NVIDIA GPU GeForce FX 5200 (NV34) at PCI:4:7:0 (GPU-0)
    70.557] (--) NVIDIA(0): Memory: 131072 kBytes
    70.557] (--) NVIDIA(0): VideoBIOS: 04.34.20.27.02
    70.557] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
    70.558] (--) NVIDIA(0): Connected display device(s) on GeForce FX 5200 at PCI:4:7:0:
    70.558] (--) NVIDIA(0):     ViewSonic VA2448 SERIES (CRT-0)
    70.558] (--) NVIDIA(0): ViewSonic VA2448 SERIES (CRT-0): 350.0 MHz maximum pixel
    70.558] (--) NVIDIA(0):     clock
    70.558] (II) NVIDIA(0): Assigned Display Device: CRT-0
    70.558] (==) NVIDIA(0): 
    70.558] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
    70.559] (==) NVIDIA(0):     will be used as the requested mode.
    70.559] (==) NVIDIA(0): 
    70.559] (II) NVIDIA(0): Validated modes:
    70.559] (II) NVIDIA(0):     "nvidia-auto-select"
    70.559] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
    70.560] (--) NVIDIA(0): DPI set to (93, 94); computed from "UseEdidDpi" X config
    70.560] (--) NVIDIA(0):     option
    70.560] (==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
    70.560] (II) UnloadModule: "nouveau"
    70.560] (II) Unloading nouveau
    70.560] (II) UnloadModule: "nv"
    70.560] (II) Unloading nv
    70.560] (II) UnloadModule: "modesetting"
    70.560] (II) Unloading modesetting
    70.561] (II) UnloadModule: "fbdev"
    70.561] (II) Unloading fbdev
    70.561] (II) UnloadSubModule: "fbdevhw"
    70.561] (II) Unloading fbdevhw
    70.561] (II) UnloadModule: "vesa"
    70.561] (II) Unloading vesa
    70.561] (--) Depth 24 pixmap format is 32 bpp
    70.563] (II) NVIDIA(0): Initialized GPU GART.
    70.566] (II) NVIDIA(0): Unable to connect to the ACPI daemon; the ACPI daemon may not
    70.566] (II) NVIDIA(0):     be running or the "AcpidSocketPath" X configuration option
    70.566] (II) NVIDIA(0):     may not be set correctly.  When the ACPI daemon is
    70.566] (II) NVIDIA(0):     available, the NVIDIA X driver can use it to receive ACPI
    70.566] (II) NVIDIA(0):     events.  For details, please see the "ConnectToAcpid" and
    70.566] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
    70.566] (II) NVIDIA(0):     Config Options in the README.
    70.566] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
    70.865] Loading extension NV-GLX
    70.886] (II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
    70.891] (II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
    70.891] (==) NVIDIA(0): Backing store disabled
    70.891] (==) NVIDIA(0): Silken mouse enabled
    70.892] (==) NVIDIA(0): DPMS enabled
    70.892] Loading extension NV-CONTROL
    70.893] (==) RandR enabled
    70.914] (II) Initializing extension GLX














Looks fine now.:slight_smile:

For clarification: You need either “nomodeset” or blacklist the nouveau driver for the nvidia driver to work correctly.

And there are driver RPMs available in the NVIDIA repo even for your graphics card (the repo should be listed in Yast->Software Repositories->Add->Community Repositories). You would need the packages “nvidia-gfxG01-kmp-default” and “x11-video-nvidiaG01” from there…

I confess to not undertanding why the nvidia proprietary driver loads with ‘nomodeset’ assigned and no configuration file specifying the ‘nvidia’ driver to load. Typically by specifying ‘nomodeset’ one can then go to the ‘vesa’ or ‘fbdev’ driver … but I’m guessing in this case if one wished to load the ‘fbdev’ or ‘vesa’ driver one would need the boot code ‘x11failsafe’.

I note ‘modesetting’ is being loaded (possibly by ‘X’ ? ) even though ‘nomodeset’ was specified as a kernel boot code.

Interesting … and educational.

The nvidia driver doesn’t use Kernel Modesetting because it’s proprietary.
The “nomodeset” or blacklist is needed to prevent the nouveau kernel module from being loaded and claim the graphics card, which would prevent the nvidia driver from loading.

If you don’t have a driver specified in xorg.conf or xorg.conf.d, X uses auto-configuration. It tries a list of drivers depending on your graphics card, and then uses the first one that it succeeds to load. For an NVIDIA card this list would be nvidia->nouveau->nv->modesetting->fbdev->vesa as can be seen in the Xorg.0.log.
(nouveau and modesetting need KMS, so if you don’t have the nvidia driver installed specifying nomodeset would cause nv or fbdev to be used)

You can also specify more than one driver I think, then all of those will be tried and one that doesn’t fail will be used.

If you specify x11failsafe xorg.conf.install is used for X’s configuration, which is created by the installation system and also contains a list of drivers…

And “modesetting” is a generic X driver similar to vesa (but it uses KMS, obviously ;)).

Thanks a bunch, that really clarifies the process! Such a robust approach yet clearly it is not able to handle the situation I had. Why this has occurred now and with this update I find a bit puzzling. In the case of the added options created by more than one video card it appears to be unable to manage the two. Is that an X issue or Linux? Just curious as to what changed. I guess X is older so it is most likely a kernel issue???
Thanks again,

Well, the problem is, I think, that according to hwinfo both cards seem to be active. So the kernel drivers and X drivers for both cards are loaded. And the readeon driver crashes.
So the difference could be that maybe the radeon driver did not crash before (so a new bug in X or the radeon driver), or that the ATI card got disabled before (would be the kernel update I suppose).
When you blacklist the radeon kernel module, the radeon X driver can’t be loaded and therefor X doesn’t crash.

Maybe you should report a bug at http://bugzilla.novell.com/ against X, since that’s what crashes. (you can use the same username/password as here)

Cheers, will do.

Don’t know if Stefan will read this but I tried to put “nvidia” in the 50-device.conf and it complained it could not be found.

You should answer in the bugreport. I don’t think he will read that here, especially since you didn’t mention this forum thread in the bugreport.:wink:

But: if you got an error that nvidia was not found, I really think you did something wrong.
/etc/X11/xorg.conf.d/50-device.conf should look similar to this:

Section "Device"
  Identifier "Default Device"
  Driver "nvidia"
EndSection

Lines starting with ‘#’ are just comments, they are ignored. So you could just append the above to the existing file.

So, please try to do that again and see if it works or if X still doesn’t start. (don’t forget to remove the “radeon” blacklist…)
Then add your findings to the bugreport.