12.3-64 UEFI boot attempt didn't work as expected! Please help again!

Hi list, moderators! I’ve been here before and thought I had this figured out!

Environment is 12.3 install DVD on Asus mobo P8Z77-M LK. Cpu is i7-3770. My UEFI BIOS is up to date. It’s set to boot both UEFI and legacy.

My expectation was that installing this 12.3 would put grub2 into /boot/efi. Instead it put in a link of grub-efi back to grub2 and overwrote the previous grub2. What did I miss this time?

The crux of the problem seemed to be with the install CD in the drive, Once in the drive, all the UEFI went away! I couldn’t set the Secure Boot or UEFI only. Like the last time I overwrote the /boot code I was headed down the same path again. This time both OSes are 12.3-64.

This time I left the format checkbox for the /boot partition unchecked. My hope was to change the install name in the bootloader distributor line so it wouldn’t overwrite the other OS line. The installer made some fuss about that, like it wasn’t responsible if the boot didn’t work!

At the installation midpoint I edited the bootloader distributor line to change 12.3 to 12.3_alt. That seems to have got ignored.

I put this latest install into separate / and /home partitions. Both of those partitions are automounted by this latest install. I’m expecting my salvation to be that I copied the original /boot into the previous /usr/boot. With this saved I think I could replace the existing /boot and cause my overwritten system to boot.

What I would rather do is to restore the original /boot, but redo this install as a proper UEFI with the help of this thread. Heboland.

So the UEFI link is correct for grub2 in openSUSE 12.3. Did you select the DVD in your UEFI PC setup to boot from the hybrid DVD? That is not the same as just booting in standard mode from the DVD. We also know that installing openSUSE 12.3 into a 12.2 boot folder, not formatting /boot, does not work properly either. It is best to do a clean install of openSUSE 12.3 when using an efi boot setup.

Thank You,

It should have done what you saw.

It should also have put “grub.efi” and “grub.cfg” in “/boot/efi/EFI/opensuse”. However, your main “grub.cfg” will still be in “/boot/grub2”.

I’m not sure what that means. If all the UEFI went away, then you would not have a “/boot/efi”.

Probably a mistake, but not a serious one. I did that for one install, and the only problem was that I had some old kernels sitting around from an earlier install.

I’m not sure that change does anything.

If you had changed the distributor line from “openSUSE 12.3” to “openSUSE_alt 12.3”, that should have had an effect.

Can you give us the output from:


# ls -l /boot/efi/EFI/opensuse

(and put that in code tags).

Thanks for the responses guys!

jdmcdaniel3 let me answer you first. This is a clean install except for not formatting /boot. I have a pair of slash partitions /1 & /2 and a pair of home partitions /home1 & /home2. I’m here again because I have one boot partition and it got overwritten again.

Did you select the DVD in your UEFI PC setup to boot from the hybrid DVD? That is not the same as just booting in standard mode from the DVD.

This looks like where I went wrong. I think I can do the DVD selection, but what is a hybrid DVD? My install DVD is a commercial one I bought from OsDisk. Should this work for what want or are there two flavors of Install DVDs?

The /boot that got overwritten was another 12.3. I did end up with a lot of boot options, but they all lead to the same 12.3. What I was expecting was for the installer to create /boot/efi and put grub2 into that.

nrickert, sorry to bother you with this again! I had your notes with me when I did this. First I selected the boot order to be DVD, UEFI Hdd, Hdd. When I put the install DVD in, your notes said to press F12 and select EFI boot.

My Bios didn’t give me that option. I had to press F2 and the UEFI Hdd was gone from the boot order.

I think I made a mistake with the boot loader distributor rename. I changed it to openSuse alt_12.3 leaving a space between se & alt.

Again there’s no efi directory in /boot so what you asked for comes back “not found”

Instead let me give you ls -l /boot which looks like this:

frank[5005] ls -l /boot 
total 48088
-rw-r--r-- 1 root root      512 Apr 21 13:57 backup_mbr
lrwxrwxrwx 1 root root        1 Apr 21 13:51 boot -> .
-rw-r--r-- 1 root root     1484 Feb 26 06:33 boot.readme
-rw-r--r-- 1 root root   137539 Mar  1 05:16 config-3.7.10-1.1-desktop
drwxr-xr-x 2 root root     4096 Apr 21 13:51 grub
drwxr-xr-x 6 root root     4096 Apr 21 15:14 grub2
lrwxrwxrwx 1 root root        5 Mar  6 05:13 grub2-efi -> grub2
lrwxrwxrwx 1 root root       25 Apr 21 13:57 initrd -> initrd-3.7.10-1.1-desktop
-rw-r--r-- 1 root root 32060991 Apr 21 13:56 initrd-3.7.10-1.1-desktop
drwx------ 2 root root    16384 Mar 25 13:58 lost+found
-rw-r--r-- 1 root root   621056 Mar  6 05:10 message
-rw-r--r-- 1 root root   693512 Mar  1 07:27 symtypes-3.7.10-1.1-default.gz
-rw-r--r-- 1 root root   688005 Mar  1 07:44 symtypes-3.7.10-1.1-desktop.gz
-rw-r--r-- 1 root root   687142 Mar  1 06:44 symtypes-3.7.10-1.1-pae.gz
-rw-r--r-- 1 root root   669395 Mar  1 09:11 symtypes-3.7.10-1.1-xen.gz
-rw-r--r-- 1 root root   239396 Mar  1 07:42 symvers-3.7.10-1.1-desktop.gz
-rw-r--r-- 1 root root      500 Mar  1 07:42 sysctl.conf-3.7.10-1.1-desktop
-rw-r--r-- 1 root root  2007259 Mar  1 07:26 System.map-3.7.10-1.1-desktop
-rw-r--r-- 1 root root  6326893 Mar  1 07:42 vmlinux-3.7.10-1.1-desktop.gz
lrwxrwxrwx 1 root root       26 Apr 21 13:53 vmlinuz -> vmlinuz-3.7.10-1.1-desktop
-rw-r--r-- 1 root root  4958496 Mar  1 07:27 vmlinuz-3.7.10-1.1-desktop
frank[5006] 

This should be good for a laugh, but I did this to get a 12.3 kde as a dual boot with a 12.3 lxde! I know I could have added kde to my 12.3 lxde, but I didn’t want that for three reasons.

With my tiny internet BW, my up-to-date lxde would have installed all of kde from the net rather than use my install cd. Second, I may need to build a kernel to make my wireless work, so this could give me a kernel to burn. Third I wanted some practice to do a UEFI install properly!

Guess I’m getting that practice!

What do you guys think of the following plan? Assuming that my DVD will work for an UEFI boot, I’ll restore the /boot to be the original (12.3_lxde), then use the Bios UEFI to read the install DVD. Leave the /boot unformated since the install now will be loaded into /boot/efi. Heboland.

Sharing /boot between different installations is not recommended and leads to problems you observed.

-rw-r--r-- 1 root root   687142 Mar  1 06:44 symtypes-3.7.10-1.1-pae.gz

Are you trying to install 32 bit distribution?

Thank you arvidjaar!

Both of the 12.3 installations here are 64 bit.

Are you telling me the symtypes-3.7.10-1.1-pae.gz file will be different in /boot even if I can get the UEFI install to install into /boot/efi?

For the record I got my my 12.3-64_lxde back by overwriting the 12.3-64_kde files in /boot. This is of course too tedious to be considered a dual boot process! Rather it got me back to my starting point before the attemped UEFI install of 12.3-64_kde.

Now that I know I can get back to my starting point, I’m going to attempt the UEFI 12.3-64_kde again. Heboland.

He was telling you that “symtypes-3.7.10-1.1-pae.gz” only exists for 32-bit installs, and UEFI won’t work with 32-bit.

Very interesting nrickert!

He was telling you that “symtypes-3.7.10-1.1-pae.gz” only exists for 32-bit installs, and UEFI won’t work with 32-bit.

When I bought the 12.2 install DVD, it came in -32 and -64 versions. I bought the 12.2-64. When the 12.3 came out there was only a 12.3 DVD, neither -32 or -64. This 12.3 DVD installed on my old 32-bit tower after I installed it on this 64-bit tower.

Could it be this install DVD is only a 32-bit installer? How else could the 32-bit only /boot file end up there? Are there any more tests for 32 Vs 64 to figure out what I have installed? Surely I don’t have to enable 64-bits in the Bios!

Maybe the reason I’m having trouble with the UEFI install is that the only OS I have to install is only 32-bits! Heboland.

Yes, it looks that way.

The output of:


uname -a

will tell you what you are running. For 64 bit, there will be a “x86_64” in the output.

Thanks again nrickert!

Here’s one smoking gun:

 frank[5001] uname -a
Linux linux-uso4.heboland 3.7.10-1.1-desktop #1 SMP PREEMPT Thu Feb 28 15:06:29 UTC 2013 (82d3f21) i686 i686 i386 GNU/Linux
frank[5002]

I just took a look at the OsDisk website. They have a 64-bit 12.3 DVD listed now. Looking back to the 12.2-64 install, I never got the Oracle virtualBox to work. VB would crash formatting the virtual drive. With the 12.3-32 virtualBox just worked!

Do you think the UEFI Bios is smart enough to know whether the install DVD is 32 or 64 bit? If 32-bit UEFI is not allowed, that would seem necessary. I did notice during the 12.3-32bit_kde install some mention of 4GB of memory. I have 16GB, but 32-bits can only access 4GB.

Guess I’ll have to get another install DVD and start over from scratch. I’m inclined to get this disk from someone else! Heboland.

No, but it can tell whether the UEFI structure is there, and it isn’t there on the 32-bit DVD.

Part of the specification of UEFI seems to require 64 bit. I think you can run 32-bit linux under UEFI, as long as you boot it with 64-bit grub2-efi. But I don’t know of any distro packaging it that way.

I think your system should be able to access more than 4G. Both the “pae” kernel and the “desktop” kernel can access it through the use of PAE (Physical Address Extension)

The command “free” (at a terminal) will tell you how much memory your processor is seeing.

Right on again nrickert!

frank[5001] free
             total       used       free     shared    buffers     cached
Mem:      16279040     867440   15411600          0      41344     468496
-/+ buffers/cache:     357600   15921440
Swap:     40959996          0   40959996
frank[5002] 

I don’t mean to monopolize your time, but I have a follow-up question that may be of more general interest, if you please!

I’ve been advised elswhere on this forum that all the install DVD memory tests are 32-bit tests. Do they use PAE if the memory is over 4GB or do they just check the lower 4GB?

My reason for asking is that I’m expecting my tower to crash again with 12.3-64 when I try to run Oracle virtualBox. This tower will run the DVD memory test all day and night without a failure. It would help the Vb debug if I could rule out memory as the problem. Heboland.

AFAIK there is no address limit. The program is memtest86 I believe.

please read here Memtest86 - Wikipedia, the free encyclopedia

Thanks for the explanation and the link, gogalthorp!

Your response gives me more confidence in 64-bit memory testing from the install DVD.

Something I experienced on another thread here may be of interest in this thread. The 12.2-64 install DVD memory test has a bug in it. For me test 7 failed catastrophically!

The wiki information for me begs the question of an iso download from somewhere that would have both versions of the test on it.

My 12.3-64 bit install DVD is in the mail. I’m anxious to attempt my first real UEFI install. Heboland.