12.3 64 bit - reboot hangs, cold boots fine, won't power off after shutdown

Reboot hangs at “loading initial ramdisk”. I set a kernel parmeter of debug but nothing else printed out

I’m using EFI
I’ve tried various reboot=* options
I’ve installed the proprietary amd drivers (fixes problem where I can’t resume after suspend but not reboot) using the yast 1-click install for 64-bit
I’ve tried using nomodeset parameter - no affect

some system information:

Linux linux-421n.site 3.7.10-1.1-desktop #1 SMP PREEMPT Thu Feb 28 15:06:29 UTC 2013 (82d3f21) x86_64 x86_64 x86_64 GNU/Linux

display: :0 screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6520G
OpenGL version string: 4.2.12002 Compatibility Profile Context 9.012

linux-421n:~ # cat /etc/default/grub

Modified by YaST2. Last modification on Tue Mar 26 10:47:27 EDT 2013

THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader

For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader

If you change this file, run ‘grub2-mkconfig -o /boot/grub2/grub.cfg’ afterwards to update

/boot/grub2/grub.cfg.

GRUB_DISTRIBUTOR=“openSUSE 12.3”
GRUB_DEFAULT=saved
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=8
GRUB_CMDLINE_LINUX_DEFAULT=" debug"

kernel command line options for failsafe mode

GRUB_CMDLINE_LINUX_RECOVERY=“showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe”
GRUB_CMDLINE_LINUX=""

Uncomment to enable BadRAM filtering, modify to suit your needs

This works with Linux (no patch required) and with any kernel that obtains

the memory map information from GRUB (GNU Mach, kernel of FreeBSD …)

#GRUB_BADRAM=0x01234567,0xfefefefe,0x89abcdef,0xefefefef

Uncomment to disable graphical terminal (grub-pc only)

GRUB_TERMINAL=gfxterm

The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo’

GRUB_GFXMODE=auto

Uncomment if you don’t want GRUB to pass “root=UUID=xxx” parameter to Linux

#GRUB_DISABLE_LINUX_UUID=true

Uncomment to disable generation of recovery mode menu entries

#GRUB_DISABLE_LINUX_RECOVERY=true

Uncomment to get a beep at grub start

#GRUB_INIT_TUNE=“480 440 1”

Skip 30_os-prober if you experienced very slow in probing them

WARNING foregin OS menu entries will be lost if set true here

GRUB_DISABLE_OS_PROBER=false
GRUB_THEME=/boot/grub2/themes/openSUSE/theme.txt
GRUB_BACKGROUND=/boot/grub2/themes/openSUSE/background.png
GRUB_USE_LINUXEFI=true

May I suggest you give kernel 3.8.4 a try? I have a blog on the ways one can do that you can read here. Check out the many links on the subject and read down to the end: openSUSE and Installing New Linux Kernel Versions - Blogs - openSUSE Forums

Thank You,

I tried the latest stable kernel (3.8.5) using your script, but still get the same behavior, so I backed it out.
I’ve also tried the proprietary ati driver with no change.

this is an Acer aspire 5560 with a6-3420m 6gig (radeon hd 6520g/512MB shared)

I seem some ACPI warnings in dmesg. I’ve tried booting with acpi=off, but it doesn’t alter the outcome. below is the contents of dmesg w/out acpi=off

dmesg | grep -i acpi
0.000000] BIOS-e820: [mem 0x000000000008f000-0x000000000008ffff] ACPI NVS
0.000000] BIOS-e820: [mem 0x00000000bf251000-0x00000000bf350fff] ACPI NVS
0.000000] BIOS-e820: [mem 0x00000000bf351000-0x00000000bf3d0fff] ACPI data
0.000000] efi: ACPI=0xbf3d0000 ACPI 2.0=0xbf3d0014 SMBIOS=0xbf1d7000
0.000000] ACPI: RSDP 00000000bf3d0014 00024 (v02 ACRSYS)
0.000000] ACPI: XSDT 00000000bf3d0120 00074 (v01 ACRSYS ACRPRDCT 00000001 ANNI 00000001)
0.000000] ACPI: FACP 00000000bf3bb000 000F4 (v04 ACRSYS ACRPRDCT 00000001 PTL 00000001)
0.000000] ACPI: DSDT 00000000bf3bd000 11A03 (v01 ACRSYS ACRPRDCT 00001000 ANNI 00000001)
0.000000] ACPI: FACS 00000000bf32e000 00040
0.000000] ACPI: SLIC 00000000bf3cf000 00176 (v01 ACRSYS ACRPRDCT 00000001 ANNI 00000001)
0.000000] ACPI: HPET 00000000bf3ba000 00038 (v01 ACRSYS ACRPRDCT 00000001 PTL 00000001)
0.000000] ACPI: APIC 00000000bf3b9000 0007A (v02 ACRSYS ACRPRDCT 00000001 PTL 00000001)
0.000000] ACPI: MCFG 00000000bf3b8000 0003C (v01 ACRSYS ACRPRDCT 00000001 PTL 00000001)
0.000000] ACPI: UEFI 00000000bf3b7000 0003E (v01 ACRSYS ACRPRDCT 00000001 PTL 00000001)
0.000000] ACPI: UEFI 00000000bf3b6000 00042 (v01 PTL COMBUF 00000001 PTL 00000001)
0.000000] ACPI: SSDT 00000000bf3b5000 00E34 (v01 AMD POWERNOW 00000001 AMD 00000001)
0.000000] ACPI: SSDT 00000000bf3b3000 0193D (v02 AMD ALIB 00000001 MSFT 04000000)
0.000000] ACPI: UEFI 00000000bf3b2000 0021A (v01 ACRSYS ACRPRDCT 00000001 PTL 00000001)
0.000000] ACPI: Local APIC address 0xfee00000
0.000000] ACPI: PM-Timer IO Port: 0x808
0.000000] ACPI: Local APIC address 0xfee00000
0.000000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
0.000000] ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] enabled)
0.000000] ACPI: LAPIC (acpi_id[0x02] lapic_id[0x02] enabled)
0.000000] ACPI: LAPIC (acpi_id[0x03] lapic_id[0x03] enabled)
0.000000] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
0.000000] ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
0.000000] ACPI: LAPIC_NMI (acpi_id[0x02] high edge lint[0x1])
0.000000] ACPI: LAPIC_NMI (acpi_id[0x03] high edge lint[0x1])
0.000000] ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
0.000000] ACPI: IRQ0 used by override.
0.000000] ACPI: IRQ2 used by override.
0.000000] ACPI: IRQ9 used by override.
0.000000] Using ACPI (MADT) for SMP configuration information
0.000000] ACPI: HPET id: 0x43538210 base: 0xfed00000
0.007638] ACPI: Core revision 20120913
0.081071] PM: Registering ACPI NVS region [mem 0x0008f000-0x0008ffff] (4096 bytes)
0.081071] PM: Registering ACPI NVS region [mem 0xbf251000-0xbf350fff] (1048576 bytes)
0.081679] ACPI FADT declares the system doesn’t support PCIe ASPM, so disable it
0.081688] ACPI: bus type pci registered
0.083212] ACPI: Added _OSI(Module Device)
0.083212] ACPI: Added _OSI(Processor Device)
0.083212] ACPI: Added OSI(3.0 SCP Extensions)
0.083212] ACPI: Added OSI(Processor Aggregator Device)
0.085949] ACPI: EC: Look up EC in DSDT
0.094568] [Firmware Bug]: ACPI: BIOS OSI(Linux) query ignored
0.131094] ACPI: Interpreter enabled
0.131106] ACPI: (supports S0 S3 S4 S5)
0.131131] ACPI: Using IOAPIC for interrupt routing
0.131703] PCI: MMCONFIG at [mem 0xf8000000-0xfbffffff] reserved in ACPI motherboard resources
0.150479] ACPI: EC: GPE = 0x3, I/O: command/status = 0x66, data = 0x62
0.150850] ACPI: No dock devices found.
0.150860] PCI: Using host bridge windows from ACPI; if necessary, use “pci=nocrs” and report a bug
0.152007] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-ff])
0.161307] ACPI: PCI Interrupt Routing Table _SB
.PCI0.PRT]
0.161637] ACPI: PCI Interrupt Routing Table _SB
.PCI0.PB4
.PRT]
0.161717] ACPI: PCI Interrupt Routing Table _SB
.PCI0.PB6
.PRT]
0.161865] ACPI: PCI Interrupt Routing Table _SB
.PCI0.P2P
.PRT]
0.162224] pci0000:00: Requesting ACPI OSC control (0x1d)
0.162641] pci0000:00: ACPI OSC control (0x1d) granted
0.173983] ACPI: PCI Interrupt Link [LNKA] (IRQs 10 11) *0
0.174186] ACPI: PCI Interrupt Link [LNKB] (IRQs 10 11) *0
0.174261] ACPI: PCI Interrupt Link [LNKC] (IRQs 10 11) *0
0.174334] ACPI: PCI Interrupt Link [LNKD] (IRQs 10 11) *0
0.174397] ACPI: PCI Interrupt Link [LNKE] (IRQs 10 11) *0
0.174466] ACPI: PCI Interrupt Link [LNKF] (IRQs 10 11) *0
0.174535] ACPI: PCI Interrupt Link [LNKG] (IRQs 10 11) *0
0.174603] ACPI: PCI Interrupt Link [LNKH] (IRQs 10 11) *0
0.175236] ACPI: bus type scsi registered
0.175264] ACPI: bus type usb registered
0.175264] PCI: Using ACPI for IRQ routing
0.183350] pnp: PnP ACPI init
0.183377] ACPI: bus type pnp registered
0.184539] pnp 00:00: Plug and Play ACPI device, IDs PNP0a08 PNP0a03 (active)
0.184664] system 00:01: Plug and Play ACPI device, IDs PNP0c02 (active)
0.185441] pnp 00:02: Plug and Play ACPI device, IDs PNP0200 (active)
0.185548] pnp 00:03: Plug and Play ACPI device, IDs PNP0c04 (active)
0.185637] pnp 00:04: Plug and Play ACPI device, IDs PNP0b00 (active)
0.185665] pnp 00:05: Plug and Play ACPI device, IDs PNP0800 (active)
0.185905] system 00:06: Plug and Play ACPI device, IDs PNP0c02 (active)
0.186195] system 00:07: Plug and Play ACPI device, IDs PNP0c01 (active)
0.186415] pnp 00:08: Plug and Play ACPI device, IDs PNP0303 (active)
0.186521] pnp 00:09: Plug and Play ACPI device, IDs ETD0500 PNP0f0b PNP0f12 PNP0f03 PNP0f0e PNP0f13 (active)
0.186613] pnp: PnP ACPI: found 10 devices
0.186618] ACPI: ACPI bus type pnp unregistered
6.104240] ACPI: acpi_idle registered with cpuidle
6.116547] ACPI: Thermal Zone [TZS0] (45 C)
6.123127] ACPI: Thermal Zone [TZS1] (38 C)
18.860149] ACPI: Power Button [PWRB]
18.867958] ACPI: Lid Switch [LID0]
18.874358] ACPI: Sleep Button [SLPB]
18.876386] ACPI: Deprecated procfs I/F for AC is loaded, please retry with CONFIG_ACPI_PROCFS_POWER cleared
18.876655] ACPI: Power Button [PWRF]
18.887143] ACPI: AC Adapter [ADP1] (on-line)
18.896549] ACPI: Deprecated procfs I/F for battery is loaded, please retry with CONFIG_ACPI_PROCFS_POWER cleared
18.898660] ACPI: Battery Slot [BAT0] (battery present)
18.906324] ACPI Error: [SSZE] Namespace lookup failure, AE_ALREADY_EXISTS (20120913/dsfield-211)
18.908231] ACPI Error: Method parse/execution failed _SB
.PCI0.LPC0.EC0
.ADP1.PSR] (Node ffff880196e967b8), AE_ALREADY_EXISTS (20120913/psparse-536)
18.910281] ACPI Exception: AE_ALREADY_EXISTS, Error reading AC Adapter state (20120913/ac-122)
18.915392] ACPI Error: [SSZE] Namespace lookup failure, AE_ALREADY_EXISTS (20120913/dsfield-211)
18.917220] ACPI Error: Method parse/execution failed _SB
.PCI0.LPC0.EC0
.ADP1.PSR] (Node ffff880196e967b8), AE_ALREADY_EXISTS (20120913/psparse-536)
18.920899] ACPI Exception: AE_ALREADY_EXISTS, Error reading AC Adapter state (20120913/ac-122)
18.925412] ACPI: Marking method PSR as Serialized because of AE_ALREADY_EXISTS error
19.739770] acpi device:37: registered as cooling_device4
19.741716] ACPI: Video Device [VGA1] (multi-head: yes rom: no post: no)
19.789272] ACPI Warning: 0x0000000000000b00-0x0000000000000b07 SystemIO conflicts with Region _SB
.PCI0.SMB
.SMB0 1 (20120913/utaddress-251)
19.790842] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
20.351203] acpi-cpufreq: overriding BIOS provided _PSD data
20.356981] acer_wmi: Acer Laptop ACPI-WMI Extras
20.360632] acer_wmi: Brightness must be controlled by acpi video driver

I tried running the 3.8.5 kernel from the repository. This also failed - on a side note, after a couple boots it corrupted my efi partition and I ended up re-installing 12.3.

I tried running poweroff from runlevel 1. The last thing printed is:

[ACPI] : Preparing to enter system sleep state S5

Sounds like a hardware issue of some sort. Can you tell us all about this PC? Make, model, year, add-ons, options and such. All info is important.

Thank You,

It is an acer aspire 5560 laptop with 6 gig of ram (512MB goes to graphics)
AMD 3420M processor. The motherboard has the 1.15 bios (latest), which is what was on it out of the box. I got it at Christmas 2012. The machine came with win 7 (which would shutdown/reboot the machine with no problem), but I’ve wiped that off and just have linux now. I’ve tried a couple different distros (ubuntu, fedora, openSuse) and had similar problems on all. Ubuntu 12.10 with the 3.5.0-17 kernel would shutdown correctly, but the later kernel patches the distro supplied caused it to stop powering off.

Have you checked to see if any BIOS or UEFI updates exist for this Laptop PC?

Thank You,

as stated in my previous, the latest bios is already on the motherboard.

Regards

Sorry I missed that in your last post. I wonder if the issue is graphics related? I do not use AMD Radeon myself, but they seem to have a whole list specific kernel load commands when you use the built-in video driver. Such a command as radeon.modeset=0 or radeon.modeset=-1 for auto. Makes you wonder if it ignores the nomodeset command or what it is doing, but have a look here:

X.Org Wiki - RadeonFeature

And there is more stuff there one could try for your computer.

Thank You,

Take a look at this thread:

http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/484825-opensuse-12-3-shutdown-problems.html

It recommends this:

sudo zypper rm acpid

Is that a system which was upgraded from a previous version?

Remove acpid
it is not needed and conflicts on 12.3 with logind (on a fresh 12.3

install it does not exist).