12.2rc2 "GM" - on laptop, audio only plays in headphones, not speakers

Just installed openSUSE 12.1rc2 “GM” today and noticed that I can’t hear any audio out of my speakers from my laptop. I only hear sound from my headphones, so that at least tells me it’s working.

Here are the results of my /usr/sbin/alsa-info.sh:
http://www.alsa-project.org/db/?f=d02f515c6b9ae99078dafad302fd7d8af786556b

saultdon@d830-opensuse122:~> **rpm -qa '*alsa*'**
alsa-firmware-1.0.25-2.1.1.noarch
alsa-utils-1.0.25-3.2.2.x86_64
alsa-plugins-1.0.25-3.1.2.x86_64
alsa-oss-1.0.25-3.1.2.x86_64
alsa-1.0.25-3.5.1.x86_64
alsa-plugins-pulse-1.0.25-3.1.2.x86_64
saultdon@d830-opensuse122:~>** rpm -qa '*pulse*'**
pulseaudio-1.1-6.1.2.x86_64
libpulse0-1.1-6.1.2.x86_64
libxine2-pulse-1.2.2-5.1.2.x86_64
pulseaudio-utils-1.1-6.1.2.x86_64
pulseaudio-module-x11-1.1-6.1.2.x86_64
pulseaudio-module-zeroconf-1.1-6.1.2.x86_64
libpulse-mainloop-glib0-1.1-6.1.2.x86_64
pulseaudio-module-bluetooth-1.1-6.1.2.x86_64
pulseaudio-module-lirc-1.1-6.1.2.x86_64
alsa-plugins-pulse-1.0.25-3.1.2.x86_64
pulseaudio-module-jack-1.1-6.1.2.x86_64
saultdon@d830-opensuse122:~> **rpm -qa libasound2**
libasound2-1.0.25-3.5.1.x86_64
saultdon@d830-opensuse122:~> **cat /etc/modprobe.d/50-sound.conf**


options snd slots=snd-hda-intel
# u1Nb.bHIrUAw8+c5:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

I should probably also mention that the only extra package I’ve installed that wasn’t already there was alsa-firmware but that didn’t make it so sound comes out of my speakers.

saultdon wrote:

> Just installed openSUSE 12.1rc2 “GM” today

No such thing
It’s either RC2 or GM

GM is Gold Master, which will be released next week
Check your mixer settings
99/100 that’s the problem

https://lh4.googleusercontent.com/-BK8EQ19vDRc/UEOZsd87rUI/AAAAAAAAAgU/Xlbmmh7uaMc/s800/Audio.Mixer1.jpeg

https://lh6.googleusercontent.com/-Tyqhq8JTodY/UEOZqav9YPI/AAAAAAAAAgM/3dIglaytrS8/s800/Audio.Mixer.jpeg

If I switch the connector to headphones, the audio still comes out only for the headphone jack using the test buttons.

There is only one option for the sound card too and that is what the default is for the devices in the Device Preference panel.

Backend is GStreamer.

I also did an install of VLC from the VideoLAN repo for 12.2 and it installed a bunch of dependencies.

I immediately ran VLC and started playing a movie and some music from Amarok. The sound was coming out of the speakers!

I restarted the laptop and now it’s back to sound only from the headphone jack…

saultdon wrote:

> VLC from the VideoLAN repo

You should NOT use that repo, but rather just Packman

http://forums.opensuse.org/content/127-multimedia-restricted-formats-installation-guide-12-2.html

You could check the possibility that you do not have pulse audio tuned properly for your speakers. This blog entry may help a bit: Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

Thanks for the blog. It’s been helpful.
I downloaded and installed the pavucontrol utility but it shows the same thing. A single device again.

https://lh5.googleusercontent.com/-mpALpNowodE/UEUlgtGJTXI/AAAAAAAAAg4/KA49OEy14Dk/s800/pavu_OutputDevices.png

I changed it to Analog Stereo Output only and even tried Digital Stereo but still no sound from speakers.
https://lh4.googleusercontent.com/-r5duc5tj2EU/UEUlgse0D0I/AAAAAAAAAgw/fojUJqGDIoE/s800/pavu_Configuration.png

Here is the output from “aplay -l” and “arecord -l”:

saultdon@d830-opensuse:~> **aplay -l
****** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
saultdon@d830-opensuse:~> **arecord -l**
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

The audio worked fine in 12.1. I’m at a loss as to what is going on here. Is there any more information I can provide?

saultdon wrote:

> The audio worked fine in 12.1. I’m at a loss as to what is going on
> here. Is there any more information I can provide?
>
Well. You posted about using RC2 GM of 12.2
I did tell you there was no such thing exactly.
Except that you could be running RC2 that hs been 'dup’ed
Even so, you should have been asking in the pre-release forum.

Not long now and you can install 12.2 proper :smiley:

The mixer setting has this:


Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 14 [22%] -37.50dB] [on]

22% is very low. The scale is not linear, and so it is plausable that is a problem.

I assume you have checked YaST > Hardware > Sound > Other > Volume … ?

I forgot to check there! Got so much into checking the settings in kmix and pavucontrol that YaST slipped my mind.

The sliders in there say 100% already and the Test button doesn’t give me sound from the speakers again. Headphone jack is still working:

https://lh3.googleusercontent.com/-kmGXMbEBF6I/UEYkEJpkmWI/AAAAAAAAAhU/4cdleE35tRI/s800/YaST_Sound_Other_Volume.png

I re-ran that alsa-info.sh command and this time it says 100%. Maybe when I ran it earlier I had my audio turned down anyways?
http://www.alsa-project.org/db/?f=60d2d0f53a8c0255b7480e1969bd7fb71badacc6

Thanks for the help so far oldcpu - learning lots because I’ve never had to troubleshoot an audio issue before.

I just thought it was RC2 GM because I downloaded the openSUSE-DVD-Build0091-x86_64.iso on August 25th, after the technical contributions freeze and installed that.

On August 31st I ran an update with the default openSUSE repos and it installed a bunch of updates, about 200 give or take. I can’t remember how many exactly.
This coincided with the openSUSE Roadmap 12.2 release schedule and that’s what suggested to me I was working in GM because the ISO was still called “Build0091” so I called it “RC2 GM”.

So I should just call it GM without the RC2 or there is no such thing as GM* in my case* because those updates I got on Aug 31 were not for that and I needed a separate ISO for GM?

That’s possible, but I checked the sha1 and md5 sums before making a bootable USB and they matched for Build0091.

Given that the public release is tomorrow, would it matter to have this migrated? I forgot about the pre-release forum and went straight to the hardware forum because I am having a hardware issue. I don’t know how to move this thread, do I need to request that somehow?

I could try re-installing with the new ISO from the public release tomorrow, but would I get the same update results running a regular update or ‘dup’? I’ll check the update wiki again for details on how to do that properly again.

I don’t know why the speaker sounds are not working. I assume there is no hardware problem ?

You could try to modify the model option. The list of options from the HD-Audio-Model.txt file in the alsa documentation has this for the stac9205 on your Dell:


STAC9205/9254
=============
  ref		Reference board
  dell-m42	Dell (unknown)
  dell-m43	Dell Precision
  dell-m44	Dell Inspiron
  eapd		Keep EAPD on (e.g. Gateway T1616)
  auto		BIOS setup (default)

each option can be tried one at a time, and then alsa driver restarted (easy way to explain a way to restart alsa driver is to say to you to reboot) and then test the audio.

say you want to try the option “dell-m42”. Then you would add this line to the very start of your PC’s /etc/modprobe.d/50-sound.conf file:


options snd-hda-intel model=dell-m42

reboot and test.

Try each option one at a time. Some will make it worse. Others will make no difference. Maybe one will work.

Tried all of them and none would work. They all added a “dummy output” but that didn’t have any sound coming from the speakers or the headphone jack.

I then re-installed a fresh openSUSE 12.2 KDE x64 system from the DVD. Same problem, no audio from my speakers…

Is there something I can check in the boot process or something? Maybe this is a small bug because I only have the single audio card.

I also just went into **Yast2 - Sound **and highlighted my only card in the list and pressed “Delete” and re-configured it using the “automatic” option.

I can only hear audio from my headphones still…

Looks like I may of been experiencing some hardware failure.
The speakers don’t output audio on Win7 either.

Thanks for all the help trying to trouble shoot this. I wonder what kind of test I could of done to see if it was just my speakers crapping out b/c the sound card is still processing audio to my headphone jack (which I can just plug in some external speakers for now).

Tearing my laptop down tonight and checking for loose wires >:)

I have the same issue with a Fujitsu SIemens Lifebook 7020. Until the version 12.2 everything was fine. Last week I installed the new version. And no so sound at all only if I use the headphone. I tried everything which was recommended here in this forum and several other forums. I used different search engines, I spent hours and hours while I tried to solve this problem.

And finally I found a solution. The solution is: to reinstall Opensuse 12.1 again.:frowning:

I hope someone will find a real solution. After that I can install 12.2 again.

It wasn’t hardware failure.

What I did (you probably don’t have to do this…), was re-install openSUSE from the DVD and this time, removed pulse, installed alsa and disabled the pulse audio support during the configuration process (you have to make sure you don’t let the installer do automatic configuration). I’m pretty sure you can just do all this from YaST > Software Management and Sound.

When I booted the laptop, I could hear audio, but it was extremely faint.
I went into Kmix > Settings… > Configure Channels… and on the left pane I added PCM to the right pane under Visible Channels. Not sure what PCM is.
I don’t remember seeing the PCM channel in pavucontrol either. Probably had to enable it like I did in kmix.

The master channel is set to Master, by default.
So now I have three channels with volume sliders, Master / PCM / Headphone.

I get audio now when I turn up PCM to max and can use Master as the overall volume.

Now that I turned PCM up, audio is working in my Windows 7 as well. Strange that that hardware volume setting for PCM is hardcoded or something…