12.2 RC2 discussion thread

I have installed RC2 in one system. I’ll try on another later.

One problem, which I’ll report in a followup to this post.

First problem with RC2 - crypto did not work on initial boot.

Background. Both “/home” and swap are using LUKS encryption.

On the first boot, the system hung at:

Creating device nodes with udev

I have no idea of the cause, but am guessing that it might have been crypto-related. I had to force power off.

Booted a different system (12.1 on the same computer). Running “fsck” showed no problems. Since I forced power off, I think that means that no file system had been mounted.

I edited grub.cfg (in “/boot/grub2”), and removed “splash=silent quiet” from the kernel line.

I then tried booting again. The boot screen was noisy. There was never any prompt for the crypto key. However, the system did boot without swap and without “/home” mounted. Yast started to complete the setup. It warned me that “/home” was not mounted.

At that point, I used CTL-ALT-F2 to get a terminal shell (already logged in as root, it seems). There, I manually open the encrypted “/home”. When I tried to mount, I found that it was already mounted. So something was running in the background to complete the crypto handling, and it mounted “/home” as soon as it found that it was available.

CTL-ALT-F7 got me back to the Yast screen, where I allowed the final configuration to complete.

Then, logged into KDE, I opened a root shell and manually opened the encrypted swap and did a “swapon”.
Next I ran “mkinitrd”.

Note, that I added the swap first, because it is my impression that “mkinitrd” partly goes by what is running on the current system.

The “mkinitrd” looked successful.

I rebooted. This time the plymouth splash came up properly, I was prompted for the crypt keys, and all went well.

I’ll report this as a bug later. However, it is hard to tell what the problem is. I cannot repeat the same circukstances without doing a fresh reinstall.

I’m hoping that others with the same problem will see this and add their reports. If several people have the problem, then it will be easier to know how to report the bug.

I installed RC2 tonight it works - for me - better than RC1.

  • plymouth prompts for the crypt key (encrypted /home) : OK now
  • the KDE NetworkManager applet is able to cope with my old WLAN card again; first time in 12.2
  • Apper does not apply updates: regression from RC1; I need to investigate this further before filing a bug report
    … to be continued …

happy testing!

hi there!

duly: is 12.2 rc2 same as “FACTORY”?

so…why’s asking me so many packages to install\upgrade?

# zypper upLoading repository data...
Reading installed packages...

The following package update will NOT be installed:

The following NEW packages are going to be installed:
  a2ps akregator bash-doc bea-stax-api bluedevil-lang bootsplash-branding-openSUSE 
  bundle-lang-gnome-ar bundle-lang-gnome-extras-ar cups digikam digikam-doc digikam-lang 
  enblend-enfuse enscript exiftool foomatic-filters ft2demos fuse 
  gdk-pixbuf-loader-libopenraw gegl-0_2 ghostscript ghostscript-fonts-other ghostscript-x11 
  gimp gimp-branding-openSUSE gimp-help-browser gimp-plugins-python gnome-icon-theme 
  gnome-icon-theme-extras gnome-icon-theme-symbolic graphviz graphviz-gd graphviz-gnome 
  grub2-branding-openSUSE gtk2-branding-openSUSE gtk2-engine-clearlooks 
  gtk2-metatheme-adwaita gtk2-theme-clearlooks gtk3-branding-openSUSE gtk3-metatheme-adwaita 
  gtk3-theming-engine-adwaita gvfs gvfs-backend-afc gvfs-backends gvfs-fuse hugin 
  icedtea-web ImageMagick iso-codes ispell ispell-american java-1_7_0-openjdk 
  java-ca-certificates jline jpackage-utils kdeartwork4-wallpapers 
  kdeartwork4-wallpapers-weather kdegames4-carddecks-other kipi-plugins 
  kipi-plugins-acquireimage kipi-plugins-geolocation kipi-plugins-lang konversation 
  konversation-lang kopete lcms2 lensfun-data libaa1 libbabl-0_1-0 libblas3 libbluray1 
  libboost_regex1_49_0 libboost_signals1_49_0 libboost_system1_49_0 libboost_thread1_49_0 
  libchm0 libdjvulibre21 libepub0 libeXosip2-6 libgadu3 libgegl-0_2-0 libgeoclue0 
  libgfortran47 libgimp-2_0-0 libgimpui-2_0-0 libglade-2_0-0 libgle3 libGLEW1_7 libglut3 
  libgvfscommon0 libieee1284 libjavascriptcoregtk-1_0-0 libkdcraw20 libkdeedu4-data 
  libkeduvocdocument4 libkface1 libkgeomap1 libkgeomap-lang libksane0 libkvkontakte1 
  liblapack3 liblensfun0 liblpsolve55 liblqr-1-0 liblua5_2 libmarblewidget13 libmeanwhile1 
  libmediawiki1 libmsn0_3 libmspack0 libnetpbm10 libopencv2_4 libopenjpeg1 libopenraw1 
  libosip2 libotr2 libpano13-2 libpoppler25 libpoppler-glib8 libpoppler-qt4-4 
  libqdialogsolver1 libquadmath47 libreoffice-base libreoffice-base-drivers-mysql 
  libreoffice-calc libreoffice-filters-optional libreoffice-help-en-US 
  libreoffice-icon-theme-crystal libreoffice-icon-theme-galaxy 
  libreoffice-icon-theme-hicontrast libreoffice-mailmerge libreoffice-math libreoffice-pyuno 
  libreoffice-templates-en libreoffice-templates-presentation-layouts 
  libreoffice-thesaurus-en-US libsnmp30 libspectre1 libstorage4 libudisks2-0 
  libwebkitgtk-1_0-0 libwmf-0_2-7 libwx_baseu-2_8-0-stl libwx_baseu_net-2_8-0-stl 
  libwx_baseu_xml-2_8-0-stl libwx_gtk2u_adv-2_8-0-stl libwx_gtk2u_aui-2_8-0-stl 
  libwx_gtk2u_core-2_8-0-stl libwx_gtk2u_gl-2_8-0-stl libwx_gtk2u_html-2_8-0-stl 
  libwx_gtk2u_xrc-2_8-0-stl libxmi0 libzip2 linphone marble marble-data 
  metatheme-adwaita-common netpbm notification-daemon okular parallel-printer-support 
  perl-Archive-Zip perl-Image-ExifTool plasma-addons-marble poppler-data poppler-tools 
  python-cairo python-distribute python-gobject2 python-gtk python-kde4 python-kdebase4 
  python-numpy python-pyudev rdesktop readline-doc rhino samba-client sane-backends 
  sane-backends-autoconfig skanlite skanlite-doc skanlite-lang snmp-mibs synaptiks systemtap 
  systemtap-runtime timezone-java udisks2 vim-data w3m wdiff wdiff-lang words wxWidgets-lang 
  xmlbeans xorg-x11-fonts xscreensaver-data-extra yast2-qt-graph 

The following product is going to be upgraded:

1157 packages to upgrade, 199 new.
Overall download size: 880.0 MiB. After the operation, additional 1.1 GiB will be used.

Installed 64 bit Gnome on the desktop, no problems so far. Now I install 32 bit Gnome on my netbook, surprisingly kernel-firmware isn’t on the default selection for 32 bit while it is for 64 bit. In 12.1 I used 32 bit on both machines and had to manually select the package, makes at least my wireless work out of the box.

btw: ‘nada’ on distrowatch!


No, I am pretty sure it is not. As far as I know, FACTORY is already working on the early stages of 12.3, and 12.2 was split off into a separate development line.

On 2012-08-02 23:16, homie35 wrote:
> hi there!
> duly: is 12.2 rc2 same as “FACTORY”?

No; Factory is 12.3 now.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

SO I have a big big problem with openSUSE 12.2 RC2 with my real install (as opposed to a VM). I normally install the nVIDIA video driver. After a zypper dup command, when I log into KDE my display goes upside down and backwards. There is no way to guess where anything is at to select with your mouse. You can do an Ctrl-Alt-F1 and get a right side up terminal session. I have seen this before after an update of openSUSE 12.1 with the latest xorg and KDE4 files. I don’t know how to over come the issue. I can do a Alt-Shift-F12, turn off Desktop Effects and the display goes back to normal. It seems to be a nvidia/KDE4/xorg problem, but you can do the same deed to openSUSE 12.1 if you want to. Not sure what to even complain about or to whom, but its stops me dead for now, at least using any desktop effects.

Thank You,

Thx folks!

after the

zypper up

all went fine! now I need to know how to change my repos for **Factoy repos ?


On 08/02/2012 09:46 PM, homie35 wrote:
> Thx folks!
> after the
> Code:
> --------------------
> zypper up
> --------------------
> all went fine! now I need to know how to change my repos for *Factoy
> repos ?

Are you really sure you want Factory repos? At this point, they are for 12.3 and
much of the stuff is unlikely to work.

If you still want them, you need to set repos to


On 2012-08-03 04:46, homie35 wrote:

> after the
> Code:
> --------------------
> zypper up
> --------------------

You really want dup here, not up.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

> You really want dup here, not up.

folks who don’t know they should not use factory or ‘up’ are not gonna
be extremenly helpful in finding, documenting or squashing RC2 bugs…



No, Factory and 12.2 RC2 are two different things :slight_smile:

Good day, here is my feedback on openSUSE 12.2 RC 2:

  • the upgrade process from RC1 to RC2 went well, all 1400+ packages where upgraded without any problems. The major issue i had here was that after i rebooted the system the bootloader menu did not appeared, after seeing ”welcome to grub…” the screen stayed black. To solve this i had to reinstall Grub 2 using one of the live CD and chroot. After this issue was solved, using the system did not prompted me with any problems while running KDE plus apps like Firefox, Yast → Software management or Desktop Settings
  • testing live CD`s went also well, even if i could see in the output that the Vbox module failed to load. I could say that as a normal user i did not encountered any issues for the programs used. Excellent work in fixing the bugs so far ! :slight_smile:

I don’t speak very well english.
I had the same problem. It’s because of the update of the kernel. And the grub.cfg file cannot be actualized. I had this:

Kernel image:   /boot/vmlinuz-3.4.4-1.1-default
Initrd image:   /boot/initrd-3.4.4-1.1-default
Root device:    /dev/disk/by-id/ata-VBOX_HARDDISK_VBdcac2bdf-ae573355-part3 (/dev/sda3) (mounted on / as ext4)
Resume device:  /dev/disk/by-id/ata-VBOX_HARDDISK_VBdcac2bdf-ae573355-part1 (/dev/sda1)
Kernel Modules: hwmon thermal_sys thermal processor fan libata libahci ahci ata_piix ata_generic scsi_dh scsi_dh_hp_sw scsi_dh_emc 
scsi_dh_alua scsi_dh_rdac pata_acpi pdc_adma pata_ninja32 sata_mv pata_it8213 sata_uli pata_triflex pata_hpt3x3 pata_optidma acard-ahci 
pata_hpt366 sata_inic162x pata_sch pata_sis pata_cs5520 pata_mpiix pata_isapnp pata_legacy pata_rz1000 sata_sx4 pata_rdc pata_cs5530 sata_promise 
pata_artop sata_sis pata_pdc202xx_old pata_serverworks pata_efar sata_sil pata_cmd640 sata_qstor pata_hpt37x pata_oldpiix pata_sil680 pata_marvell 
pata_via pata_piccolo pata_pdc2027x pata_ns87410 sata_svw pata_jmicron pata_ali pata_sc1200 pata_amd sata_sil24 pata_cs5536 pcmcia_core pcmcia 
pata_pcmcia pata_atp867x sata_nv pata_sl82c105 pata_cs5535 pata_opti pata_arasan_cf ahci_platform sata_vsc pata_it821x pata_atiixp pata_cypress 
pata_netcell pata_radisys pata_ns87415 pata_cmd64x sata_via pata_hpt3x2n usb-common usbcore ohci-hcd uhci-hcd ehci-hcd xhci-hcd hid usbhid 
Features:       acpi plymouth block usb resume.userspace resume.kernel
**Perl-Bootloader: 2012-08-02 20:05:58 ERROR: Command '/usr/sbin/grub2-mkconfig -o /boot/grub2/grub.cfg >/var/log/YaST2/y2log_bootloader 2>&1' failed with code 256 and output: Generating grub.cfg ...
/etc/grub.d/05_menu_color: line 8: /usr/lib/grub/grub-mkconfig_lib: No such file or directory**

There was an error generating the initrd (1)
warning: %posttrans(mkinitrd-2.7.0-62.5.1.i586) scriptlet failed, exit status 1

The file grub-mkconfig_lib is in /usr/share/grub2, not in /usr/lib/grub. So i made a symbolic link and it works!

ln -s /usr/share/grub2/grub-mkconfig_lib /usr/lib/grub/grub-mkconfig_lib

Reported as Bug 774400 No prompt for crypto key in verbose boot

a little tiny typo: factory [factort]:wink: