12.2 install from ISO not working?

Hi there!

I have installed openSUSE 12.1 from an ISO by booting it with GRUB2 using the following commands:
loopback loop /openSUSE-12.1-DVD-x86_64.iso
linux (loop)/boot/x86_64/loader/linux iso-scan/filename=/openSUSE-12.1-DVD-x86_64.iso splash=silent showopts install=hd:/openSUSE-12.1-DVD-x86_64.iso
initrd (loop)/boot/x86_64/loader/initrd

Using these same commands to install 12.2 (ofcourse 12.1 is replaced by 12.2) LinuxRC tells me that it can’t find the repositories. If I specify an instsys-parameter, it still can’t seem to find it’s repo’s.
Any thoughts on this? The sha1 is correct, and since 12.1 did launch YaST and installed successful, I can’t figure out why 12.2 doesn’t.

Thanks you all,


AFAIK this is not a supported method of installing and never has been with openSUSE.

Burn iso image to cd/dvd install from there. If you have no burner then you can use a mem stick

You are right, this is not officially supported. Yet I cannot imagine being the first one to update systems this way (it’s fast, you can put multiple ISO’s on one partition, etc). I have enough DVD’s at hand, yet it saves me a lot of time installing from an USB 3.0 HDD.
Plus: I am a curious person. Any thoughts where they may have changed these settings?

Not able to answer your specific question but I must mention that 12.2 is the fastest SUSE to date to install. Much faster than 12.1; gone seem to be the days of being one of the sluggish distros in this department :slight_smile:

On 2012-09-22 01:36, TheMerciless wrote:
> Plus: I am a curious person. Any thoughts where they may have changed
> these settings?

Ask the devs…

Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Never used that method you mentioned, so I have no answer for you, but I
am following that thread with interest.
If you can get an answer on the mailing list from the devs, I would be
grateful if you report here back how to make that work again. That looks
like a really convenient method for installations which I have not seen

PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.1 | HD 3000
eCAFE 800: oS 12.2 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

I’ll email the devs and post the answer here.
It sure is a convenient method, especially since GRUB2 can boot from NTFS, so your ISO’s can be managed on any machine.

This should work for Grub2.

menuentry "openSUSE 12.2 DVD" {
  set isofile=/openSUSE-12.2-DVD-x86_64.iso
  set root=(hd0,1)
  loopback loop $isofile
  linux (loop)/boot/x86_64/loader/linux install=hd:$isofile
  initrd (loop)/boot/x86_64/loader/initrd

This works for legacy Grub. I used it for the last couple of releases.

title openSUSE 12.2 DVD
    root (hd0,0)
    kernel /linux install=hd:/openSUSE-12.2-DVD-x86_64.iso
    initrd /initrd

With legacy Grub, you have to extract the linux & initrd from the iso.

What I would like to know is how to do this with a live iso. I haven’t figured that one out.

Unfortunately, it doesn’t work here. It is still complaining about his repositories. Did you use this on 12.2? Because this does work with all older versions (like my GRUB2-menuentry).
I’ll look into the Live-CD, hopefully it doesn’t give me as much headache as this…

I did this with a 12.2 iso.
I first tried what you posted and got the “no repository” message and the graphical Yast did not start.
When I tried what I posted, Yast started and worked fine. I did not click “install” as I already have 12.2 installed.

If Yast did not start for you, I think you either made a typo or you got the hd(x,x) part wrong.

As far as I can tell, the only real difference is that your version does not specify “iso-scan” parameter.

The main difference is the “set root” part. I believe I tried it with and without the iso-scan and it worked both ways.

I copied what you typed and put it in grub.cfg (I checked the filenames, just to be sure). The system won’t boot at all when hd(0,3) (the partition containing the ISO) is changed to something else because GRUB can’t find the kernel when it’s wrongly specified.
And… It still won’t start YaST. It is really strange, almost as if my PC is haunted.

This is weird: when I press ALT+F4 (virtual console - kernel messages) it gives the error:

url mount: trying hd:/openSUSE[ommitted]
(Partition: 30GB, ntfs, BOOT)
sh: /bin/mount: No such file or directory
mount failed
repository not found

That could be correct: mount is located in lbin, not bin. Could this be the issue?

I was able to reproduce your problem using a ntfs formatted usb stick.
It works fine with a ext4 usb stick.

Nice catch.
I created a link to /usr/bin/mount at boot and it’s working now with ntfs.

menuentry "openSUSE 12.2 DVD" {
  set isofile=/openSUSE-12.2-DVD-x86_64.iso
  set root=(hd1,1)
  loopback loop $isofile
  linux (loop)/boot/x86_64/loader/linux install=hd:$isofile exec="ln -s /usr/bin/mount /bin/mount"
  initrd (loop)/boot/x86_64/loader/initrd

That works like a charm! Problem solved. Strange that that’s necessary in 12.2, but it works. With the old menuentry, I also tried to create the symlink from the console while Linuxrc was running, went back to Linuxrc and pressed “Start install”: it mounted the ISO, it could mount the rescue-system again, so this clearly solves it all.
Thanks for your help and I hope this thread is useful as a reference to someone else!