12.2 Does not recognize my sound card on the ASUS M5A88-M motherboard

I have just installed 12.2 64 bit on a new computer that I have just put together. My sound card is not recognized. Shouldn’t the install have recognized the card? What do I do to get it installed?
I appreciate all you who help on this forum, This Linux stuff is not for the faint of heart!! I did do the one step multimedia install with seemingly no problems, but of course with no sound card recognized it doesn’t matter. LOL. Again thanks.

Also when I try to mount the DVD I get

mount /dev/sr0

mount: can’t find /dev/sr0 in /etc/fstab

Also when I try to mount the DVD I get

mount /dev/sr0

mount: can’t find /dev/sr0 in /etc/fstab

In general, no fstab entry is required for removable media. This is handled dynamically by udev/udisks, and with the desktop environment support. Are you trying to mound a DVD with a valid file system? Or play a movie?

My sound card is not recognized. Shouldn’t the install have recognized the card? What do I do to get it installed?

Start here, and make sure you follow all the diagnostic steps before reporting back here if still necessary.

In particular, there is a diagnostic script which can be run (as root)

sudo /usr/sbin/alsa-info.sh

It will provide useful output which may help with getting your audio system working.


So, in reverse order, DVD’s should mount automatically and do not require a manual mount command. If it is a movie DVD, there are things that must be done to play multimedia. Have a look at this Article on the subject:


As for sound, I suggest you need to look at the following article on the subject:

Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

I have a bash script that is useful in checking out sound problems you can find here:

S.T.A.R.T. - SuSE Terminal Audio Reporting Tool - Version 1.12 - Blogs - openSUSE Forums

Now the three biggest problems I know of are:

  1. You have more than one sound device and the one you want to use is not the default.

To determine this go to YaST / Hardware / Sound and if more than one device is present, make sure the one you want to use is listed as device 0, use the Other button to set that default. Make sure the device want to use is not listed as uncofigured. If so, then configure it.

  1. If you have more than one sound device, the profile for any sound devices you do not use must be set to the Profile of Off.

To determine this you need to visit (in KDE) menu / Configure Desktop / Hardware / Multimedia / Phonon (on Left) / Device Preference Tab - Make sure your preferred device is listed First / Audio Hardware Setup - Make sure the hardware Sound Profile for any sound devices not used is set to Off.

  1. Often Sound Channel and captures are turned to zero and or muted for the primary sound device you want to use.

Looking at the pavucontrol, make sure all devices are turned up and unmuted.

As you can see, having more than one sound device can cause a problem when the device you want to use is not the default sound device and Video Cards and Tuners among others can include sound devices detected by openSUSE. See if any of this information is helpful to you,

Thank You,

I appreciate your help.

Here is output from alsa. It is lengthy! Looks like my system has been detected. I had to tuncate most of the file.

!!ALSA Information Script v 0.4.61

!!Script ran on: Thu Sep 13 01:54:39 UTC 2012

!!Linux Distribution

Welcome to openSUSE 12.2 “Mantis” - Kernel \r (\l). openSUSE 12.2 (x86_64) LSB_VERSION=“core-2.0-noarch:core-3.2-noarch:core-4.0-noarch:core-2.0-x86_64:core-3.2-x86_64:core-4.0-x86_64” NAME=openSUSE PRETTY_NAME=“openSUSE 12.2 (Mantis) (x86_64)” ID=opensuse CPE_NAME=“cpe:/o:opensuse:opensuse:12.2”

!!DMI Information

Manufacturer: System manufacturer
Product Name: System Product Name
Product Version: System Version
Firmware Version: 0801

!!Kernel Information

Kernel release: 3.4.6-2.10-desktop
Operating System: GNU/Linux
Architecture: x86_64
Processor: x86_64
SMP Enabled: Yes

!!ALSA Version

Driver version: 1.0.25
Library version:
Utilities version: 1.0.25

!!Loaded ALSA modules


!!Sound Servers on this system

Installed - Yes (/usr/bin/pulseaudio)
Running - Yes

!!Soundcards recognised by ALSA

0 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xfe8f8000 irq 16
HDA ATI HDMI at 0xfeae8000 irq 19

!!PCI Soundcards installed in the system

00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40)
01:05.1 Audio device: Advanced Micro Devices [AMD] nee ATI RS880 HDMI Audio [Radeon HD 4200 Series]

!!Advanced information - PCI Vendor/Device/Subsystem ID’s

00:14.2 0403: 1002:4383 (rev 40)
Subsystem: 1043:841b

01:05.1 0403: 1002:970f
Subsystem: 1043:843e

!!Loaded sound module options

!!Module: snd_hda_intel
align_buffer_size : -1
bdl_pos_adj : 32,32,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
beep_mode : 1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1
enable : Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y
enable_msi : -1
id : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
index : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
model : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
patch : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
position_fix : 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
power_save : 0
power_save_controller : Y
probe_mask : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
probe_only : 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
single_cmd : N
snoop : Y

Thanks for your help. I am not sure what happened but somehow the two sound sources got recognized. The only thing that I did was take out the cables and reinsert them. But before I did that, data dvds were being recognized. So now I have sound, but I am not sure why. Thanks again!! Much appreciated.

We hope at least that you now know more about your sound devices and how to make adjustments to them. Its good to hear you have sound again.

Thank You,

I am also experiencing configuration issues with audio and am not sure what to pursue next: I am running openSUSE 12.1 on an HP with a dual-core AMD x64 processor and 4 GB RAM. The video and audio are on-board and the chipset, I believe, is NVidia.

Running a hardware probe (system info) details the audio settings. Running an application like Kaffeine to play an audio file outputs sound through an earphone port, and Amarok plays a digital file that came with it as an example. So it seems that the system is set up correctly; I’ve noticed that 12.1 is better at recognizing and configuring hardware than earlier versions.

I also wanted to use this machine for more advanced audio work. I have some Windows-based hardware and software but had heard that Linux had fewer latency problems than Windows; so I installed Rosegarden, Jack and a few VST instruments.

Rosegarden starts but complains that the MIDI sequencer and sound are unavailable. A dialog suggests running alsa-conf, which I did, and that’s where I ran into a dead-end: Alsa reports that there is no sound card and no drivers.

Can you suggest an avenue to explore? Thanks for any suggestions.