12.2 Beta GRUB install fails - VB

In my VirtualBox installing goes well up to the point where the bootloader needs to be installed. This fails and thus leaves me with an unbootable system. I’ve ran the installer twice, once with proposed partition layout and once with an additional boot partition. Both give the same result.

http://www.freeimagehosting.net/aprnq

http://www.freeimagehosting.net/aprnq

Clicking OK:

sh: /usr/sbin/grub2-mkconfig: No such file or directory

Anybody suggestions to get GRUB installed? Or how to go from here from the GRUB rescue prompt?

For some reason my image got lost:
http://www.freeimagehosting.net/t/aprnq.jpg](http://www.freeimagehosting.net/aprnq)

Install from the DVD with “Install from images” enabled fails. Install with this option disabled.

that solves it, its listed as a bug

Ah thanks! :slight_smile:

>:(
Just like to add that I tried installing the latest openSuse Beta (12.2 Beta 1) dvd and the install also failed. Like other posters above I tried several attempts failed every time with the same error of Grub/Grub2 failing to install correctly due to some missing files. I have also disabled the “Install using images” recommended by another user and the result is the same.

I am starting to think with every release now (since 11.4) that installing openSuse has become a running joke between the developers at the expense of the enduser. They must enjoy wasting everybody’s time and effort or maybe they just don’t want users to install their software, who knows?

When I installed 12.1 back when it released it too had major installation problems and failed to install correctly resulting in my system being completely frozen. Luckily, after a forced shutdown the system did boot up and whatever happened went away but was a complete mystery, although I still have no idea to what extent my system was affected by this failure. I thought at the time how crazy this was to be happening with the release version but hey, at least I’m out of the woods.

Now with the beta 1 release I am here again trying to install the latest and greatest only to find more problems at install. This time though Grub/Grub2 is refusing to install resulting in the installation becoming unbootable. After countless attempts using different combinations of setups and different settings I am nowhere closer to resolving this.

I’m now left feeling completely pissed off trying to reinstall this cr@p. What are these developers smoking over there at OpenSuse HQ to put this untested software out there that won’t even install for people to BETA test. Why should I post a bug report if the developers can’t even ensure it can install, you know the BASIC REQUIREMENT?

I understand this is free software developed by volunteers, but this is simply not good enough!

<Time for a cup of tea>
>:(

This is only a Beta release. Hopefully, the install problems will be worked out by the time of the final release.

For installing from the DVD:

1: Disable install from images.
2: If the grub2 install fails, then revert to grub1 (called just “grub” in the selection menu).
3: If your system prompts for a Luks key during boot, then before rebooting, be sure to edit either “/boot/grub/menu.lst” (for grub1) or “/boot/grub/grub.cfg” for grub2. Change the “splash=silent” to “splash=verbose”. In the case of grub2, you will have to make the same change in “/etc/grub.conf” once you have the system running.
4: Once the system is up and running, install “plymouth-plugin-label”, and then run “mkinitrd”. If you have to edit “/etc/grub.conf” (see step 3 above), then do that before the “mkinitrd”.

Thanks for you reply however, like I said in my post I did try disabling install from images and when the installation process failed for Grub2 I swapped to Grub and still the installation failed. The result was that the boot process for my pc was not updated and so the linux installation fails to even attempt to boot. Given that the install process completely failed I have no clue about how to go about modifying files during the installation process.

I will add though that disabling the install from images option resulted in some really strange noises coming from my pc as it attempted to install. At times is sounded like it was repeatedly attempting to access the floppy drive like it was looking for something. Never heard my PC make that much noise before.

My setup uses a duel boot with Windows 7 and luckily that still boots so I have only lost my linux installation and not everything. I think I will avoid any further attempts to install the Beta and maybe my time is best spent elsewhere.

You might have a failing hard drive.

On 2012-06-10 03:46, nrickert wrote:
> This is only a Beta release. Hopefully, the install problems will be
> worked out by the time of the final release.

Do not hope, report!
You have to report your issues in Bugzilla, or they will not ever be solved.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)