12.1 x86_x64 & xrdp(malcolmlewis)/xorg-11

Hey guys!

First post and liking OpenSuse 12.1, for the last couple of days I have been searching endlessly about resolving some issues in xRDP. Currently I’m using the xorg-x11/xrdp build from malcolmlewis, I am able to start an x11rdp session from Windows client to Linux host, my problem is the functionality of Gnome-based applications in an xrdp session, I’m not able to launch anything Gnome-based ie Games, YaST cpanel, Install & Update, Gnome calc, gnome character map etc. Got everything working through an x11rdp connection, (an xvnc connection doesn’t allow mouse use). My main problem though is that Gnome based utilities like gnome calc, gnome character map, and more importantly YaST cannot be accessed through an xrdp session from a windows client. Other programs not working in an xRDP session are all gnome based games, multimedia stuff etc. Connecting locally YaST and Gnome based apps work just fine. When I go into terminal and try to launch /sbin/yast2 during an x11xrdp session I get back:

(y2controlcenter -gnome:6838): Gdk-WARNING **: The program ‘y2controlcenter-gnome’ received an X Window System error.
This probably reflects a bug in the program. The error was ‘BadLength (poly request too large or internal Xlib length erro’. (Details: serial 66 error_code 16 request_code 131 minor_code 47) (Note to programmers: normally, X errors are reported asynchronously; that is, you will receive the error a while after causing it. To debug your program, run it with the --sync command line option to change this behavior. You can then get a meaningful backtrace from your debugger if you break on the gdk_x_error() function.)

Some of the other steps I have attempted were to make my user have its own .Xauthority file linked to root. Tried to double check X11 libraries to ensure they were installed correctly etc. Does anyone have any suggestions as to whats occurring? YaST will launch in a terminal as a command program but the Gnome-based YaST won’t launch.

So I tried an Xvnc/xRDP connection, luckily I was able to use my keyboard since the mouse doesn’t work and attempted to launch YaST and Install Software & Updates. They both launched pkexec and allowed me to type in my pw. I’m thinking there is a libX11 issue somewhere with Gnome based applications. An X11 server cannot handle the dependencies correctly like an Xvnc handles them. Does anyone have any insight to this? Has anyone attempted x11/xrdp yet with OpenSuse 12.1 x64 (can’t rely on x86 builds since I’ve been working with x64 the whole time).

So doing some more research I found out how to deal with VNC capture issues through a post a lil while ago. Haven’t tried it yet and am about to, still need to figure out why X11 is doing this. Having a hard time checking the logs and trying to debug. This seems like a good solution to try to change the Xorg.conf file and check to see how things are running through there. I’ve been endlessly searching for the past 4 days, does anyone have any help whatsoever or have any experience with xrdp and openSuse 12.1 with an xfce4 interface?

Went back to 11.4 OpenSuse did some manual changes to xRDP and voila! no more problems. I would like to thank everyone in this forum for the help :stuck_out_tongue: