12.1 X64 audio podcasts do not work

Hello folks.
After trying a lot of distros out there, I eventually ended up with opensuse 11.4, which I quite enjoyed. Nice one (and excellent configuration tools. Thanks for that).
So I upgraded to 12.1 this week end. Everything works fine after the usual tweaks, BUT the podcasts.

I’m quite a heavy audio podcasts listener. I usually use amarok to listen to them.
Problem, after switching to 12.1, amarok couldn’t retrieve ANY of my podcast feeds. Gave gives me a message like “can’t find podcast : unknown host.”
So I removed amarok, got rid of all configuration files, and started with a fresh install, trying to re-suscribe to my rss feeds. But no luck, still the same message.
Tried with the firewall switched off, but still no luck.
I then installed gPodder, but when I try to suscribe to any feed (even the ones gPodder suggests), I get something like “could not add some podcast”.

I tried a few searches on google, amarok forums, this forum, but I don’t seem to be able to find anyone with this problem. Am I cursed ?
The only thread that looked “interesting” was this one, but i do have python-feedparser 5.0.1-3.1.1 installed. (tried re-installing it. No luck.)

I don’t use a proxy, my internet connection is working fine, and my podcasts work well on other distros/computers and on my smartphone, so I don’t think it is a problem with the feeds. (they mostly come from french radio : france inter and france culture. Very popular ones. if there was a problem with them, the net would have known…)

I’m lost here. And I don’t want to install yet another distro on another partition or VM for such a “small” issue.

Any help greatly appreciated. Merci.

Weel, don’t ask me why, but this morning’s update seems to have solved the problem. Both amarok and gpodder now work.

Life is sweet. :slight_smile:

(It looks like I can’t edit my first post and add [solved] in the title. Sorry for that.)