12.1 vs Tumbleweed

How to distinguish between openSUSE 12.1 and Tumbleweed? In both cases {?suse_version} returns 1210.

Wojciech Kazubski

On 2012-08-13 01:26, wkazubski wrote:
>
> How to distinguish between openSUSE 12.1 and Tumbleweed? In both cases
> {?suse_version} returns 1210.

That’s a good question…


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Hi
You need to add the tumbleweed repository to your project.
Repositories -> Add repository and select openSUSE Tumbleweed.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 14 days 21:33, 3 users, load average: 0.46, 0.71, 1.86
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

I think you just could check your repositories in terminal with: zypper repos, and if it has Tumbleweed repositories there, you are using Tumbleweed. Further, Its my guess if you were still using kernel 3.1.10, you are not using Tumbleweed. You have always had the ability to upgrade any of the individual applications, the kernel or groups of apps like upgrading the KDE Desktop, but that did not really change the basic distribution version and neither does using Tumbleweed, it would appear.

Thank You,

Hi James
The OP is talking about the spec file macro that’s used to determine
the openSUSE release… :wink:
http://en.opensuse.org/openSUSE:Build_Service_cross_distribution_howto


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.34-0.7-default
up 15 days 0:06, 2 users, load average: 0.36, 0.54, 0.85
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

An “osc meta prjconf openSUSE:Tumbleweed” shows that you simply can’t.

I am trying to build python-basemap package for several releases of openSUSE. It requires lapack and builds fine for 11.4, 12.1 (using lapack/liblapack 3.3.1), 12.2 and Factory (using lapack 3.4.1) but not for Tumbleweed. In this last case I get “unresolvable” error due to nothing provides liblapack = 3.3.1 needed for lapack. This is strange since I do not require specific version and repository science provides lapack 3.4.1 for Tumbleweed.
If I change specfile to require lapack = 3.4.1 it builds fine for Factory and Tumbleweed but not for others, including 12.1. As I can’t distinguish between 12.1 and Tumbleweed, I am unable to create specfile working in all cases.

I have added science and hamradio repositories to my configuration.

I propose changing Tumbleweed to return 1219 or so when asked about version number.

Wojciech Kazubski

Actually it says that nothing provides liblapack3 = 3.3.1.

It doesn’t provide a package with that name.

For < 12.2 either BuildRequire lapack-devel to use the package from the science repo or BuildRequire lapack but don’t add the science repo.