12.1 system gets stuck while booting, failsafe and "fast boot" boot okay

Hi,

I recently installed opensuse 12.1 from downloaded and verified DVD, onto an SSD disk (root), using the existing home partition on another harddisk.
The system behaves a little strange upon booting :
Failsafe boots function okay.
After booting into failsafe, and restarting, and most of the normal boots I experience, the system will start with the splash screen and display “doing fast boot”. This will boot okay.
But, which is I suppose all the not-“fast boot” boots, the system will display grub, and then the screen will go black and nothing further happens.
I experience this black screen in other boots too, it comes right before the boot splash screen with the opensuse logo is displayed, and the system runs through the listing of boot messages. So, my system gets stuck before this bootsplash on these few boots.

If this happens, all further boots I tried will result in the same black screen. I have to boot one time into “Failsafe”, hit restart, and select normal boot again. Boots afterwards will display “doing fast boot”, and those function.

Any help will be very appreciated.
Thanks
StG

On 12/01/2011 04:36 PM, Goettschwan wrote:
> Any help will be very appreciated.

maybe this is a systemD vs systemV problem (systemD is new in 12.1 and
a known trouble maker), try using systemV, see instructions here:

http://forums.opensuse.org/english/get-technical-help-here/network-internet/468111-systemd-1-network-service-operation-timed-out-terminating.html#post2407022

if that works you may want to plan to do that on all boots until it is
fixed (how long, i do not know…days, weeks, maybe a month) or you can
revert to systemv (the how-to do that is in #2 in that thread)


DD
openSUSE®, the “German Engineered Automobiles” of operating systems!

Hi, since these non-boots happen to loop until I start in failsafe, I was able to test different things.
Sadly, none of the four options seem to change the problem, it results in a black screen right beforeit should be displaying the opensuse splash.
I have not so much of an overview over the boot internals, but it has to be something that gets stuck that is not called upon in either failsafe or doing fast boot. I will try and find some time and copy the different boot options from failsafe so as to reduce a bit and find out which makes things work, maybe that encircles my problem better.
Thanks
StG

It was not mentioned as to which Desktop you are using -but- IF you are using KDE -and- you have an nVidia card you might be experiencing the conflict between the two. This requires an alteration in a KDE file.

Please edit ~/.kde4/share/config/kwinrc

and under Composting please add:

Enabled=false

Take care,
Chuck

Yes I am using KDE and have an Nvidia card, sorry to have not mentioned this.

I have found out in the meantime that the boot option edd=off eliminates the problem. Is this connected to your suggestion?
Thanks,
StG

I have checked the file you mentioned, and under Compositing there was Enabled=false already. But thanks anyway for your suggestion :slight_smile:

I have no real idea about what that does or means, but i have now added edd=off to Grubs default options, so all booting functions normally for now. Anybody enlightening me on this is very appreciated, I found an old, german language, suse 11.0 thread in another forum where they connect edd probing and nvidia graphics adapters to a boot problem. But for now, I am good. Thanks for the tips!