12.1- Stuck @ Boot Screen on Shutdown

hi guys,
after upgrading to 12.1, there are 3 issues troubling me:

  1. after pressing the ‘Shutdown’ button, the system hangs and shows just the boot screen. no error messages. i have to manually shut down by pressing the Power button.
  2. at the login screen, i have to enter the password twice. i first time i enter the password, nothing happens-except the password column goes blank. the second time it will work.
  3. how can i revert back to old screen? i dont like the new bootscreen, esp the BRIGHT green colour:(.

waiting for your responses. thanks in advance.

no one can help me?:frowning:

Try disabling/uninstalling systemd and use sysinitv instead.
Some have trouble with boot/shutdown because of it (including me).

Might be better to just try SystemV
F5 from the Boot menu and you can choose it for that boot session

If that works, we can make a permanent edit

I had the same problem and was helped by this:


I have the very same issue (strangely enough it came up only after some update coming out). So, you can see what happens, while the system begins to shutdown you hit immediately ESC and you can read where the system stops. Mine blocks at “system halted”. So there is no problem to switch it off manually pressing the power button (just the annoyance). If this is your case then you can try to open a terminal and write

shudown -h now

In my case this results in a correct shutdown.
Now, if this latter thing is your case, you may try to edit as described in the bug mentioned above:

In /usr/share/kde4/config/kdm/kdmrc is default

But in /usr/share/kde4/config/kdm/kdmrc.rpmnew it is default
/sbin/shutdown -h -P now

So suse 12.1 (new kde version from 12.1) need shutdown not halt.

Delete kdrmrc and rename kdmrc.rpmnew in kdmrc and restart.

You have to be superuser to do this, use the dolphin in superuser mode if you feel more comfortable than in the command line. My advice would be not to delete but to rename kdmrc in BADkdmrc and to rename kdmrc.rpmnew into kdmrc only afterwards. So if anything goes wrong you may easily revert. If this solves your trouble, you can still delete BADkdmrc afterwards. Good luck, and thank you to who posted the bug.

systemD has been a great improvement for me :smiley:
I’m happy with the change

Before I had the time to take a coffee when shutting down. Now, before this issue, it was lightning fast. I hope it will be again. The update procedure in general was not working very well for the details, as it seems. Maybe normal, the changes in the structure of the system where quite important.

**DON’T DO THAT! **On my machine this advice given in the bug results in a broken x-server and impossibility to start KDE. Renaming the backup copy will restore functionality. Will now read and edit the two rc files and change just the part that is needed. Will report on the result.

This solved my issue: don’t(!) erase kdmrc. No need to rename either. Open dolphin in the superusermode. Go to:


right click and edit it with kwrite or the editor of your choice.
In the section shutdown substitute the two lines I did mark in bold below. Save it and restart your system (the first time it will not shutdown or restart well because it is still using the old rc to shutdown). Then it should be solved. At least for me it was. Let us know if it was also for you.

# The command (subject to word splitting) to run to halt the system.
# Default is "/sbin/shutdown -h -P now"**
HaltCmd=/sbin/shutdown -h -P now**
# The command (subject to word splitting) to run to reboot the system.
# Default is "/sbin/shutdown -r now"**
RebootCmd=/sbin/shutdown -r now**
# Whether it is allowed to shut down the system via the global command socket.
# Default is false
# Whether it is allowed to abort active sessions when shutting down the
# system via the global command socket.
# Default is true
# The boot manager KDM should use for offering boot options in the
# shutdown dialog.
# "None" - no boot manager
# "Grub" - Grub boot manager
# "Grub2" - Grub2 boot manager
# "Lilo" - Lilo boot manager (Linux on i386 & x86-64 only)
# Default is Grub

The values that you do find in your system are probably “halt” and “reboot”.

Thanks a lot for your reply guys!

Try disabling/uninstalling systemd and use sysinitv instead.
Some have trouble with boot/shutdown because of it (including me).

i think that is the cause of this issue. i uninstalled systemd and installed ‘sysvinit-init’ from Apper. after that no gui. this is error that appears in the boot up screen:
‘starting vmtoolsd FATAL:Error inserting vmw_balloon (/lib/modules/kernel version/kernel/drivers/misc/vmw_balloon.ko). No such device.’

also when i try to install sysvinit-init, it replies: ‘problem retrieving files from opensuse current-OSS. Connection failed. could not contact DNS servers.’

also ‘startx’ is not installed.

is there any link between the above two issues?

Might be better to just try SystemV
F5 from the Boot menu and you can choose it for that boot session

If that works, we can make a permanent edit

as you can see from my signature, i dual boot opensuse along with ubuntu. the grub menu belongs to ubuntu and i couldnt get ‘F5’ to work in that menu.

@ gugrim & stakanov,
i am unable to enter the gui. its just command line at present.

Do you feel comfortable to edit the file in Vim or Emacs via the command line? Then you can do the very same procedure from the CLI.

@ stakanov

no, I don’t know how to use CLI. I’m just an end-user of opensuse:\

thanks a lot for your help, but I have reinstalled opensuse 12.1 since I needed my laptop for work.

but, I need your advice on this ‘stuck @ shutdown’ issue. Its troubling me even after a fresh install (last time I did an upgrade from 11.4)>:(. How should I remove systemd from my system? I lost my gui trying to uninstall it from ‘Software Management’.

I do not think it is a question of systemd. Please tell me: do you have the possibility to hit the ESC (escape) key upper left when the shutdown picture goes? Then do it, the screen turns black and the logs run by (like in matrix ;), so don’t worry, and then tell me what are the exact last line(s) (one or two the system shows. If the last line is “system halted” everything will be easier than you think. In the latter case just tell me: it is written “system haltet”. I suppose you have the same problem also when doing “suspend system to disk”. But if I am right you do not have any problem starting up the machine.

BTW, using the command line is not a question of “end user”. Linux has been done for giving you the right to use it, to modify your system in every way you want. That’s why we call it free software. This does not refer to the pricing but to the fact that the sourcecode is open, you can modify it and you are free, free to choose. That said it is up to us to learn how to use this freedom. It is a choice, nobody is going to push you but if you are interested I can give you some links to books that are well written and that allow you to be more confident.

I have the same problem, and yes, the last line is “system halted”. If i edit the the kdmrc file, or use “shutdown -h -P now” from command line than there is no problem, but when the system boot up again, it tend to do fsck to all my partition, is it normal? Is there any ways to use systemd without having this problem?

You can’t just remove one and install the other because default is to the one you just removed (D).
Usually both are installed anyway, which is what you should have done.
I understand you are using grub2 now

See if you can edit the /boot/menu.lst in suse from your debian install
Add this argument to the menu.lst


the problem seems to have disappeared after the fresh install. thank you for responding to my thread:)

@ stakanov
i would like to learn CLI (atleast the basics). it would be nice if you could direct me to those tutorials

Well, then instead of overwhelming you with thousands of links and complicated book, I will advise you to read at first this website](http://www.tuxfiles.org/linuxhelp/cli.html). It is well structured, not too “cryptic” and so you can begin to loose your distance. If you do not like it you may come back here and tell me. Following your needs and taste, there are other sources but as I do not know what you need we go be “trial and eventual error”.
You will let me know.
Have fun and play a lot with the basic small commands to memorize. You will see, this is a much more powerful instrument then all the rest.

I have written a FAQ to support our supporters with caf in mind :slight_smile:

Faq to support our supporters - grub2@ubuntu

Thank you for taking the time to do that