12.1 - Sound in XBMC and Media Players no longer working


I have a 12.1 x86_64 system running as a media PC to my TV via HDMI. It’s been working for months as an 11.4 system, and then 3 weeks ago I upgraded to 12.1. The upgrade went fairly smoothly (no un-manageable issues). However, a few days ago, my sound stopped working for playing any videos and music in XMBC or any media player (tried VLC and Kaffeine). When I start a video in XMBC, it complains that it “Failed to Initialize Audio Device”. VLC and Kaffeine do not complain. The strange thing is, I still have system sounds coming through the HDMI to the TV. All the menu click sounds and such work just fine. This is just for media play.

Any idea how I can troubleshoot something that was working, and then has just stopped? I have checked /var/log/messages, and don’t see anything out of the ordinary. I’ve tried zypper updates, reinstalling the nvidia driver, as well as followed some of the multi-media installation guides around here. It’s currently hard for me to tell if this is an alsa, pulseaudio, or nvidia issue.

Here’s some more info:

rpm -qa | grep alsa


rpm -qa | grep libasound


cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel,snd-hda-intel
# u1Nb.oG6iePWsS5E:Intel Corporation
alias snd-card-1 snd-hda-intel
# NXNs.RAUoF_mLvaF:nVidia Corporation
alias snd-card-0 snd-hda-intel

Any direction on this would be greatly appreciated. Thanks!

I don’t use XBMC nor do I use HDMI.

But I do find that pulse audio volume control (pavucontrol) can help setting up various audio devices for sound, and you could install that application (if using KDE, if using gnome it likely is already installed) and then run that application the 1st time you run any multimedia application to tune pulse audio for that application to the device in which you wish to use.

Further to my last post, I have a blog entry here on pavucontrol (although it does not cover HDMI per se … I think the same approach applies) : Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

Oddly enough, I installed pavucontrol to follow through the instructions, and it started working again! Not sure what got re-loaded or refreshed, but seems better now. Although, watching through videos last night the audio crashed twice on me. Logging out and then in again fixed the crash. Very strange, and I still can’t find anything in the logs as to why it is crashing.

Any other suggestions or places I could check to try to troubleshoot this strange issue? Again, it only seems to be when playing videos or music.

Next time your audio crashes try this: delete ~/.pulse istead of logging out. It sounds like you have the same problem I do. If so you will see the directory get recreated almost immediately and your sound will work just fine (until the next crash).

Assuming we have the same issue the above is only a crude workaround not a fix but it might help in diagnosing this problem. I’ve posted on my saga with various aspects of this sound issue (particularly with HDMI) with 12.1 and with 11.4 ever since an update in late January or early Feb. My posts have been viewed so many times I suspect we’re not alone in having this problem. Unfortunately I’ve had almost no replies so I also suspect there’s a lot more work to be done before the Gurus on the forum have enough data to be able to help out. (I’m not complaining… Those guys are so good and so helpful I’m sure they would have replied if they’d felt able to help.)

My posts: here and here and here