12.1 RC1 / 11.4 Kernel 3.1.0-1

Hello,

Installation on external USB 3 “plug and play” still not possible.

On my vaio VPCSB1Z9E/B (i5 2.3 Ghz), the fans are always 100%, it is noisy.

It worked better under 2.6.39-36 I think.

Thank you and goodbye

I do not realy understand if you are asking for help here or only want to tell something. But this is not the place for any 12.1 discussion as 12.1 is still not released.

Please go to the Pre-release/Beta subforum for any 12.1 bussiness.

The ability to boot from a USB 3 drive requires two things. First, your computer BIOS must support the selection of the USB 3 device to boot from. If you can not designate your USB 3 drive for booting in your PC BIOS setup, it can **NOT **be used to boot openSUSE. Second, if you can load openSUSE onto the USB 3 drive, but it fails to boot, you need to load the correct USB 3 driver into initrd. Here is what you must do:

  1. Boot from a LiveCD AFTER you have installed openSUSE properly onto your USB3 device, but where it does not boot into openSUSE properly.
  2. Open Up a terminal session and execute the following commands:

mkdir /mnt/sysimage
mount /dev/sdXY /mnt/sysimage
chroot /mnt/sysimage

NOTE: X=disk name as in a, b, c or d AND Y=1, 2, 3 or 4 as to partition number. Ex:sdb1 where you have installed the main or root openSUSE partition called /

  1. Use VI or other text editor (Look up the VI editor command first) and edit the file /etc/sysconfig/kernel
  2. In the text file called kernel look for the line that starts with INITRD_MODULES=" and add the name xhci-hcd to the line and save the file. For instances, here is what my line says with this option added:

INITRD_MODULES=“xhci-hcd pata_jmicron ata_generic thermal processor fan”

Your line will likely be different than mine.

  1. Issue the following terminal commands after you have edited the above text file called kernel located in the folder /etc/sysconfig/

mount -tproc none /proc
mkinitrd

This should create a new image in the /boot folder that might be named: initrd-3.1.0-1-desktop and is being loaded in your /boot/grub/menu.lst file. This only modifies the initrd image for the present loaded kernel version.

Thank You,

Hcvv thank you for your answer,

I should have put this post in Pre-release/Beta 12.1 Any Subforums for bussiness…

Good day.

Jdmcdaniel3 thank you for your answer,

We already talked about USB 3 problem to install suse, I hoped that it will no longer be present in suse 12.1.

I created my own process that I find easier thanks to you.

Installation being connected usb3 port, connect to usb2 to complete the install (auto config), boot suse 11.4 (usb2) as root edit kernel in /etc/sysconfig , adding “xHCI-hcd” (INITRD_MODULES = "xHCI -hcd ata_generic thermal processor fan "), reboot the machine usb3 connect and everything works.

Good day.

The problems of fans seems to come from non-optimized kernels (not desktop kernel).

The kernel-desktop-3.1.0-2.1.x86_64.rpm, 31-Oct-2011 (38MB) for suse 11.4 can not be installed, it will be dependent on kernel-desktop-2.6.37.6-0.7.0, not existent …

Good day.

Jdmcdaniel3 thank you for your answer,

We already talked about USB 3 problem to install suse, I hoped that it will no longer be present in suse 12.1.

I created my own process that I find easier thanks to you.

Installation being connected usb3 port, connect to usb2 to complete the install (auto config), boot suse 11.4 (usb2) as root edit kernel in /etc/sysconfig , adding “xHCI-hcd” (INITRD_MODULES = "xHCI -hcd ata_generic thermal processor fan "), make a mkinitrd, reboot the machine usb3 connect and everything works.

Good day.

Jdmcdaniel3 thank you for your answer,

We already talked about USB 3 problem to install suse, I hoped that it will no longer be present in suse 12.1.

I created my own process that I find easier thanks to you.

Installation being connected usb3 port, connect to usb2 to complete the install (auto config), boot suse 11.4 (usb2) as root edit kernel in /etc/sysconfig , adding “xHCI-hcd” (INITRD_MODULES = "xHCI -hcd ata_generic thermal processor fan "), make a mkinitrd, reboot the machine usb3 connect and everything works.

Good day.

You are welcome for the help phil995511 and happy to hear you got it working. Attaching the USB 3 drive to USB 2 port in order to install and setup the correct kernel module was also a very good idea.

Thank You,

Hi jdmcdaniel3,

Tks for your help. I have tested all 3.1 kernel for suse 11.4, all have a problem to fans optimisation on VPCSB1Z9E/B (i5 2.3 Ghz) only one run normaly : the base kernel (13 MB) but with this kernel i have not lan…

I should like to retourn on 2.6.39 but this rpm hase deleted from Index of /repositories/Kernel:/HEAD/openSUSE_11.4

How it’s possible to optain this rpm ?

Good day for you

On 2011-11-03 14:56, phil995511 wrote:
> How it’s possible to optain this rpm ?

Oss repo. And not that one.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I have compiled/installed a 2.6.39 kernel from The Linux Kernel Archives, but I have a problem with a few drivers, my computer not boot on « standart mode » but on « safe-mode » i’ts possible… have you a idea to optain a good compilation with a fonctionnel drivers ?

I have compiled/installed a 2.6.39 kernel from The Linux Kernel Archives, but I have a problem with a few drivers, my computer not boot on « standart mode » but on « safe-mode » i’ts possible… have you a idea to optain a good compilation with a fonctionnel drivers ?

So this thread was about openSUSE 12.1 which will have kernel 3.1. What version of openSUSE did you install kernel 2.6.39 in to? You must tell us more; openSUSE version, 32 or 64 bit, desktop installed (KDE or GNOME) and something about your computer and video system.

Thank You,

On 2011-11-05 11:36, phil995511 wrote:
>
> I have compiled/installed a 2.6.39 kernel from ‘The Linux Kernel
> Archives’ (http://www.kernel.org), but I have a problem with a few
> drivers, my computer not boot on « standart mode » but on « safe-mode
> » i’ts possible… have you a idea to optain a good compilation with
> a fonctionnel drivers ?

You have to use a similar .config to the one openSUSE uses.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Hi,

I work on suse 11.4 x64, with gnome, on Vaio VPCSB1Z9E/B ( http://www.sony.fr/product/vn-s-series/vpcsb1z9e ) with Radeon HD 6470M graphic card.

Kernel 3.1 is not optimised for my system, the fans are always 100%, it is noisy.

When I have compiled my new kernel (2.6.39), I have tested to use .config on 2.6.37 kernel but dont work correctly.

12.1 Live-Gnome RC2 dont boot or install on this system… RC1 worked better.

Tks for your help and good day.

Hi,

I work on suse 11.4 x64, with gnome, on Vaio VPCSB1Z9E/B ( VPCSB1Z9E (VPCSB1Z9E, VPCSB1Z9E/B.FR5) : Spécifications techniques : VAIO & Informatique : Sony ) with Radeon HD 6470M graphic card.

Kernel 3.1 is not optimised for my system, the fans are always 100%, it is noisy.

When I have compiled my new kernel (2.6.39), I have tested to use .config on 2.6.37 kernel but dont work correctly.

12.1 Live-Gnome RC2 dont boot or install on this system… RC1 worked better.

Tks for your help and good day.

So based on what you say, I think you need to add in the kernel load option called: **nomodeset **which you can typed in before you select the standard openSUSE load and which is part of the Failsafe startup. Anyone using an AMD/ATI video chipset should look at the following thread:

Upgrading ATI driver with atiupgrade

Thank You,

tks for your suggestion, it’s a intel and amd graphic drivers she have a fan regulation problem…

Hello,

I have making a search from this problem. When I boot normaly on 12.1 final, I go on system settings, I have a option Graphical card. Only intel graphic card run, it’s impossible to use the physical switch buton from my laptop for using a Ati card… If I run on the restrain forced mode, I make init 3 and init 5 to restart x windows the fan of a intel graphical card run with noise.

It’s not a kernel problem ?

When I boot with nomodeset fonction all its cool…

I have tested the procedure to update a graphical driver on 11.4/kernel 3.x all run but after a update I have optain a kernel panik…

I need to do a test more on 12.1.

Good day.