12.1: Onboard graphic on FM1 socket uefi board in console mode (runlevel 3)

Yesterday I installed OpenSuSE 12.1 64Bit on a new ASUS F1A55-V UEFI mainboard with AMD A4 3400 CPU.
Had many problems with onboard graphics VGA connector: Welcome screen appeard on boot, selection menu also worked. Selecting “Installation”, SuSE “advertising” screen appeared, then screen got black, monitor display “no signal”, but for sure, installation kept in progress, as DVD drive spins up and down as if it were starting the install kernel. Having installation run in text mode, seemed as if hardware setup reached “starting udev”, then display went black.

I solved this by disabling onboard “IGFX” graphics in UEFI and plugged in a PCIe card - and installation worked fine with that!

As this machine should run 24/7 as an internet gateway, power costs are a concern. So I hoped it would be an issue of the installation kernel only. But for now, as OpenSuSE 12.1 runs fine with that PCIe card plugged in, I want to have it use the onboard graphics and remove the PCIe card. But the installed kernel also refuses to use the onboard graphics!

My guess: the onboard graphics has a VGA and a DVI-D connector (DVI without those analog signal pins …), and my monitor has to be connected to VGA (no chance to use DVI here!). I assume that the kernel (to be precise: something that comes with udev …) just switches output to that DVI connector, disabling the VGA output. I was not able to verify that for now, as I do not have a DVI cable to test. But even if I can verify this, it just would not solve the problem.

So: how do I get OpenSuSE 12.1 work with that FM1 socket onboard graphics on it’s VGA connector in console mode (runlevel 3)? No X is needed, nor wanted, for that gateway!

Please try:

  • kernel-{flavor} = 3.1.9 from openSUSE:12.1:Update
  • drm-radeon-kmp-{flavor} from home:jobermayr

You have then latest upstream/development KMS drivers from here:
~airlied/linux - Temporary kernel tree while k.org is off](http://cgit.freedesktop.org/~airlied/linux/log/?h=drm-next)

Another solution could be adding “nomodeset” to boot parameters.

I chose the “quick” solution adding “nomodeset” to boot parameters, and it works!
Think that’s fine for the moment.

Thanks a lot for assistance!