12.1 made my laptop forget it was a laptop

I installed SUSE 12.1 on my ASUS Z65 laptop when updating from SUSE 11.1. The upgrade was the usual nightmare, so I had to reinstall 12.1 as though it was a new install. Fortunately, I keep my /home directory on a separate partition. I now have the system running semi-acceptably, except for four problems, three of which are laptop specific type problems. I cannot seem to find any solution by searching these forums or on Google. I did not have any of these issues with 11.1.

  1. The system does not power off at system halt. I do a “shutdown -h now”, and the system will go down to the halt state, but will not turn the power off. I have also tried “shutdown -h -P now”. Both commands were tried in a terminal, and as a part of the Personal Setting/SYS Admin/Login screens.

  2. The Power Settings on the battery monitor does not recognize the laptop lid closing, nor does it allow me to set any of the actions when the AC cord is not plugged in or the battery is low. Those options are ghosted.

  3. Under 11.1, my touchpad turned off when I plugged a USB mouse in. There used to be check box in the Personal Settings/Hardware/Input Devices/Touchpad. Where has it gone?

  4. The battery monitor does not recognize that this is a laptop, with a battery. This means that I have no warning that the battery is getting low (See 2 above).

I have done quite a bit of searching on the web, and can’t seem to find anything that addresses these problems. Thanks for any insights.

These issues are very hardware specific, but I would ask if you loaded the Laptop Pattern from yaST? Try this if you use KDE: YaST / Software / Software Management, From the View Button (Top Left), select Patterens. Next, in the Pattern Listing under Base Technologies, select Laptop and the press the Accept button on the bottom right and allow those to install.

Next, you could always install the latest stable kernel from The Linux Kernel Archives at 3.2.9 using my bash script you can find here: S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.62 - Blogs - openSUSE Forums

The kernel is were most of these drivers reside, but some of the changes you note are due to the change of the KDE version to 4.7.

CPU power stuff can be setup here: YaST Power Management - Control Your CPU Energy Usage How To & FAQ - Blogs - openSUSE Forums

Another CPU Speed control script can be found here: C.F.U. - CPU Frequency Utilitiy - Version 1.10 - For use with the cpufrequtils package - Blogs - openSUSE Forums

Thank You,

On 2012-03-03 01:16, billrclarity wrote:
>
> I installed SUSE 12.1 on my ASUS Z65 laptop when updating from SUSE
> 11.1. The upgrade was the usual nightmare, so I had to reinstall 12.1
> as though it was a new install.

A system upgrade from 11.1 to 12.1 is not supported. Did you read the
documentation first?

> I now have the system running semi-acceptably,
> except for four problems, three of which are laptop specific type

Is the new install fully patched?


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I downloaded a 32 bit iso image from the SUSE .org page/Get It, 12.1 32 bit; then proceeded with Install. The Laptop pattern was by default selected, as it has been for past installs such as 11.3.

This has been one of the worst upgrades I have seen yet from Open SUSE>:(. I will give it another try, but if I am about ready to go back to 11.4, or even 11.3 which was working, even if no longer supported.:frown:

On 2012-03-03 18:06, billrclarity wrote:
> This has been one of the worst upgrades I have seen yet from Open
> SUSE>:(. I will give it another try, but if I am about ready to go back
> to 11.4, or even 11.3 which was working, even if no longer
> supported.:frown:

You upgraded from 11.1 to 12.1, and this is not supported; thus whatever
happened is your fault.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Actually, I made a typo in the original post. I should have said 11.3. But in any case, the upgrade failed, by screwing up the grub boot addresses, so I tried a new install of 12.1. So it should not have made any difference what I was upgrading from. What is important was that 12.1 did not recognize the hardware that 11.3 did. I have since done a new install of 11.4, and that went like a champ. So I will stop there, and maybe do an upgrade again when 12.2 comes along.

On 2012-03-04 22:26, billrclarity wrote:
>
> Actually, I made a typo in the original post. I should have said 11.3.
> But in any case, the upgrade failed, by screwing up the grub boot
> addresses, so I tried a new install of 12.1. So it should not have made
> any difference what I was upgrading from.

So, to clarify, what you did was a fresh install of 12.1 over an old
install of whatever. I assume you kept a separate /home partition intact.

Please, do not say “upgrade” when what you did was not an upgrade, it
confuses things and delays help.

> What is important was that
> 12.1 did not recognize the hardware that 11.3 did. I have since done a
> new install of 11.4, and that went like a champ. So I will stop there,
> and maybe do an upgrade again when 12.2 comes along.

12.1 uses a new kernel series. Sometimes problems happen. Did you run the
updater to get all the available patches?

Anyway, as you have no installed 11.4 instead, there is no point in continuing.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

There is nothing wrong with that approach and I am happy you found a working combination. I just had a hard drive failure this morning and decided to switch up to 12.1 from 11.4 myself. I had only one hard ware issue because my new sound card, well it was new last year anyway, is not supported by kernel 3.1, but requires 3.2 to work. So I used my SAKC script to install 3.2.9 today. Its possible a newer kernel might be required in your case as well and openSUSE 12.2 will likely have 3.3 I would guess. The main thing is 11.4 is still supported right here and if you have any issues, you need only to ask for help and good luck with your new installation!

Thank You,

Update on this, in case anyone else has a similar problem. I have recently installed 12.1 on the laptop again, and when I did I had a similar problem again. However, when I installed both times I had a problem from the install DVD with the video display. So, following the suggestions in the included help screen and installed with ACPI off. This turns it off in the system configuration. You have to turn it back on. Once I did this, the battery manager and power management worked that way they should.

Nice you got it working, but details, details please. ACPI off? Various options, so please the exact used one. Back on? How, where? That’s what people with the similar problem want to know.

Possibly by removing the acpi=off from grub’s boot options?