12.1 loging in to KDE withou password

New install of 12.1 with KDE I have checked that KDM is not set to passwordless login but it skips the loging scree and boots direct to desktop

Check System settings>Login screen>Convenience to see if autologin is enabled; if so, disable it.

That was the first thing I checked

eww just seen my horrible typing in first post, few more details.
Was working as should until I installed the nVidia driver and changed the splash screen to the one I used on 11.4 (login-scan-print splash 1.1) will try reinstalling this weekend.