12.1 install nvidia drivers in the hard way failed

On 12.1 fresh installed, I followed all the instructionshere:

In the past everything went smooth with 11.4, but with 12.1 it gives me an error, this is the log:
hints?? suggestions?? swear words??:wink:

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sat Nov 19 15:43:41 2011
installer version: 270.41.06


option status:
  license pre-accepted               : false
  update                             : false
  force update                       : false
  expert                             : false
  uninstall                          : false
  driver info                        : false
  precompiled interfaces             : true
  no ncurses color                   : false
  query latest version               : false
  no questions                       : false
  silent                             : false
  no recursion                       : false
  no backup                          : false
  kernel module only                 : false
  sanity                             : false
  add this kernel                    : false
  no runlevel check                  : false
  no network                         : false
  no ABI note                        : false
  no RPMs                            : false
  no kernel module                   : false
  force SELinux                      : default
  no X server check                  : false
  no cc version check                : false
  run distro scripts                 : true
  no nouveau check                   : false
  run nvidia-xconfig                 : false
  sigwinch work around               : true
  force tls                          : (not specified)
  force compat32 tls                 : (not specified)
  X install prefix                   : (not specified)
  X library install path             : (not specified)
  X module install path              : (not specified)
  OpenGL install prefix              : (not specified)
  OpenGL install libdir              : (not specified)
  compat32 install chroot            : (not specified)
  compat32 install prefix            : (not specified)
  compat32 install libdir            : (not specified)
  utility install prefix             : (not specified)
  utility install libdir             : (not specified)
  installer prefix                   : (not specified)
  doc install prefix                 : (not specified)
  kernel name                        : (not specified)
  kernel include path                : (not specified)
  kernel source path                 : (not specified)
  kernel output path                 : (not specified)
  kernel install path                : (not specified)
  precompiled kernel interfaces path : (not specified)
  precompiled kernel interfaces url  : (not specified)
  proc mount point                   : /proc
  ui                                 : (not specified)
  tmpdir                             : /tmp
  ftp mirror                         : ftp://download.nvidia.com
  RPM file list                      : (not specified)
  selinux chcon type                 : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> Installing NVIDIA driver version 270.41.06.
-> Running distribution scripts
   executing: '/usr/lib/nvidia/pre-install'...
-> done.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> Kernel source path: '/lib/modules/3.1.0-1.2-desktop/source'
-> Kernel output path: '/lib/modules/3.1.0-1.2-desktop/build'
ERROR: If you are using a Linux 2.4 kernel, please make sure
       you either have configured kernel sources matching your
       kernel or the correct set of kernel headers installed
       on your system.
       If you are using a Linux 2.6 kernel, please make sure
       you have configured kernel sources matching your kernel
       installed on your system. If you specified a separate
       output directory using either the "KBUILD_OUTPUT" or
       the "O" KBUILD parameter, make sure to specify this
       directory with the SYSOUT environment variable or with
       the equivalent nvidia-installer command line option.
       Depending on where and how the kernel sources (or the
       kernel headers) were installed, you may need to specify
       their location with the SYSSRC environment variable or
       the equivalent nvidia-installer command line option.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.

I think the problem is the version you are trying to install: installer version: 270.41.06, as stated in your post. The most current nVIDIA driver is 285.05.09 which is required to work with the kernel 3.1 included in openSUSE 12.1. You can find links to this here:

Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

I would give the new version a try or tell us the exact nVIDIA hardware to determine what else might be done.

Thank You,

The nvidia repository is up now

The problem, as jdmcdaniel3 pointed out, is the version of the driver you’re trying to use.

I got the same error on 11.4 after a Kernel-Update to 2.8.whatever when I tried to install the CUDA Development driver.

The driver version 285.xx installs just fine on 3.1 kernel (for me atm OS 11.4 x64, kernel 3.1.0-3-desktop)

I always chmod my *.run to be executable and then run them off in init level 3 as root, works just fine for my MSI N210D512D2H)

ooook :slight_smile: thanks, I will try when I will pass to tumbleweed, for now I installed from the repo :-))

I have the same issue with nvidia driver 260.19.44…

All the newer versions (starting from 270) do not work (even since opensuse 11.4). I can install the newest driver just fine, but KDE hangs during startup. It blocks on the blue ‘K’ icon when starting KDE. I can hear the startup KDE sound, but the panel and desktop itself never show up. On 11.4 I could bypass it by using the older 260.19.44 driver, but on 12.1 I can’t install it anymore…

This is a blocking issue to use opensuse 12.1 on my laptop. Can someone help out please? Card is Geforce Go 7300

Please do not attach your problem to another one, especialy not as it is resolved (as the OP here states in his last post). Most people will not visit this when they have seen that the OP is satisfied and thus not see your ask for help.

Also, you should be very, very sure that your problem is exeactly the same as the original one, else we get a mess of poss for all sorts of different problems here where nobody will understand anymore what is an answer to what.

Please start a thread of your own, with a title that expresses what your problem is. That will hopefuilly attracht peoplw to it.

nevermind, I found a bypass. In desktop effects I have to disable direct rendering and then the latest driver from the repo works. It seems to be a known problem for GO 7300 cards since april (see link below). I’m very surpriced that nvidia still has not fixed this issue…

Desktop freeze with 270.x drivers, KDE 4 and Compiz - nV News Forums