12.1 Factory KDE Live CD Build 0174 Available

After a fairly long delay, new builds of the KDE Live CDs are available at
http://download.opensuse.org/factory/iso/. I downloaded Build 0174 from August 1
and booted the CD on a VirtualBox VM. I was particularly interested to see if
Bug #704261 was fixed, and whether wireless networking would work when using the
plasmoid applet. The answer in both cases is yes.

I then installed Build 0174 on that same VM. Again, the applet showed wired and
wireless devices. I was able to connect to WPA, WPA2, and WEP networks.

So far with limited usage, the only bug I have found is that the other virtual
terminals (CTRL-ALT-F1, etc.) are garbled. I will file a bug report ASAP, but
I’m getting a “Gateway timeout” when trying to access bugzilla.novell.com.

I downloaded the 64-bit version of the 12.1 Factory KDE CD Build 0174 and burned the iso file to CD. Then I booted my Dell Studio 1537 laptop to this liveCD.

Wireless worked on my laptop. Hardware details:


linux@linux:~> /sbin/lspci -nnk | grep WiFi -A2
04:00.0 Network controller [0280]: Intel Corporation Ultimate N WiFi Link 5300 [8086:4235]
        Subsystem: Intel Corporation Device [8086:1121]
        Kernel driver in use: iwlagn

with dmesg content related to the wireless:


   45.884285] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:d
   45.889199] iwlagn: Copyright(c) 2003-2011 Intel Corporation
   45.893464] iwlagn 0000:04:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
   45.897655] iwlagn 0000:04:00.0: setting latency timer to 64
   45.897704] iwlagn 0000:04:00.0: Detected Intel(R) Ultimate N WiFi Link 5300 AGN, REV=0x24
   45.923990] iwlagn 0000:04:00.0: device EEPROM VER=0x120, CALIB=0x4
   45.928212] iwlagn 0000:04:00.0: Device SKU: 0Xb
   45.932279] iwlagn 0000:04:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
   45.936528] iwlagn 0000:04:00.0: irq 47 for MSI/MSI-X
.............
   49.114872] iwlagn 0000:04:00.0: loaded firmware version 8.83.5.1 build 33692
.............
  556.088228] wlan0: authenticate with bc:05:43:5f:0e:cd (try 1)
  556.091305] wlan0: authenticated
  556.108477] wlan0: associate with bc:05:43:5f:0e:cd (try 1)
  556.118633] wlan0: RX AssocResp from bc:05:43:5f:0e:cd (capab=0x431 status=0 aid=3)
  556.118637] wlan0: associated
  556.132681] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
  566.930015] wlan0: no IPv6 routers present
  654.020124] iwlagn 0000:04:00.0: Aggregation not enabled for tid 0 because load = 0
  659.316051] iwlagn 0000:04:00.0: iwlagn_tx_agg_start on ra = bc:05:43:5f:0e:cd tid = 0

I had the laptop powered for about 45 minutes and did not see any wireless dropouts.

This laptop has Radeon HD3450 graphics (details of graphics hw info):


linux@linux:~> /sbin/lspci -nnk | grep VGA -A2
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Mobility Radeon HD 3400 Series [1002:95c4]
        Subsystem: Dell Device [1028:029f]
        Kernel driver in use: radeon

I obtained an error upon desktop boot that special desktop effects needed to be disabled. There was no folder on the desktop (with My computer, firefox, etc … ) but it was a simple matter to add the folder via the widget and pointing it to /home/linux/desktop.

There was no ‘set of 4 squares’ to provide the nominal 4 desktop selection (I don’t know its proper name).

I don’t have time to confirm tonight, but on the liveCD it appears there was a step back in Radeon driver functionality from the Milestone-3 build for this Radeon HD3450 hardware (ie fewer desktop effects functional). I note - xf86-video-ati 6.14.2 included in xorg-x11-driver-video, so possibly some functionality was lost with that …

This needs more testing …

In reply to my own previous observations :

I rebooted to the liveCD and obtained no such behaviour this time. I do recall I was messing about with the mouse and start menu last time before KDE had finished booting. Maybe I brought that error on myself.

Same again this time. No folder on the desktop. But it is easy to add, and for all I know this could be a deliberate policy decision.

The same again when I rebooted, but this time I figured out to go to Configure Desktop > Workspace Behaviour and increase the # of desktops from 1 to 4. IMHO if 1 desktop is the default behaviour it may not be optimal.

I take that back. Its working well now with the Radeon driver. … cube rotation, fade, slide, etc … and other effects. The problem last time may have been me.

I reported the successful behavour of the Intel Wireless 5300 AGN in this bug report: https://bugzilla.novell.com/show_bug.cgi?id=675433

It may not be the best place to comment, but due to social commitments, I may not be able to participate in the upcoming August bug squashing session, so such entries into bugzilla on bugs that I have raised may be the best I can do.

Encouraged by your success, I downloaded Build 179 of the Gnome LiveCD and Build 186 of the KDE LiveCD. Tested in live sessions, both versions worked correctly, although the subsequent processes of installing them to hard disk on a spare machine were, for some reason, glacially slow. The same (lack of) performance was evident whether I used an actual CD or a USB stick, so the slow performance was presumably caused by a CPU-bound process (image decompression comes to mind, but I am no expert in this area) rather than being governed by data transfer limitations.

Once the installation was completed, both versions ran at normal speed. In the Gnome version, I experienced crashes with Evolution 3.1.3 (which still seems to be very much a WIP) and we seem to have returned to a more-or-less vanilla G3 shell, with all its current minor frustrations. The KDE version was very nice, although I installed Thunderbird rather than using Kmail, so can’t report on how successful the roll-out of Kmail2 has been. On both versions, wireless and graphics are just fine on my Compaq C700 laptop.

There’s obviously been a lot of solid progress since M3. My compliments to all concerned.