12.1 did not run Automatic Configuration after instalation and will not boot

I am having issues getting the Automatic Configuration to run after the initial reboot I have had this issue before but somehow managed to get 12.1 working and running well for a month and then the computer went in for warranty work and Dell re-imaged my hard drive alas Linux was no more. I am trying to dual boot between SUSE and Windows 7 which I still need. I am a new Linux user but I am learning quick here is what I know so far. The error codes I am getting are as follows.

After the initial boot the codes are.

end_request: I/O error, dev sda sector 25905220
system-readahead-collect [405] :failed to open packfile: read only file system

After the first failed I tried different ways boot safe settings systemmd system v while the results were slightly different the result was similar to the end_request code above.

I have tried multiple installation media DVD Live CD Live USB and always checked the media I have run multiple reboot checks on the drive and it seems healthy and only 9 months old.
I get the grub menu to come up so I can select an OS Windows 7 still works (I killed it a few times) my partition setup and boot configuration are the default from SUSE but I have tried different things.

I am running
Dell Inspiron M5010
AMD Phenom II 2.3 Ghz tripple core processor
ATI Mobility radeon 4250
6 Gigs of ram

root@PartedMagic:~# fdisk -l

Disk /dev/sda: 640.1 GB, 640135028736 bytes
255 heads, 63 sectors/track, 77825 cylinders, total 1250263728 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x8865e943

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63   246051539   123025738+   7  HPFS/NTFS/exFAT
/dev/sda2   *   246052864  1250263039   502105088    f  W95 Ext'd (LBA)
/dev/sda5       246054912   250261503     2103296   82  Linux swap
/dev/sda6       250263552   292206591    20971520   83  Linux
/dev/sda7       292208640  1250242559   479016960   83  Linux

Help is appreciated. Matt

Just because it is only 9 months does not mean that it does not have a bad sector. Get a low level scan program form the disk’s maker and check it.

Tried reading more posts and then tried nomodset and safe settings from the installation disk while waiting and this post is from a 3 minute old working SUSE instalation.