12.1: crypt-setup und systemd

Hi,

is there a chance to disable the timeout on crypt-setup during the boot process?
Basically the system shall wait for an input, and not continue booting after some minutes, without having the encrypted home-partition mounted.

Thanks

http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/472714-how-disable-timeout-password-entry-encrypted-home-partition.html

This came up in in another thread.

The solution is to handle the cryptsetup earlier, before systemd is involved.

Edit “/etc/crypttab” and put “initrd” in the last column. There is probably a “none” there, so change that to “initrd”. Do this for every line that has a LUKS encrypted partition.

Then (also as root), run


# mkinitrd

That should put the cryptsetup into your “initrd”, where it will wait forever for entering the key.

/lib/systemd/system/cryptsetup.target

#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU General Public License as published by
#  the Free Software Foundation; either version 2 of the License, or
#  (at your option) any later version.

# See systemd.special(7) for details

[Unit]
Description=Encrypted Volumes

[Service]
TimeoutSec=0

So I am not using this service, but above is the setup file I find in my system but I have added the service section with the option TimeoutSec=0 which which means to wait forever. If your file has more than mine, just add in this one section. If this is not the problem, your system may hang at this point. You must edit this file as root and restart your PC for it to take effect on your next startup. Good Luck

Thank You,

Hi,

thanks for your replies, unfortunately both do not work.
When creating initrd:

T520:~ # mkinitrd

Kernel image:   /boot/vmlinuz-3.1.10-1.9-desktop
Initrd image:   /boot/initrd-3.1.10-1.9-desktop
KMS drivers:     i915
Root device:    /dev/disk/by-id/ata-HITACHI_HTS727550A9E364_J3360081GELPDD-part6 (/dev/sda6) (mounted on / as ext4)
Resume device:  /dev/disk/by-id/ata-HITACHI_HTS727550A9E364_J3360081GELPDD-part5 (/dev/sda5)
Device mapper!cr_sda7 not found in sysfs
There was an error generating the initrd (1)

And the variable TimeoutSec=0 is just silently ignored. Any other value instead of 0 as well (tried 99999) not working

This already been submitted as a bug. https://bugzilla.novell.com/show_bug.cgi?id=749706

Ah, OK, thanks for the hint

You are welcome. Hopefully they will be able to resolve this with an update in the near future.