12.1> 'Configure Desktop> System, Personal Settings)> Loing Screen> Does Nothing

Hello,
I know this is a KDE fairy issue, but maybe someone has figured it out… or is the ‘Login Screen’ another useless app, I’ve wasted half a day on and I should have been using YaST2> SysConfig all along?

I’ve changed every setting in the ‘Login Screen’ applet and Nothing changes at login in.
I’ve enabled, disabled the ‘splash screen’ too.

The ONLY thing that changes the ‘login screen’ is SysConfig (YaST2) > Desktop> Manager> either Default or SUSE are the choices… I’ve just Typed in Oxygen myself and after I’m done installing VLC, I’ll see what that did… if anything…

So, has Anyone gotten the nice looking, black ‘Oxygen’ theme, Nonu by Fernandes Pinheiro to work?

No? didn’t thinks so…

I looked one of my other systems, Linux-IBM running 11.4 and on the ‘general’ tab, it’s set to ‘<default>’
I’m afraid to touch it…

Thanks in advance,
Landis.
p.s, KDE kicked me off years ago and knows when i re-signup and kick me right back off … LOL … : )
Спасибо!

Nope… typing ‘Oxygen’ in the sysconfig> desktop> login theme did nothing…
I still have a streaky blue KDE login screen??

Landis.

Check if you have the package ‘kdm-branding-upstream’ installed.

I have listed:
kdm - KDE package manager, blah, blah
kdm-branding-openSUSE - blah, blah
kdm-branding-upstream - Not installed…

You know, had I not got sidetracked, I was going to try removing the opneSuSE branding like I’ve always done with mozilla. but I wouldn’t have thought to install the upstream although I always did with firefox.
but, for the last couple years, I ONLY run mozilla/nightly builds and lately have even disabled the os installed version of ff and edit the firefox.desktop… blah, blah, you don’t care about that… sorry.

So, do you think I should UnInstall the SuSE branding or just install, additionally the upstream package?

Thank You.
Landis.

well, that answers that… I started to install upstream and it errors, ‘conflicts with brandingSUSE’…
so, guess i’ll start YaST2 and uninstall suse branding first.

I’ll be back,
Landis.

Well as is the case with KDE, the applet in system settings (personal settings, desktop settings, whatever) does Nothing. I was useful for looking at, downloading and installing other ‘themes’ but failed at that several times, as it timed out ‘getting previews’…

Anyways… Using YaST2> System> SysConfig Editor worked most of the time, but not every time and you Have to know the proper name to your ‘theme’ directory as the ‘pull-down’ in SysConfig>Desktop>Display Manager> DISPLAYMANAGER_KDM_THEME does not list the contents of the ‘themes’ directory. You’ll have to know the Actual Directory Name in /usr/share/kde4/apps/kdm/themes/ eg, BlueCurls, oxygen-original, tuxnspc etc…
Unless I did something different or wrong, this didn’t work ‘every time’ in SysConfig Editor, but It did work every time using root login or su and editing /etc/sysconfig/displaymanager file directly (i use kwrite, always, kate’s nice too).

anyways, thought i’d share… After 25 or more reboots, the ‘Login Screen’ applet didn’t work once! I got it to change the ‘splash screen’ each user sees After the login screen, but Not the login screen whether I was logged in as root or the applet allows for giving the root password when you choose ‘apply’…

have a nice day.
Landis.
happy new year мир!

On 01/01/2012 02:16 AM, landis wrote:
> Unless I did something different or wrong, this didn’t work ‘every
> time’ in SysConfig Editor, but It did work every time using root login
> or su and editing /etc/sysconfig/displaymanager file directly (i use
> kwrite, always, kate’s nice too).
>
> I was logged in as root or the applet allows for giving the root
> password when you choose ‘apply’…

if by “using root login” and “I was logged in as root” you mean you
logged into KDE as root, then yes you did do something wrong, and that
something could be, might be, probably is part of the long list of
problems you encounter…

there are no admin duties which require one to log into any *nix GUI
as root…doing so should always be avoided, and doing otherwise most
often results in subtle damages to file/directory permissions which then
complicate, or prohibit, routine system administration and throw up a
multitude of small, hard to trace and seemingly impossible to solve
problems…


DD http://tinyurl.com/DD-Caveat
openSUSE®, the “German Engineered Automobiles” of operating systems!

This has been an annoyance for more than one release of OpenSuSE. This is an OpenSuSE issue. It’s been a pain for a while.

I haven’t had any real problems adjusting login themes in Fedora 15 or 16. I can change Login themes in (K)ubuntu, Arch, and others using the KDE4 gui management tools. Every so often you might have to adjust some permissions or get messy with a gui root login. I have had to copy theme files to alternate locations and change permissions which cough we’re not suppose to change.

There is a post some place in the opensuse forums where someone had over come the challenge of adjusting login themes in an earlier version of OpenSuSE. I don’t think the solution was complete; but it was close and they were just short of a couple of steps to fix the issue. I can’t find it at the moment but it has to be here.

I found this helpful; it’s not a fix for my system but it’s along these lines:
Problems when Configuring the Login Screen by the KDE4 Login Manager | Hans-Hermann-Bode.de / h2b.de

I think the above is close to the mark. I’m missing something small… I just don’t know what.

The solution is here some place.

Personally; I like to use the federation login theme.

There is a solution. There always is!

I’ve seen at least one OpenSuSE 12.1 installation on a friend’s machine where she managed to get login themes to work. She remove all the “green” login and exit stuff. She isn’t using gnome or gdm magic. I’ve asked her to to show me the magic; unfortunately she’s a Montreal Canadian’s fan and I’m Leaf’s fan.

So like everyone else: I Google.

I’m sure she had to mess with Grub2 and get dirty with some graphics files. Regardless she is using KDE4 login themes and the login management tool works on her computer. She has to adjust the login theme through KDE as Root. That’s what I do in the Fedoras and others.

As for gui login’s as root; it’s your system (I hope) and the last time I checked we’re still not sacrificing goats to what’s left of Novell; or to anything *nix… yet. Hopefully a wild pack of screaming Orthodox *nixers won’t break down your door and toss your computer into a microwave oven seeking divine judgement as a result of a login to KDE as Root. We’ll have to wait for Apple to i-Religion Unix first. Then we can get all orthodox about *nix.

After we get Ortho-nixed; then we can throw iPods at our evil machines so they refurbish themselves to the light side of the force.

Something along these lines has to influence this also:

openSUSE 12.1 SUSE KDM Login Screen User Listing - Blogs - openSUSE Forums

I’m hoping there is an “easy” solution. Well it’s a nice thought.


kdesu systemsettings

That’s all. And it should be like that. Linux is a multiuser environment, built like that. So we have the system’s space (managed by root), we have the users’ spaces (managed by each user for his/her space). The login screen belongs to the system, so can only be changed by root.

And that’s why, upon klicking “Apply”, an authorization dialog asks for the root password.
Attempts following your advice with “kdesu systemsettings” yielded no more success than attempts via “Configure desktop - Login screen” as a lowly common user (with root password dialog as mentioned above).
I think it was one of the old 9.x versions of SuSE Linux where I could still choose a .jpg picture for a background and select the users that should be listed. Actually, the latter I could still do on my 11.4 version.
In 12.1: are all the options just carried over from previous releases, but lacking functionality, or is there something we are doing wrong?