12.1 64 bit won't boot

I’ll start by saying I’m a linux noob, so please excuse my ignorance! I tried to install it from a DVD, and everything seemed ok until it said something along the lines of “changing to text-based installation, graphics card may not be supported” when it went in to the Configuration section of the install. I let it finish, and it came up with the command line so i rebooted. Up came the GRUB and I chose the Desktop option, but it got stuck on the OpenSUSE splash screen. So i rebooted, chose the Failsafe option this time and it froze at (something like):

booting /windows/C
[long number]HDMI Status: codec=0  pin=5  presence-detect=0  ELD_Valid=0

I’m dual-booting with 64-Bit Windows 7, my graphics card is an nVidia GeForce GTX460.

Any help is greatly appreciated! :slight_smile:

Here is a copy from a recent article on the subject. You most likely need to use the nomodeset kernel load option as shown below:

1st thing to try (nomodeset)

  • The 1st thing to try
    is to boot from grub with boot code: nomodeset . This is per the guidance in the openSUSE-12.1 release notes. ie in grub’s option line enter:

nomodeset
New users, to explain better for you, please note you enter this boot code in the very first openSUSE menu you see when you switch ON your PC. Just start typing and you will see the letters for ‘nomodeset’ appear in the options line of the menu.
http://en.opensuse.org/images/thumb/8/8f/Nomodeset-example.jpg/200px-Nomodeset-example.jpg](File:Nomodeset-example.jpg - openSUSE Wiki) http://en.opensuse.org/skins/common/images/magnify-clip.png](File:Nomodeset-example.jpg - openSUSE Wiki)
Boot with nomodeset boot code

Then after entering that, press <enter> and let your PC boot. Hopefully that will be sufficient and you will have a functional desktop at that time. The openSUSE-12.1 release notes provide more detail, especially on how to make this permanent.

If this helps, you may want to know how to install the proprietary nvidia video driver you can read about here: Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

and I have a bash utility you can use here: LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.20 - Blogs - openSUSE Forums

and read all of the links to get the full picture on the issue and good luck.

Thank You,

With “nomodeset”, the desktop option still freezes at a splash screen, but a smaller one. Failsafe still freezes as well. :frowning:

You should boot in console mode (not try to start X at all), login as root and install the nvidia driver from repo.


zypper ar [noparse]ftp://download.nvidia.com/opensuse/12.1/[/noparse]  nvidia
zypper refresh
zypper install x11-video-nvidiaG02

You need an Internet connection at this point though.

I have an internet connection. But what do you mean not start X? How do I boot in to console mode? Also, how do I log in as root? Sorry, I’m a really big noob…

In my example above, you enter the kernel load option nomodeset. Imagine that in addition, you add the number 3, which sends you to run level 3. So, you would enter: nomodeset 3 which would leave you at the terminal prompt, able to enter the root user name and password and then able to enter the command please_try__again suggests above to load the nVIDIA driver.

Thank You,

I bet you do, but it must be available in console mode - which might not be the case if you setup your nic with network manager. If you used the ifup method, it will be OK.

You would add “3” in the Boot Options line. I’m not sure it works in systemd. If it does not, press F5 (Init Program), select “System V”, add “3” to the Boot Options and boot the normal kernel (not failsafe!). It should bring you to a console login prompt.

None of it worked… It just got stuck. I tried everything on everything :frowning:

Boot from a live CD and post the output of these two commands:

lspci
hwinfo --gfxcard

Sorry for the double-post! would changing the DE matter? I installed with GNOME but would have no problem using KDE or XFCE

EDIT
Ok, I’ll go downlaod the Live CD now, but the download is going surprisingly slow so looks like I won’t have it until tomorrow :frowning: (I’m downloading the KDE Live CD, if it matters)

I don’t know if it matters or not, but I’m running the KDE Live CD but installed as GNOME… anyways here are the results of the commands:

lspci

00:00.0 Host bridge: Advanced Micro Devices [AMD] RS880 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (ext gfx port 0)
00:09.0 PCI bridge: Advanced Micro Devices [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 4)
00:0a.0 PCI bridge: Advanced Micro Devices [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 5)
00:11.0 SATA controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode] (rev 40)
00:12.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 42)
00:14.1 IDE interface: ATI Technologies Inc SB7x0/SB8x0/SB9x0 IDE Controller (rev 40)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: ATI Technologies Inc SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge (rev 40)
00:14.5 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:16.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:16.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
01:00.0 VGA compatible controller: nVidia Corporation GF104 [GeForce GTX 460] (rev a1)
01:00.1 Audio device: nVidia Corporation GF104 High Definition Audio Controller (rev a1)
02:00.0 IDE interface: VIA Technologies, Inc. VT6415 PATA IDE Host Controller
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

hwinfo --gfxcard

31: PCI 100.0: 0300 VGA compatible controller (VGA)                                                                                  
  [Created at pci.319]                                                                                                               
  Unique ID: VCu0.BEZbHPpl76F                                                                                                        
  Parent ID: _Znp.UAx368lzOkB                                                                                                        
  SysFS ID: /devices/pci0000:00/0000:00:02.0/0000:01:00.0                                                                            
  SysFS BusID: 0000:01:00.0                                                                                                          
  Hardware Class: graphics card                                                                                                      
  Model: "nVidia VGA compatible controller"                                                                                          
  Vendor: pci 0x10de "nVidia Corporation"                                                                                            
  Device: pci 0x0e22                                                                                                                 
  SubVendor: pci 0x3842 "eVga.com. Corp."                                                                                            
  SubDevice: pci 0x1370                                                                                                              
  Revision: 0xa1                                                                                                                     
  Driver: "nouveau"                                                                                                                  
  Driver Modules: "drm"                                                                                                              
  Memory Range: 0xfc000000-0xfdffffff (rw,non-prefetchable)                                                                          
  Memory Range: 0xd8000000-0xdfffffff (ro,non-prefetchable)                                                                          
  Memory Range: 0xd4000000-0xd7ffffff (ro,non-prefetchable)                                                                          
  I/O Ports: 0xcc00-0xcc7f (rw)                                                                                                      
  Memory Range: 0xfea80000-0xfeafffff (ro,non-prefetchable,disabled)                                                                 
  IRQ: 18 (10541 events)                                                                                                             
  I/O Ports: 0x3c0-0x3df (rw)                                                                                                        
  Module Alias: "pci:v000010DEd00000E22sv00003842sd00001370bc03sc00i00"                                                              
  Driver Info #0:                                                                                                                    
    Driver Status: nvidiafb is not active                                                                                            
    Driver Activation Cmd: "modprobe nvidiafb"                                                                                       
  Driver Info #1:                                                                                                                    
    Driver Status: nouveau is active                                                                                                 
    Driver Activation Cmd: "modprobe nouveau"                                                                                        
  Config Status: cfg=new, avail=yes, need=no, active=unknown                                                                         
  Attached to: #10 (PCI bridge)                                                                                                      
                                                                                                                                     
Primary display adapter: #31

I reinstalled once again with KDE this time, and a command-line came up immediate after installation so I managed to run these commands:

Still no luck… :frowning:

Whether you use KDE or Gnome doesn’t matter, to answer your question a bit late. I wanted to make sure that you didn’t have a hybrid graphic card (nvidia + somethng else), but it looks like you don’t. What happened when you ran the zypper commands? Did they install the nvidia driver? Are you able to get a console login now? If you do, what is the output of this command now:

hwinfo --gfxcard

and the result of these commands:

lsmod | grep -i -e nvidia -e nouveau
rpm -qa | grep nvidia
lsinitrd /boot/initrd | grep nouveau

It went through the motion’s, I guess. Everything downloaded, completed, refreshed, installed without error. I’ll go try to get in to the command-line again, and report back.

Command line still won’t boot either.

Well, I had pretty much given up on OpenSUSE until last night I left windows on to finish a download, came to check the download/turn of my computer, and somehow it was booted in to OpenSUSE! Here’s the result of the commands, please_try_again, and I’m hoping it’ll boot again:

hwinfo --gfxcard

31: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.319]
  Unique ID: VCu0.BEZbHPpl76F
  Parent ID: _Znp.UAx368lzOkB
  SysFS ID: /devices/pci0000:00/0000:00:02.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia VGA compatible controller"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0e22 
  SubVendor: pci 0x3842 "eVga.com. Corp."
  SubDevice: pci 0x1370 
  Revision: 0xa1
  Driver: "nvidia"
  Driver Modules: "nvidia"
  Memory Range: 0xfc000000-0xfdffffff (rw,non-prefetchable)
  Memory Range: 0xd8000000-0xdfffffff (ro,non-prefetchable)
  Memory Range: 0xd4000000-0xd7ffffff (ro,non-prefetchable)
  I/O Ports: 0xcc00-0xcc7f (rw)
  Memory Range: 0xfea80000-0xfeafffff (ro,non-prefetchable,disabled)
  IRQ: 18 (828794 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v000010DEd00000E22sv00003842sd00001370bc03sc00i00"
  Driver Info #0:
    Driver Status: nvidiafb is not active
    Driver Activation Cmd: "modprobe nvidiafb"
  Driver Info #1:
    Driver Status: nouveau is not active
    Driver Activation Cmd: "modprobe nouveau"
  Driver Info #2:
    Driver Status: nvidia is active
    Driver Activation Cmd: "modprobe nvidia"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #10 (PCI bridge)

Primary display adapter: #31

lsmod | grep -i -e nvidia -e nouveau

nvidia              12136858  40

rpm -qa | grep nvidia

nvidia-computeG02-290.10-13.1.x86_64
x11-video-nvidiaG02-290.10-13.1.x86_64
nvidia-gfxG02-kmp-desktop-290.10_k3.1.0_1.2-12.1.x86_64

lsinitrd /boot/initrd | grep nouveau
…nothing happens.

You were using ‘nouveau’ before. Now you’re using the nvidia proprietary driver. That’s the difference. It should be OK now.

Alright! Thanks a ton, then! If it’s not too much bother, could you explain why it suddenly worked now?

To give a short and incomplete answer, the ‘nouveau’ driver, which is open source and installed by default, uses a feature named “kernel mode setting” (that you can deactivate with the option ‘nomodeset’, although it doesn’t always work). Some models of Nvidia cards simply don’t work with kernel mode setting. Most of them will work with the ‘nomodeset’ option but not all. The nvidia driver doesn’t use “kernel mode setting” and it does deactivate it (removes the feature from initrd). It also blacklists the ‘nouveau’ driver. And this is why it finally worked.

Well it froze up as soon as my disc finished burning, so I did a manual restart and it won’t boot in to it, again. This is getting really irritating lol. Any more ideas? :frowning: