11 and 11.1 (unable to add default route using yast)

Is it me or is there no way to add your default route in yast (the command-line version, not the GUI). If this is indeed missing, has a bug report been filed? This has been a problem for me in 11.0 and it seems to still be an issue in 11.1. I don’t have this problem on OpenSuSE 10.1 or 10.3. I searched Bugzilla with no results.

Please do not reply with “use yast2” or “use route” to configure it. I know it works with yast2 yet I don’t like working in a GUI when I need to configure something so simple. I know how to use route but I’d prefer to use the OpenSuSE method/configuration tool to configure the system. I want to know if this is a problem with yast before I file a bug report. Thanks in advance.

  • Ken

There was a thread a while ago, where someone had the same problem, the routing dialog was there to do it in GUI yast, but not in ncurses yast.

The answer turned out to be surprising. For some reason, his terminal window was not large enough and ncurses yast omitted to display the tab which would have led to the routing dialog.

Maybe you might want to check if that is the case. For sure ncurses yast (on my terminal) has the routing dialog.

“His terminal window was not large enough” points to a GUI-based window within an X session being resized too small. If he’s already in a GUI, why not use yast2? I’m talking about a TTY session where screens are formated by columns and lines, not pixels.

Just to show that it’s not this issue, here is OpenSuSE 11 in a VMware Server session on my laptop and the TTY session is much greater than the normal 80x24:

ImageShack - Image Hosting :: noroutewr9.jpg

Where’s the route option? If I click on NEXT, I only get the option to confirm my settings before saving.

No, he was logged using ssh and putty IIRC.

It’s in the same position in ncurses yast as the GUI yast. Just under the title: Network Settings, there’s a menu bar:

Global Options–Overview–Hostname/DNS–Routing

Highlight this menu bar and then use the right arrow to move to Routing.

I think you went looking for it under the Network Device. But routing is global so it’s in the Network Settings menu.

That was it. I didn’t see the options at the top of the page. I was looking for it in the same area where it was located in 10.1. Many thanks for the help!

  • Ken