11.4 x64 Black border around screen at native resolution

Hi All,

I’m setting up a Dell Inspiron One 2305 and I can’t get the native monitor resolution to work without black borders. I’m also experiencing blurry text in Firefox (not sure if this is related).

At most other resolutions it will expand to the edges of the monitor fully. Note that the desktop area doesn’t extend into the border. I tried glxgears and noticed that it was only pulling 60fps – figuring it needed drivers I installed the latest ATI drivers. On reboot I was given more options for resolutions however the native one still doesn’t work properly.

I looked around for troubleshooting tips and looked into xrandr output.

Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 1920 x 1920

DFP1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 510mm x 287mm
   1920x1080      60.0 +   50.0     30.0     25.0     30.0  
   1776x1000      50.0     59.9     25.0     30.0  
   1680x1050      50.0     59.9* 
   1400x1050      50.0     59.9  
   1600x900       50.0     59.9  
   1280x1024      50.0     60.0  
   1440x900       50.0     59.9  
   1280x960       50.0     60.0  
   1360x768       50.0     60.0  
   1280x768       50.0     60.0  
   1280x720       60.0     50.0     59.9  
   1024x768       50.0     60.0  
   1152x648       50.0     59.9  
   1024x600       50.0     60.0  
   800x600        50.0     60.3  
   720x576        59.9     50.0  
   800x480        50.0     60.3  
   720x480        50.0     60.0     59.9  
   640x480        50.0     60.0     59.9  
CRT1 disconnected (normal left inverted right x axis y axis)

Using ‘configure display settings’ in Gnome, any time I picked a resolution that was 50, it would cause the borders. Any time I picked a resolution that was 60 AND xrandr listed a 60 and 59.9 and said 60 was the selected one, the borders would come back for those too.

So I tried
xrandr --output DFP1 --mode 1920x1080 --rate 59.9

Seeing as every resolution with 59.9 worked. However… This still resulted in borders. I’m out of ideas!

Resolved… Not sure how exactly which I’m kind of mad about.

Instead of using the drivers from the 11.4 Ati repository, I installed the ones direct from ATI website along with the control center. In control center had same problems, but I found a setting ‘use graphics processor for scaling’ rather than ‘use display for scaling’ which I think did the trick. I had to reset resolution again afterwards to have it take effect.

The new drivers also fixed blurry text.

Well done, thanks for the feedback.