11.4 wont boot from SATA drive

Does your issue appeared to be random or unpredictable nature? I had issues with 11.4 in machines which 11.3 ran perfectly and reliably.

I suggest you read thread I had posted and resolved.
11.4 troubled boots

OS doesnt wanna to load at all in my case. I think this is GRUB specific problem. It doesnt see my HDD or something like this.

Why in rescue mode? Any chance we could see ‘pata’, ‘sata’ or ‘ahci’ in this output?
I think I was wrong about ata_piix. I actually see it on one machine (old Intel Dual Xeon), but the HDs are on the promise (on board) controller (sata_promise).

@wezen, @si1975, It looks like both of you have a similar mainboard using the Intel IDE/PATA driver ata_piix.

Something interesting:

I have created only one partition on the drive and successfully installed OS.
/dev/sda1 * /

I also noticed that you used a separate /boot partition in your previous install:

and wondered if /boot/grub/menu.lst had been written properly. What about /, swap,/home partition scheme?

If you want to run Linux without a swap partition, you should create a swap file.

Good work wezen. I have tried somthing similar and can now boot in SATA mode:

sda1 72.52GB ext4
sda2 2.01GB swap

i installed GRUB in root and mbr.

I will try again and add a home partition as well. Is the auto partititon setup broken?

You can use a live system like PartedMagic to create the partitions you want before running openSUSE setup. Since you’ll use it only to partitionate a disk and not to repare/reinstall Grub, any version of PartedMagic will do it (newer versions don’t use the same version of Grub as openSUSE and therefore won’t repare it). Once you have prepared your partitions, install openSUSE and choose the option “Create partition setup” and “Custom partitioning (for experts)” as shown on these 2 pictures:

This is not difficult. You just select one by one the partitions you want to use for Linux, choose mountpoints, filesystems and check “Format”.

  • **Always check “Format” **
    for partitions where you want to create a new filesystem (even if you formated them previously with PartedMagic or another partitioning tool).
  • Never check "Format"
    for partitions where you want to preserve data (like a /home partition while reinstalling).

You should install Grub in MBR if it doesn’t bother anyone. It wouldn’t bother Windows in most cases but usually won’t last very long in MBR. So Windows users normally don’t like it. Installing Grub in Linux root partition doesn’t hurt (even if you think you won’t need it). Installing Grub in the extended partition, setting the bootflag on that partition and writing a generic boot code in MBR is particular to openSUSE and is also the default … and I guess I’m not going to explain once again that is a weird idea - although it does work in many “normal” situations.

  • The pictures describe the network installation of openSUSE 11.4 in a virtual machine. Except for hard disk name (/dev/vda in this case) and partition size, it’s not different from the installation on a physical machine. Net installation and DVD have the same setup. Live CD is something different (many fine tuning options are missing… I guess).

Now booting with no problems in SATA mode.

I did a manual partition setup using the opensuse installer. As long as root is in sda1 everything works. I also set grub to install into mbr and root.

Working setup is:

sda1 20.00GB ext4 /
sda2 2.00GB ext4 swap
sda3 52.52GB ext4 /home

Thanks to wezen and please_try_again for the help.