11.4 wont boot from SATA drive


I have just installed opensuse 11.4 and the install fails to boot, grub hangs or gives an error.

I have tried installing grub in MBR and root changed every setting I can find and even downloaded a fresh ISO. As a last resort I changed the machines BOIS settings from SATA to emulate ide, booted as expected but a bit slow.

11.2 and 11.3 worked on this machine with no problems. Am i missing something? I also tried an Ubuntu install and this worked fine!

si1975 wrote:

> Hi
> I have just installed opensuse 11.4 and the install fails to boot, grub
> hangs or gives an error.
Which error exactly, please post it.

Please provide some more details about your harddisk, bios, manufacturer.
Otherwise we can only guess.

PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.1 | GeForce
9600 GT | 4GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | Gnome 2.32 | nVidia
ION | 3GB Ram

Your initial ramdisk is missing something: the sata kernel module. If you switch to IDE mode, the hard disks are handled in PIO mode and the I/O is then extremely slow.
Can you boot from live CD and issue this command:

lsmod | grep ata

Then check /etc/sysconfig/kernel on your installed system:

grep "^INITRD_MODULES" /etc/sysconfig/kernel

You should add the missing sata module here and run /sbin/mkinitrd.

  • And of course, forget about IDE mode !

Thanks for the replies.

machine is: 2.4Ghz Pentium 4 | GigabyteGA-81PE1000 motherboard | Intel 865PE AGPSet BIOS| seagate
barracuda 7200.7 SATA hard drive | 3GB RAM | GeForce 6200 | ide cd/dvd writer.

The GRUB error with SATA enabled is:

"GRUB Loading stage1.5

GRUB loading, please wait . . .
Error 21

The machine then hangs and has to be rebooted.

Running a live cd (opensuse 11.3 is all i can get my hands on) “lsmod | grep ata” shows:

ata_generic 2711 0
ata_piix 19945 1
libata 185684 3 ata_generic,ata_piix,ahci
scsi_mod 189241 5 st,sg,sr_mod,sd_mod,libata

then “grep “^INITRD_MODULES” /etc/sysconfig/kernel” on the installed system shows:

INITRD_MODULES=“thermal ata_piix ata_generic processor fan”

I’m not 100% sure which bit to add.

ata_pixx should be the module you need for your Intel board. It is there. So in IDE mode, Grub finds the hard disk an boots while in SATA mode in does not? I assume you didn’t switch the mode just after installing the system, which could produce such an issue. What do you mean by SATA mode, AHCI? Can you boot with the live CD while in IDE mode and while in SATA/AHCI mode and run fdisk -l in both cases to check the differences. You will pretty much have to reinstall Grub. You said you installed Ubuntu in the meantime? Which version of Grub is in your MBR right now?

So in IDE mode, Grub finds the hard disk an boots while in SATA mode in does not?

Yes the machine hangs in SATA mode, the install failed half way through when the system restarted and ejected the DVD. This is when I changed the BIOS settings. The BOIS has a “integrated peripherals” page where the SATA port can be set in compatible mode to remap as IDE primary master. I can’t find any mention of AHCI in my BIOS settings.

My current GRUB version is: GNU GRUB version 0.97

For some reason my machine will not boot the live CD while the SATA drive is emulating IDE.

Do you have any pointers for reinstalling grub?

Thanks for the advice.

I just noticed that you ran openSUSE 11.3 live CD. That doesn’t help since you already know that 11.3 worked on this machine. You should boot 11.4 and check if the ata_piix module has been loaded. I would also test the media from which you installed 11.4. Tell us what you did exactly. Fresh install or update? Are there other operating systems on this machine? How many hard disks do you have, etc? And what do you intend to do? Single boot, dualboot, etc.

I wont get back to the desktop machine till tomorrow so cant check
ata_piix module has been loaded till then.

Here is the list of attempted installs:

Started with a working version of 11.3 booting from the sata drive. I had not changed any BOIS settings for years.

Installed 11.4 from a live dvd (magazine cover disk) as an upgrade. The machine booted and ran as expected. A few problems with KDE and my old user area so i decided to to a clean install.

11.4 clean install from live dvd (magazine cover disk) default settings and partition table. Failed to boot with grub error: Error 21

Another 11.4 clean install from live dvd (magazine cover disk). All settings checked manually, fdisk and format of harddisk. Failed to boot with grub error: Error 21. Tried again and installed grub into the MBR instead of root partition. Still failed to boot and grub hung with no error just blank screen.

Tried mythbunto install from same DVD worked and booted as expected.

Downloaded full 11.4 install iso from opensuse mirror. Checked md5 and install media checked. Clean install with default settings and partition table. Failed to boot.

Yet another clean install all settings checked manually fdisk and format of harddisk. Grub installed into MBR. Failed to boot, changed BIOS setting for SATA to remap to ide. BOOTED!

I am running a single boot system with one harddisk. I no longer have the 11.4 live dvd but will do another full clean install if i can get the system working with SATA.

Have tried to rollback to 11.3 from live dvd (drive set as SATA). This also fails to boot half way though the install when the system resets. I get the GRUB prompt with no errors.

Am I correct in thinking this is an MRB problem?

Changed the BIOS setting for SATA to remap to ide and 11.3 booted and competed the install, now i’m confused.

Found an old winXP DVD and ran FIXMBR and did another format. Did an 11.4 install from DVD with drive set to sata. I now get a GRUB prompt with no errors. I’m guesing this should boot with the correct grub command.

Can anyone help?

If i boot from the install DVD then select “boot installed system” it goes back to the GRUB prompt.

I have the same problem with openSUSE 11.4 installation.

After about ten installation attempts with different configurations I had one of the following fails:

  1. Fatal message:
    GRUB loading, please wait . . .
    Error 21

  2. Grub command line:

    find /boot/grub/menu.lst fails.

11.2 and 11.3 worked on this machine with no problems.

I have not yet experimented with IDE mode.

Same hardware?
It’s starting to sound like a bug.


Before installation, did you check the integrity of the ISO you downloaded ?

All ISO’s checked ok for me.

Have tried full 11.4 and new download of live 11.4 have also tried to install from USB stick to rule out faulty DVD drive. Have even tried a diffent SATA hard drive!

I’m out of ideas. I don’t want to change disto but others work with no probelms.

Take a SATA drive on which you have NO DATA and blank the MBR. Windows FIXMBR doesn’t fix anything. It simply write a generic bootcode. This is not what we want while booting Linux as the only operating system. To blank the first sector of the disk, boot from some live CD with NO other disk (so you’ll be sure you don’t blank the wrong disk!) and type:

dd if=/dev/zero of=/dev/sda bs=512 count=18.

This will zero fill the first 18 sectors of the disk, where usually Grub stage 1.5 get written. This disk won’t have a partition table at all. You’ll have to create one and partitionate accurately while installing openSUSE. Install from DVD or net install (not liveCD), install Grub into MBR AND in the root partition. Do not install Grub in the extended partition. Also use only one HD during the installation and don’t set your BIOS in IDE mode. If that doesn’t work, and the installation media is OK, as well as your harddisk, 11.4 install may have a problem detecting your SATA controller. The fact that other distros work could be an indication. You could also boot from fedora live CD and see if palimpsest detects an hard disk problem (it usually runs a SMART test).

Doesn`t work for me.
GRUB loading, please wait…
Error 21

Gigabyte 8IG1000-G

Did you install with only one SATA disk with blank partition table? Is it a recent WD drive with jumper 7-8 set? Does the problem occure only in 11.4? Can you boot a 11.4 live CD and look for ata/sata modules loaded?

Yes, I have detached second HDD physically.

What did you mean “blank partition table”? I ran ‘dd if=/dev/zero of=/dev/sda …’ and when created partition table:
/dev/sda1 150M ext2 /boot
/dev/sda2 1G swap
/dev/sda3 30G /
/dev/sda4 200G

This problem occurs only with 11.4. I had openSUSE 11.2 and 11.3 before. Also latest Xubundu works fine.

In rescue mode ‘lsmod | grep ata’ shows this:
ata_generic 3015 0
ata_piix 20386 0
libata 202306 2 ata_generic,ata_piix

Then “grep “^INITRD_MODULES” /etc/sysconfig/kernel” on the installed system shows:
INITRD_MODULES=“thermal ata_piix ata_generic processor fan”