11.4 upgrade to KDE4.6.2 resets login screen - can't login


Has anyone tried upgrading 11.4 to the latest SC 4.6.2 packages?

Steps I did was installing a super clean fresh 11.4 64-bits from DVD, using no other repos than the standard ones.
Then I added KDE4.6 Upgrades repo and I went to Yast and selected SWITCH PACKAGES from the repo installation list to those in KDE4.6 Upgrades. I used the following web page to guide me Install KDE4.6 in openSUSE!

But then when I come back to KDM and enter my PW, a second after I press enter it reverts back to KDM screen, no errors. I checked Xorg.0.log file and I found stuff regarding NOUVEAU driver, so I decided to start all over again but install proprio drivers of nVIDIA before performing the 4.6.2 upgrade.
Same result.

I then tried selecting packages myself from the upgrade repo, same result. I also tried the switch packages function but then manually removing KDM 4.6.2 and keep 4.6.0, same result…

I don’t know where to look for to troubleshoot that.

Any thoughts?


Can you just confirm that no issues exist immediately post install when logging in? kde4.6.0 is working fine?

Oh yes, absolutely, I have no problem logging in 4.6.0 and working inside.

I can confirm that, it happened to me too.
A very simple work around for me was(not much time to debug/dig more), logged into IceWM, open dolphin or any file manager, go to your home dir and rename .kde4 folder, log out and log back in to your normal desktop. I assume this is fresh installation for you.
OR, in terminal mode:

mv ~/.kde4 ~/.kde4_old

Best of luck.

Hmm, unfortunately that did not change anything for me.

How interesting though, a Failsafe KDE4.6.2 login does work perfectly!
So it’s something used for normal session that Failsafe session does not use.

Once you log in for the first time with failsafe you should be able to login with the normal “KDE Plasma Workspace” again which works for me.

Yes I tried that but it’s funny the KDE Plasma Workspace and KDE Plasma Workspace (Failsafe) both log me in as Failsafe session…
Then if I use Default as the session type, I get that KDM screen reset again.

I checked ~/.xsession-errors and there was something about INPUT_METHOD being invalid, not sure that’s the reason…

If you create a new user can you login with that?

Same result, it resets the KDM screen after a short blank screen, I never see the progress bar.

The .xsession-errors file of the new user I created is empty.

Looks like you should stick with 4.6.0

this post was the solution for me

This solved it for me, too. Thanks a lot!