11.4 Upgrade Chaos (cannot find /dev/sda2)

Edit: forget the ‘cannot find /dev/sda2’: that’s the error I get when I select the outdated 11.1 option from the startup selection, with the outdated kernel notated. I realize that my problem is probably seperate from that.

So a while back I upgraded from 11.1 to 11.3, and though I was skeptical at first of the upgrade option, it went swimmingly. Impressed by how that went, I recently went for the 11.4 upgrade. That’d turn out just as well, right? Hah. Ha ha. ha.

I’ve been using OpenSuSE for a while, but in terms of linux problem-fixing capability, I’m quite impaired. The most I’ve done is install my nVidia drivers from the command line, to be honest. I’m not grandma when it comes to computers, I build all of my own, but I figured I’d let you all know where I’m coming from.

I’ve got a number of problems, but the foremost problem is with startup. It gets to the startup option screen fine, and I’ll select “OpenSUSE 11.4 - ###current.kernel##” and I’ll get to the new 11.4 green-striped theme loading screen, and it’ll get halfway there before the black terminal comes up and, among fine looking outputs, these lines stand out:

Skipped features:                      boot.md boot.crypto boot.cycle
blogd cannot read from fd 0: blah blah

The rest looks normal, and it allows me to log in from the command line from there. Point is that there is no GUI, which makes me sad.

Now, if I go the route of the failsafe, I can login through a GUI and get to a KDE4 desktop, albiet with nv drivers, not my nice 3D accelerated ones, and internet that worked last night but not this morning. BUT, I’ll fix those problems when it comes time. My point is that I can get to a desktop when I go failsafe.

I have very little experience, and I’m sure there is plenty of information that you need to know before you can fix my problem. I’ll be glad to provide whatever information you need. Thanks in advance, I appreciate the help you guys provide.

Somebody reported a similar problem in the french forum (problème de carte video apres installation de suse 11.4) and says that when he selects “Failsafe” his system boots in graphic mode(!). Is that what you mean? If so, it is rather strange.

Installing the nvidia driver from repo is unproblematic, provided you have a network connection. I’ll do it like this:

su -l
zypper ar  ftp://download.nvidia.com/opensuse/11.4/ nvidia
zypper refresh
zypper in x11-video-nvidiaG02

assuming G02 is the driver you need. In doubt, post the output of

hwinfo --gfxcard | grep -i -e model -e driver

and we’ll tell you.

So I have a few questions. Did you load the nVIDIA driver, the hard way? Have you added in (or tried) the kernel load option **nomodeset **when you startup openSUSE. Have you tried the failsafe openSUSE load option (which also includes nomodeset)?

Thank You,

Also you should not boot in failsafe but in runlevel 3, as shown on this picture:


I had already installed nVidia drivers before I posted here (via one-click install). The only hiccup was a dependency notice, in which I opted to not install (or remove, I cannot remember) an older-looking option in favor of a newer one (I assumed the older one was the one I had installed years before). Nonetheless, I did as please_try_again recommended (remembering to use ‘rcxdm stop’ before using zypper), and the output was as I predicted: it told me that the driver was already installed and of the latest version, and there was nothing to do. (GeForce 6100 on an nForce 405 motherboard. Integrated :frowning: )

jdmcdaniel3: When I installed nVidia drivers most recently, I did so while in 11.4 failsafe mode. As noted above, I used the one-click install option from the OpenSUSE wiki. I have not modified any options when loading up OpenSUSE from the startup selection screen. The failsafe parameters are as follows

ide=nodma apm=off noresume nosmp maxcpu=0 edd=off powersaved=off nohz=off hires=off processor.maxcstate=1 x11failsafe vga=0x317

No edit button? I swear I saw one earlier.

Anyways, I happened upon this guide here, which I apologize for not noticing earlier. I’ll be venturing forth with those instructions, posting the results when I’m done.

x11failsafe … Hmm. I would have noticed if ever I would boot in failsafe from time to time.

So, is the nvidia driver used or not in X?

lsmod | grep nvidia


grep nvidia  /var/log/Xorg.0.log

And show us please what version you installed:

 rpm -qa | grep nvidia

I made it through step 4 in the procedure I mentioned above before noticing this interesting output in one of the sessions that ran parallel to the one that the loading screen dumps me into every time.

kernel:       21.127383 ] NVRM: API Mismatch: the client has the version 260.19.44 but
kernel:       21.127383 ] NVRM: this kernel module has the version 173.14.28 Please
kernel:       21.127383 ] NVRM: make sure that this kernel module and all NVIDIA driver
kernel:       21.127383 ] NVRM: components have the same version


lsmod | grep nvidia

nvidia       7097268   0

grep nvidia/var/log/Xorg.0.log

   20.463 ] (II) LoadModule: "nvidia"
   20.463 ] (II) Loading /usr/lib/xorg/modules/updates/drivers/nvidia_drv.so
   21.100 ] (II) Module nvidia: vendor="NVIDIA CORPORATION"
   21.127 ] (II) UnloadModule: "nvidia"

rpm -qa | grep nvidia


lots and lots of writing, but very accurate.

Why lots of writing? Can you not copy/paste these results?

Anyway it was helpful since I see a problem here:

You should not have this package installed. You don’t need it and since I don’t know if it hasn’t replaced one or the other file of the other driver, I would just deinstall both and reinstall G02 properly. Of course, you have to do that when the nvidia driver is not in use, meaning either in console (if you haven’t saved the packages, you’ll have to download them again and therefore you’ll need a network connection in console) or by switching first to the nouveau driver - the quickest way might be to rename /etc/X11/xorg.conf and boot with the option ‘nomodeset’).

Once you are either in console with network or in X with nouveau (and I assume, with network), type:

su -l
zypper rm x11-video-nvidiaG01 x11-video-nvidiaG02
zypper in  x11-video-nvidiaG02

Then reboot normally and tell us what you see.

Great success, thank you. I now have installed the following two packages, and regular startups launch me into a GUI login.


glxgears is suggesting that 3D acceleration is working fine, so I’m happy that the nVidia drivers are working. Thank you, this problem was the biggest of my worries. I now have to repair sound and get all of my old favorite applications back (Amarok 2.0 is bollocks, 1.4 was way better). Next on my agenda is dumping KDE4 for my old friend KDE3. Any suggestions before the thread is marked [SOLVED] and is retired?

Again, thank you. I really appreciate the help. (I have been traveling between adjacent rooms, working with two computers. I didn’t mind the writing)