11.4 Upgrade and audio

Audio does not work in the upgrade. The HDMI out does not work, and the USB mic in does not work (nor does it exist as a capture device in phonon settings. The video works fine).

None of these HDMI options make sound


What I have tried doing:

  • Delete phonondevicesrc
  • Reconfigure the sound device in yast2

I also do not understand as I thought I should only see “internal audio” when using pulseaudio?

Have you tried test sound?


Did sound work before with the 11.3 ?

Make sure in the multimedia settings of the systems settings that the HDA Nvidia (ALC888 analog) is at the top of every categories.

Second, did you set up audio as explained here : Multi-media and Restricted Format Installation Guide

There’s another tab on that info box - it displays the Phonon backend module. A couple of my machines started giving me Phonon errors saying my audio chip wasn’t working. This happened after a series of typical updates.

My Phonon backend was Gstreamer. I went into Yast Software Management and selected Delete on the Gstreamer backend and Yast automatically selected the Xine backend as its replacement. I let that install and it fixed ALL my audio problems on 4 Suse 11.3 installations.

I’m still trying to figure out the behaviour of 11.4 given the changes to audio handling between 11.3 and 11.4.

One application that I find has helped me a lot is the application ‘pavucontrol’. I recommend you install ‘pavucontrol’ and then run ‘pavucontrol’ and then try to play an application. Look at ‘pavucontrol’ and see if you can then tune the output so that audio plays.

I did find if I installed openSUSE-11.4 with a USB webcam or USB audio device plugged in, its configuration would not be predictable, and that once my USB webcam was configured as the default audio device (even thou it has no speaker - only a mic ! ). So there is a possibility of something being misconfigured.

OK, after a reboot, the analog does not work anymore, but the HDMI and the webcam work. So whatever, as long as it doesn’t change again after a reboot I’m ok.

So now all I need is to figure out how to get flash/skype/alsa programs to output through HDMI.

        type plug
        slave.pcm "hw:0,3"

this asoundrc no longer seems to work.

I don’t see how to edit posts.

I also tried removing the asoundrc and setting asound.conf to be

pcm.pulse {
    type pulse
ctl.pulse {
    type pulse
pcm.!default {
    type pulse
ctl.!default {
    type pulse

but still no luck. And it seems video players like smplayer do not emit sound (even kaffaine which i know uses the phonon settings). Only the “test sound” in the phonon config works and the login chime. Nothing else works. I also checked alsamixer to see if anything was low, but all was well.

edit: and now the hdmi audio does not work again. Pressing test says the device is not working. The chime works, and then no audio for anything. I switch to xine, and nothing works. Then I switch to gstreamer, and it starts working again.

I just don’t get this pulseaudio implementation openSUSE has going on… I have pulseaudio + kde working fine on my arch box. I would connect the hdmi, relog in, and the hdmi audio would work fine.

Since you upgraded (from 11.3?) and depending on how you upgraded, with soundcard configured and PulseAudio enabled in YaST, you could try adding a new userid to get fresh KDE settings and see what that does to phonon device configuration and KMix configuration.

IMHO, if you have pulseaudio installed, remove it and taboo it. It gives nothing but pain.

Try to replace your first code with this in the /etc/asound.conf (you have to create the asound.conf)

pcm.!default hdmi:NVidia
pcm:iec958 hdmi:NVidia

Add this to your /etc/pulse/default.pa

### Load HDMI 
load-module module-alsa-sink device=hw:0,3

In yast be sure to be a member of the audio group.

For your second code it’s dirty but kinda work but you won’t need it if the above is working already. In your /etc/asound-pulse.conf

# PulseAudio plugin configuration

# Let's create a virtual device "pulse" for mixer and PCM

pcm.pulse {
    type pulse

ctl.pulse {
    type pulse

# Let's make it the default!

pcm.!default {
    type plug
    slave.pcm {
    type hw 
        card 0
        device 3      

ctl.!default {
    type pulse

With this flash sound should work.

With your mplayer you have to write your device if not present in the mplayer alsa configuration.

Lastly you have to delete the .asoundrc in your /home/user
In my 11.4 asoundrc doesn’t seem to work instead /etc/asound.conf
You need the machine to re-start

Good luck

This post is to avoid confusion in my first post.
I’m kinda a slow typist due to my damaged right eye
and ran out of the ten minutes editing time.

The first and second procedure I gave will make the hdmi as your default sound
If the first procedure work you will not need to do the second procedure.
Both of those procedures should make the hdmi to have flash sound thru your browser
media plugin.

Good luck

Edit again.
I also notice that in 11.4 it tends to disable the IEC958 from time to time so have an eye for it in kmix or whatever mixer you are using it should be enable for the hdmi

If you wish to use pavucontrol with your hdmi have a look at my screenshot and atleast will give you a hint.
March Screenshot Thread

From what I see on this board and my current experience, there seems to be a bit of a mess with 11.4 and the way it handles sound now. I’ve upgraded two PC’s one with a clean install after a HDD failure and the other a 11.3 to 11.4 update via Zypper dup. Both have issues with sound and the mics not working reliably. Both often get a message to the effect “KDE has found some sound devices not working correctly and would like to remove them. Do you want KDE to forget these devices?” I’ll post separate threads for the problems but I think that the handling of sound has regressed in 11.4.

That error message has been with KDE since 11.2 if I recall correctly. Its NOT an 11.4 specific problem.

IMHO the correct answer is to “forget these devices”. My logic is typically this appears when one is reconfiguring the sound and one is being asked if KDE should keep the old obsolete configuration.

That was certainly my experience with that message on upgrading from 11.2 to 11.3. I agree with @oldcpu’s analysis and correct answer to avoid ending up with redundant device entries.

Yes, I’ve seen that occasionally before in 11.2 and 11.3. It just seemed to be popping up quite often in the 11.4 installations I had. What I didn’t really appreciate was that the correct answer was to forget the devices. I always selected the ‘no’ option thinking that forgetting them would break sound for some devices. Perhaps that’s why it kept popping up.

Anyway, on my dad’s PC (on which I installed 11.4 as his HDD failed on the weekend), I switched it back to using Xine and disabled Pulseaudio as it was too complicated trying to get the mic and sound working in the various apps and youtube / music streams within the browser. He just wants something that just works and the Pulse issues were causing a lot of frustration for him. Since I was the one that persuaded him to drop Windows for openSUSE I needed to get it working reliably which it now does and he’s happy again.

hey, thanks for your efforts.

I followed your instructions. The login chime works, but nothing more. None of the devices on the phonon settings make a sound (along with flash, mplayer, etc…)

I guess I should just try to disable pulse and revert to the alsa setup openSUSE had before. Is there good documentation on doing so?

That could be the S/PDIF are still mute
Did you add group audio in yast
Maybe try adding pulse and pulse-access
groups also.

Yeah, one SPDIF line was muted, so now I hear the sound in phonon config.

I can not get sound from flash & smplayer. Kaffeine crashes and says it cannot output audio. Skype does not work with selecting pulse. If I select the nvidia hdmi output directly, it works, but then no other audio works (so it works if it doesn’t go through pulse). For smplayer, i tried selecting different audio devices but nothing worked. “default device” plays sound in phonon, but I get no sound in skype selecting it.


It’s interesting at least there is sound now.
If you open phonon what do you see in device preferences
Can you post a screenshot.

With smplayer I want to see first your screenshot and tell me what creates a sound

Did you write your last post with pulse still enable and is it still hdmi as your default like what I had posted previously?
Please post some of the things of the developments that you did and will try to work on it with no gaurantee of success.
Good luck